aboutsummaryrefslogtreecommitdiff
From: Markus Koschany <apo@debian.org>
Date: Thu, 8 Mar 2018 17:49:24 +0100
Subject: pkg-config

Use pkg-config instead of the deprecated freetype-config command.

Bug-Debian: https://bugs.debian.org/892338
Forwarded: no
---
 src/Makefile.am | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/Makefile.am b/src/Makefile.am
index 3b7d0fe..0f5a5dd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -158,8 +158,8 @@ endif
 SDL_CFLAGS = `sdl-config --cflags`
 SDL_LIBS   = `sdl-config --libs`
 
-FREETYPE_CFLAGS = `freetype-config --cflags`
-FREETYPE_LIBS   = `freetype-config --libs`
+FREETYPE_CFLAGS = `pkg-config --cflags freetype2`
+FREETYPE_LIBS   = `pkg-config --libs freetype2`
 
 if USE_MATHSINGLE
 MATH_CFLAGS = -DVMATH_SINGLE_PRECISION
@@ -233,4 +233,4 @@ AM_CFLAGS = -Wall ${FREETYPE_CFLAGS} ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLA
             ${OPTIMIZATION_CFLAGS} ${USESSE_CFLAGS} ${USEWIN_CFLAGS} ${FASTMATH_CFLAGS} ${DEBIAN_CFLAGS} -lm
 
 AM_LDFLAGS = ${all_libraries} ${FREETYPE_LIBS} ${SDL_LIBS}
-LDADD = ${LDADD_FLAGS}
\ No newline at end of file
+LDADD = ${LDADD_FLAGS}
ed reduction.Jan Nieuwenhuizen * doc/images/gcc-core-mesboot0-graph.dot: New image, replacing * doc/images/gcc-mesboot0-bag-graph.dot: ... remove file. * doc/local.mk (DOT_FILES): Update for new image file. * doc/guix.texi (Reduced Binary Seed Bootstrap): Use it in updated description of further reduction of the trusted computing base. 2020-04-24doc: Ensure guix-daemon is built before creating guix-daemon.1.Marius Bakke * doc/local.mk ($(srcdir)/%D%/guix-daemon.1): Depend on guix-daemon$(EXEEXT) instead of its source code. 2020-04-23build: Don't build man pages when cross-compiling.Ludovic Courtès * configure.ac: Define 'CROSS_COMPILING' Automake conditional. * doc/local.mk (dist_man1_MANS): Wrap in "if !CROSS_COMPILING". 2020-04-23doc: Build more man pages.Ludovic Courtès * doc/local.mk (sub_commands_mans): Add guix-deploy.1, guix-time-machine.1, and guix-weather.1. 2020-04-16doc: Document building and installing from JSON files.Ricardo Wurmus * doc/guix.texi (Invoking guix package): Augment pargraphs for "--install-from-file". (Invoking guix build): Document building from JSON files. * doc/package-hello.json: New file. * doc/local.mk (EXTRA_DIST): Add it. 2020-02-17doc: Add German Cookbook translation.Florian Pelz * doc/local.mk (info_TEXINFOS): Add guix-cookbook.de.texi. (TRANSLATED_INFO): Add guix-cookbook.de.texi. * po/doc/guix-cookbook.de.po: New file. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add guix-cookbook.de.po. 2019-09-24Merge branch 'master' into core-updatesLudovic Courtès 2019-09-18doc: Add Guix Cookbook.Ricardo Wurmus * .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files. 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-13doc: Add Russian translation.Ludovic Courtès * doc/local.mk (info_TEXINFOS): Add guix.ru.texi. (TRANSLATED_INFO): Add {guix,contributing}.ru.texi. * po/doc/local.mk (DOC_PO_FILES): Add guix-manual.ru.po. * po/doc/guix-manual.ru.po: New file. 2019-05-04doc: Warn about missing entries in htmlxref.cnf.Ludovic Courtès * doc/local.mk (AM_MAKEINFOHTMLFLAGS): New variable. 2019-05-01Merge branch 'master' into core-updatesMarius Bakke 2019-04-24doc: Add Simplified Chinese translation.Ludovic Courtès * doc/local.mk (info_TEXINFOS): Add guix.zh_CN.texi. (TRANSLATED_INFO): Add guix.zh_CN.texi and contributing.zh_CN.texi. * po/doc/local.mk (DOC_PO_FILES): Add guix-manual.zh_CN.po. * doc/contributing.zh_CN.texi, doc/guix.zh_CN.texi: New files. 2019-04-23doc: Add Spanish translation.Miguel Ángel Arruga Vivas * doc/local.mk (info_TEXINFOS): Add guix.es.texi. (TRANSLATED_INFO): Add guix.es.texi and contributing.es.texi. * po/doc/guix-manual.es.po: New file. * po/doc/local.mk: Add guix-manual.es.po. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2019-03-14Merge branch 'staging' into core-updatesMarius Bakke 2019-03-13doc: Document the graphical installer some more.Ludovic Courtès * doc/guix.texi (Preparing for Installation): Rewrite to specify the two installation modes. (Guided Graphical Installation): New node. (Manual Installation): New node, with the former sections. (After System Installation): New node. * doc/images/installer-network.png, doc/images/installer-partitions.png, doc/images/installer-resume.png: New files. * doc/local.mk (dist_infoimage_DATA): Add them. 2018-12-11Merge branch 'master' into core-updatesMarius Bakke 2018-11-01doc: Add German translation.Julien Lepiller * doc/contributing.de.texi: New file. * doc/guix.de.texi: New file * doc/local.mk (TRANSLATED_INFO): Add them. (info_TEXINFOS): Add guix.de.texi. * po/doc/guix-manual.de.po: New file. * po/doc/local.mk (EXTRA_DIST): Add it. * doc/guix.texi: Document the German translation. 2018-09-23doc: Describe the Reduced Binary Seed bootstrap.Jan Nieuwenhuizen * doc/guix.texi (Reduced Binary Seed Bootstrap): New node. * doc/images/gcc-mesboot-bag-graph.dot: New file. * doc/local.mk (DOT_FILES): Add it.