aboutsummaryrefslogtreecommitdiff
Author: Danny Milosavljevic <dannym@scratchpost.org>
Date: 2023-06-12
License: expat

diff -ur orig/fluxbox-1.3.7/util/fluxbox-remote.cc fluxbox-1.3.7/util/fluxbox-remote.cc
--- orig/fluxbox-1.3.7/util/fluxbox-remote.cc	1970-01-01 01:00:01.000000000 +0100
+++ fluxbox-1.3.7/util/fluxbox-remote.cc	2023-05-01 01:11:52.225547895 +0200
@@ -73,7 +73,7 @@
     if (strcmp(cmd, "result") == 0) {
         XTextProperty text_prop;
         if (XGetTextProperty(disp, root, &text_prop, atom_result) != 0
-            && text_prop.value > 0
+            && text_prop.value != NULL
             && text_prop.nitems > 0) {
 
             printf("%s", text_prop.value);