aboutsummaryrefslogtreecommitdiff
diff --git a/pasp-mode.el b/pasp-mode.el
index 7f83645..5daf08e 100644
--- a/pasp-mode.el
+++ b/pasp-mode.el
@@ -199,9 +199,12 @@
 Argument ENCODING The current buffer which holds the problem encoding.
 Optional argument INSTANCE The problem instance which is solved by the encoding.
   If no instance it is assumed to be also in the encoding file."
-  (if 'instance
-      (concat pasp-clingo-path " " pasp-clingo-options " " encoding " " instance)
-    (concat pasp-clingo-path " " pasp-clingo-options " " encoding)))
+  (if instance
+      (concat pasp-clingo-path " " pasp-clingo-options " "
+              (shell-quote-argument encoding) " "
+              (shell-quote-argument instance))
+    (concat pasp-clingo-path " " pasp-clingo-options " "
+            (shell-quote-argument encoding))))
 
 (defun pasp-run-clingo (encoding &optional instance)
   "Run Clingo with some ASP input files.
NDY to pass the BTRFS-SUBVOLUME-FILE-NAME argument. Normalize the KEYMAP file as well. (eye-candy): Add a BTRFS-SUBVOLUME-FILE-NAME parameter, and use it, along with the NORMALIZE-FILE procedure, to normalize the FONT-FILE and IMAGE nested variables. Adjust doc. * gnu/bootloader/depthcharge.scm (depthcharge-configuration-file): Adapt. * gnu/bootloader/extlinux.scm (extlinux-configuration-file): Likewise. * gnu/system/file-systems.scm (btrfs-subvolume?) (btrfs-store-subvolume-file-name): New procedures. * gnu/system.scm (operating-system-bootcfg): Specify the Btrfs subvolume file name the store resides on to the `operating-system-bootcfg' procedure, using the new BTRFS-SUBVOLUME-FILE-NAME argument. * doc/guix.texi (File Systems): Add a Btrfs subsection to document the use of subvolumes. * gnu/tests/install.scm (%btrfs-root-on-subvolume-os) (%btrfs-root-on-subvolume-os-source) (%btrfs-root-on-subvolume-installation-script) (%test-btrfs-root-on-subvolume-os): New variables. Maxim Cournoyer