aboutsummaryrefslogtreecommitdiff
Do not capture the build-time value of $PATH in the 'emacs' executable
since this can noticeably increase the size of the closure of Emacs
with things like GCC being referenced.

Index: emacs-next/lisp/loadup.el
===================================================================
--- emacs-next.orig/lisp/loadup.el
+++ emacs-next/lisp/loadup.el
@@ -599,7 +599,8 @@ lost after dumping")))
                           ((equal dump-mode "dump") "emacs")
                           ((equal dump-mode "bootstrap") "emacs")
                           ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
-                          (t (error "Unrecognized dump mode %s" dump-mode)))))
+                          (t (error "Unrecognized dump mode %s" dump-mode))))
+            (exec-path nil))
         (when (and (featurep 'native-compile)
                    (equal dump-mode "pdump"))
           ;; Don't enable this before bootstrap is completed, as the