aboutsummaryrefslogtreecommitdiff
Do not capture the build-time value of $PATH in the 'emacs' executable
since this can noticeably increase the size of the closure of Emacs
with things like GCC being referenced.

--- a/lisp/loadup.el
+++ b/lisp/loadup.el
@@ -530,7 +530,8 @@ lost after dumping")))
                         ((equal dump-mode "dump") "emacs")
                         ((equal dump-mode "bootstrap") "emacs")
                         ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
-                        (t (error "Unrecognized dump mode %s" dump-mode)))))
+                        (t (error "Unrecognized dump mode %s" dump-mode))))
+          (exec-path nil))
       (when (and (featurep 'native-compile)
                  (equal dump-mode "pdump"))
         ;; Don't enable this before bootstrap is completed, as the
7:39 +0200'>2022-11-27gnu: vim: Update to 9.0.0954....Efraim Flashner 2022-11-17gnu: neovim: Update to 0.8.1....ギャラ 2022-11-05gnu: Add python-neovim-remote....ギャラ 2022-10-30gnu: vim: Update to 9.0.0820....Efraim Flashner 2022-10-30gnu: vim: Patch another '/bin/sh' shebang....Efraim Flashner 2022-10-11gnu: vim: Update to 9.0.0719....Efraim Flashner 2022-10-02gnu: neovim: Update to 0.8.0....ギャラ 2022-09-28gnu: vim: Update to 9.0.0594....Efraim Flashner 2022-09-27gnu: vim-nerdcommenter: Update to 2.6.0, use G-expressions....kiasoc5 2022-09-22gnu: vifm: Update to 0.12.1....Efraim Flashner 2022-09-20gnu: vim: Update to 9.0.0509....Efraim Flashner 2022-09-06gnu: Add neovim-packer....gyara