aboutsummaryrefslogtreecommitdiff
# Source: <https://sources.debian.org/patches/docbook-utils/0.6.14-4/bug_394511.patch/>

Description: docbook2man should translate the NAME section according to the REFENTRY's lang attribute
 Currently, docbook2man translates the NAME section according to the lang
 attribute provided to the REFNAMEDIV tag.
 When a lang attribute is specified in the REFENTRY tag and no lang
 attribute is specified with the REFNAMEDIV, the lang attribute of the
 REFENTRY should be used.
Author: Nicolas François <nicolas.francois@centraliens.net>
Forwarded: not-needed
Bug-Debian: http://bugs.debian.org/394511

Index: docbook-utils-0.6.14/helpers/docbook2man-spec.pl
===================================================================
--- docbook-utils-0.6.14.orig/helpers/docbook2man-spec.pl	2012-05-09 18:55:53.276783163 +0200
+++ docbook-utils-0.6.14/helpers/docbook2man-spec.pl	2012-05-09 18:58:04.792778418 +0200
@@ -359,11 +359,14 @@
 # NAME section
 man_sgml('<REFNAMEDIV>', sub {
 	my %words = qw( fr NOM es NOMBRE de NAME );
-	if (defined($_[0]->attribute('LANG')->value)) {
-	my $id = $_[0]->attribute('LANG')->value;
-	my $ad = $words{$id};
-	output("\n.SH $ad\n");}
-	else {output("\n.SH NAME\n");}
+	# Use the REFNAMEDIV's lang attribute, and default to the
+	# REFENTRY's lang attribute.
+	my $lang = $_[0]->attribute('LANG')->value;
+	$lang = $manpage_lang unless defined $lang;
+	if (defined($lang) and defined $words{lc($lang)}) {
+		my $ad = $words{lc($lang)};
+		output("\n.SH $ad\n");}
+	else {	output("\n.SH NAME\n");}
 });
 
 sgml('<REFNAME>', \&save_cdata);