aboutsummaryrefslogtreecommitdiff
Fix esan compilation against glibc 2.26:

  /tmp/guix-build-clang-runtime-3.9.1.drv-0/compiler-rt-3.9.1.src/lib/esan/esan_sideline_linux.cpp: In static member function ‘static int __esan::SidelineThread::runSideline(void*)’:
  /tmp/guix-build-clang-runtime-3.9.1.drv-0/compiler-rt-3.9.1.src/lib/esan/esan_sideline_linux.cpp:73:22: error: aggregate ‘__esan::SidelineThread::runSideline(void*)::sigaltstack SigAltStack’ has incomplete type and cannot be defined

Patch from <https://github.com/google/sanitizers/issues/822>.

index d04f5909d..bc272dfe4 100644
--- a/lib/esan/esan_sideline_linux.cpp
+++ b/lib/esan/esan_sideline_linux.cpp
@@ -70,7 +70,7 @@ int SidelineThread::runSideline(void *Arg) {
 
   // Set up a signal handler on an alternate stack for safety.
   InternalScopedBuffer<char> StackMap(SigAltStackSize);
-  struct sigaltstack SigAltStack;
+  stack_t SigAltStack;
   SigAltStack.ss_sp = StackMap.data();
   SigAltStack.ss_size = SigAltStackSize;
   SigAltStack.ss_flags = 0;
fault for tempel to use quoted strings is rather off. Thus, let the placeholder reflect actual usage. * etc/snippets/tempel/scheme-mode (git-reference...)[commit]: Use field name as placeholder and don't quote value. (svn-reference..., bzr-reference...)[revision]: Likewise. (hg-reference...)[changeset]: Likewise. Liliana Marie Prikler 2023-02-19etc: Add a news entry snippet....* etc/snippets/yas/scheme-mode/guix-news-entry: New file. Maxim Cournoyer 2022-12-27snippets: Remove unwanted git-commit-mode invocation....We only need to check if git-commit-mode is t, not enable it in all text-mode buffers. * etc/snippets/tempel/text-mode: Remove unwanted git-commit-mode invocation. Andrew Tropin 2022-11-28snippets: yas: Add snippets for vc.el...* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page: New file Signed-off-by: Ludovic Courtès <ludo@gnu.org> Morgan Smith 2022-10-22snippets: Harden for review activity....When reviewing patches, whose commit logs don't follow the structure outlined in “Submitting Patches”, a reviewer might be tempted to use snippets to rewrite them. This makes it so that their attempt, while not immediately succeeding, isn't completely thwarted. * etc/snippets/tempel/text-mode (add\ , remove\ , rename\ , update\ ) (addcl\ , https\ ): Use an empty "p" field if (car (magit-staged-files)) fails. Liliana Marie Prikler 2022-10-06snippets: Fix move....The current move is never correct. It flip-flops between car and cadr for the destination. Since the position of the destination is not actually a fixed point in the list of changes, use a more robust method of inferring it. * etc/snippets/tempel/text-mode (move\ ): Infer source and destination from washed diffs. Process new module before destination. Liliana Marie Prikler 2022-10-06snippets: tempel: Reformat....This makes it so that ‘indent-region’ and ‘delete-trailing-whitespace’ do not change the file. * etc/snippets/tempel/text-mode: Reformat. Liliana Marie Prikler 2022-10-06snippets: tempel: Fix calls to mapconcat....* etc/snippets/tempel/text-mode (update\ ,https\ ): Add "\n" as separator argument to mapconcat. Liliana Marie Prikler 2022-09-26etc: Add tempel snippet move....* etc/snippets/tempel/text-mode (move\): New entry. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nicolas Graves 2022-08-30etc: Update yasnippet build system list....* etc/snippets/yas/scheme-mode/guix-package (build-system): Add chicken-build-system, minetest-build-system, rebar-build-system and renpy-build-system. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Nicolas Graves 2022-08-30etc: Add tempel snippet for :phases....* etc/snippets/tempel/scheme-mode (:phases, add-before\ , add-after\ ) (replace\ ): New snippets. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Nicolas Graves 2022-08-30etc: Add tempel snippets....* etc/snippets/tempel/scheme-mode: New file. * etc/snippets/tempel/text-mode: New file. * etc/snippets/scheme-mode: Moved from here... * etc/snippets/yas/scheme-mode: ... to here. * etc/snippets/text-mode: Moved from here... * etc/snippets/yas/text-mode: ... to here. * doc/contributing.texi ("The Perfect Setup"): Adjust yasnippet setup accordingly. Add tempel setup. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Nicolas Graves