aboutsummaryrefslogtreecommitdiff
Fix esan compilation against glibc 2.26:

  /tmp/guix-build-clang-runtime-3.9.1.drv-0/compiler-rt-3.9.1.src/lib/esan/esan_sideline_linux.cpp: In static member function ‘static int __esan::SidelineThread::runSideline(void*)’:
  /tmp/guix-build-clang-runtime-3.9.1.drv-0/compiler-rt-3.9.1.src/lib/esan/esan_sideline_linux.cpp:73:22: error: aggregate ‘__esan::SidelineThread::runSideline(void*)::sigaltstack SigAltStack’ has incomplete type and cannot be defined

Patch from <https://github.com/google/sanitizers/issues/822>.

index d04f5909d..bc272dfe4 100644
--- a/lib/esan/esan_sideline_linux.cpp
+++ b/lib/esan/esan_sideline_linux.cpp
@@ -70,7 +70,7 @@ int SidelineThread::runSideline(void *Arg) {
 
   // Set up a signal handler on an alternate stack for safety.
   InternalScopedBuffer<char> StackMap(SigAltStackSize);
-  struct sigaltstack SigAltStack;
+  stack_t SigAltStack;
   SigAltStack.ss_sp = StackMap.data();
   SigAltStack.ss_size = SigAltStackSize;
   SigAltStack.ss_flags = 0;
f8391a42c803978e8f6a1cb045b7c52531acb'>gnu: privoxy: Update to 3.0.28....Tobias Geerinckx-Rice 2018-12-12gnu: onionshare: Update to 1.3.1....Eric Bavier 2018-11-29gnu: onionshare: Fetch sources from git....Ricardo Wurmus 2018-11-11gnu: privoxy: Remove custom bootstrap phase....Ricardo Wurmus 2018-11-02gnu: tor: Update to 0.3.4.9....Tobias Geerinckx-Rice 2018-09-10gnu: tor: Update to 0.3.4.8....Tobias Geerinckx-Rice 2018-07-15gnu: tor.scm: Fix copyright line....Efraim Flashner 2018-07-15gnu: tor: Update to 0.3.3.9....Efraim Flashner 2018-06-22gnu: nyx: Show header stats....Tobias Geerinckx-Rice 2018-06-22gnu: nyx: Update to 2.0.4....Tobias Geerinckx-Rice 2018-06-22gnu: nyx: Update home page....Tobias Geerinckx-Rice 2018-06-22gnu: nyx: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-12gnu: tor: Update to 0.3.3.7....Tobias Geerinckx-Rice 2018-05-23gnu: tor: Update to 0.3.3.6 [security fixes]....Tobias Geerinckx-Rice