aboutsummaryrefslogtreecommitdiff
Patch based on changes from
https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208

diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py
index 5ea2ca1..d7bc287 100755
--- a/lib/sanitizer_common/scripts/gen_dynamic_list.py
+++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py
@@ -100,7 +100,7 @@ def main(argv):
     print('global:')
   result.sort()
   for f in result:
-    print('  ' + f.encode('utf-8') + ';')
+    print(u'  %s;' % f)
   if args.version_list:
     print('local:')
     print('  *;')
/xen-docs-use-predictable-ordering.patch?id=7937c8827b8d23347a3159b4696335bd19fc17aa&showmsg=1'>Expand)Author 2023-09-24gnu: xen: Build reproducibly...* gnu/packages/virtualization.scm (xen)[source]: Add patches. [arguments]: Add a new 'remove-cruft phase. * gnu/packages/patches/xen-docs-use-predictable-ordering.patch, * gnu/packages/patches/xen-remove-config.gz-timestamp.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them both. Tobias Geerinckx-Rice