aboutsummaryrefslogtreecommitdiff
diff --git a/hunt/hunt/playit.c b/hunt/hunt/playit.c
index 9acf86e..881a4e7 100644
--- a/hunt/hunt/playit.c
+++ b/hunt/hunt/playit.c
@@ -114,7 +114,7 @@ playit()
		bad_con();
		/* NOTREACHED */
	}
-	if (ntohl(version) != (unsigned long)HUNT_VERSION) {
+	if (ntohl(version) != (uint32_t)HUNT_VERSION) {
		bad_ver();
		/* NOTREACHED */
	}
@@ -649,7 +649,7 @@ do_message()
		bad_con();
		/* NOTREACHED */
	}
-	if (ntohl(version) != (unsigned long)HUNT_VERSION) {
+	if (ntohl(version) != (uint32_t)HUNT_VERSION) {
		bad_ver();
		/* NOTREACHED */
	}
>Commit message (Expand)Author 08f4003dedd8dfe99327c15668ca1a43ebd93b'>tests: Fix malformed JSON....Guile-JSON 4.3.2 would parse in spite of these typos, but 4.4.1 is stricter. * tests/swh.scm (%directory-entries): Add missing comma. * tests/cve-sample.json: Likewise. Ludovic Courtès 2020-02-27swh: Adjust 'origin' test....This is a followup to 3d2f29382de2d0ee852745cc002dfe2b5d22e1c2. * tests/swh.scm (%origin): Remove "id". ("lookup-origin"): Remove use of 'origin-id'. Ludovic Courtès