aboutsummaryrefslogtreecommitdiff
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Wed, 3 Oct 2018 23:30:42 +0200
Subject: [PATCH] bastet: Change source of unordered_set.

This allows building bastet 0.43.2 with boost >=1.66.
It was backported verbatim from the upstream master branch.

From 0e03f8d4d6bc6949cf1c447e632ce0d1b98c4be1 Mon Sep 17 00:00:00 2001
From: Federico Poloni <fpoloni@di.unipi.it>
Date: Wed, 4 Oct 2017 19:35:01 +0200
Subject: [PATCH] Changed source of unordered_set (should hopefully fix #6
 without reopening #1)

---
 BastetBlockChooser.hpp | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/BastetBlockChooser.hpp b/BastetBlockChooser.hpp
index 992e556..7ee3b7c 100644
--- a/BastetBlockChooser.hpp
+++ b/BastetBlockChooser.hpp
@@ -23,8 +23,7 @@
 
 #include "Well.hpp"
 
-#include <boost/tr1/tr1/unordered_set>
-#include <set>
+#include <boost/unordered_set.hpp>
 #include <boost/functional/hash.hpp>
 
 namespace Bastet{
@@ -75,7 +74,7 @@ namespace Bastet{
   public:
     Searcher(BlockType b, const Well *well, Vertex v, WellVisitor *visitor);
   private:
-    std::tr1::unordered_set<Vertex> _visited;
+    boost::unordered_set<Vertex> _visited;
     //std::set<Vertex> _visited; ^^ the above is more efficient, we need to do many inserts
     BlockType _block;
     const Well *_well;
nu/packages/cmake.scm?id=8bd0632a02c84ff6ca4e3fc3708657633ec10f08'>gnu: cmake-shared: Update to 1.1.0-32....* gnu/packages/cmake.scm (cmake-shared): Update to 1.1.0-32. [source]: Add snippet to remove bundled sources. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at> Raghav Gururajan 2021-02-03Merge branch 'master' into core-updatesChristopher Baines 2021-01-31gnu: Add cmake-shared....* gnu/packages/cmake.scm (cmake-shared): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at> Raghav Gururajan 2020-12-30gnu: cmake-bootstrap: Update to 3.19.2....* gnu/packages/cmake.scm (%preserved-third-party-files): Repatriate from the cmake package definition. (cmake-bootstrap): Update to 3.19.2. (cmake): Remove the version and source field overrides. Maxim Cournoyer 2020-12-26gnu: cmake: Update to 3.19.2....* gnu/packages/cmake.scm (cmake): Update to 3.19.2. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Greg Hogan 2020-12-17gnu: Remove 'curl-minimal'....* gnu/packages/curl.scm (curl-minimal): Deprecate variable. * gnu/packages/games.scm (yamagi-quake2)[inputs]: Replace CURL-MINIMAL with CURL. * gnu/packages/cmake.scm (cmake-bootstrap)[inputs]: Likewise. (cmake-minimal)[inputs]: Don't override the "curl" input. Marius Bakke 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-26gnu: cmake: Update to 3.19.1....* gnu/packages/cmake.scm (cmake): Update to 3.19.1. Tobias Geerinckx-Rice 2020-11-24gnu: cmake: Update to 3.19.0....* gnu/packages/cmake.scm (cmake): Update to 3.19.0. [source]: Modify inherited source to adjust the hash as well as the snippet so that the "Utilities/cm3p" sub-directory is preserved. [phases]{patch-bin-sh, check}: Temporarily overrides until the next rebuild cycle. Maxim Cournoyer 2020-11-19gnu: cmake-minimal: Remove some documentation....These files are still available in the user-facing cmake package. * gnu/packages/cmake.scm (cmake-minimal)[arguments]: Add phase to remove help documentation. Efraim Flashner 2020-11-19gnu: cmake: Only build ccmake on user facing cmake....* gnu/packages/cmake.scm (cmake-bootstrap)[inputs]: Remove ncurses. (cmake)[inputs]: Add ncurses. Efraim Flashner 2020-11-08gnu: cmake: Update source URI....* gnu/packages/cmake.scm (cmake-bootstrap)[source]: Update to new source URI. Efraim Flashner