aboutsummaryrefslogtreecommitdiff
Patch by Andreas Enge to force installation of libraries into lib
independently of the architecture, instead of lib32 or lib64.
On x86_64, the C library path coded in CMAKE_C_IMPLICIT_LINK_DIRECTORIES 
contains a library (jack) installed into lib64, which forces lib64
for avidemux with the original code.

diff -u -r avidemux_2.6.8.orig/cmake/admInstallDir.cmake avidemux_2.6.8/cmake/admInstallDir.cmake
--- avidemux_2.6.8.orig/cmake/admInstallDir.cmake	2014-03-12 07:15:23.000000000 +0100
+++ avidemux_2.6.8/cmake/admInstallDir.cmake	2015-07-26 14:31:10.418459984 +0200
@@ -16,13 +16,7 @@
                 MESSAGE(STATUS "No install dir provided, using /usr/local")
         ENDIF(NOT AVIDEMUX_INSTALL_DIR )
         SET(AVIDEMUX_BIN_DIR ${AVIDEMUX_INSTALL_DIR}/bin)
-        IF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib64)
-        ELSEIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib32([; ]|$)")
-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib32)
-        ELSE(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
-        ENDIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
+        SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
         SET(AVIDEMUX_LIB_DIR ${AVIDEMUX_INSTALL_DIR}/${AVIDEMUX_RELATIVE_LIB_DIR})
 ENDIF(WIN32)
 SET(AVIDEMUX_INCLUDE_DIR ${AVIDEMUX_INSTALL_DIR}/include)
path to Guile 3.0 directories....Ricardo Wurmus 2022-11-09machine/digital-ocean: Use static-networking-service-type....Ricardo Wurmus 2022-11-09machine/digital-ocean: Use nightly Guix....Ricardo Wurmus 2022-10-17guix: Fix typos....Julien Lepiller 2022-09-26machine: ssh: Parameterize '%current-system' early on....Ludovic Courtès 2022-09-04Fix misspelling of GUIX_DIGITAL_OCEAN_TOKEN....Matthew James Kraai 2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer 2022-01-16machine: ssh: Add 'safety-checks?' field....Ludovic Courtès 2022-01-09machine: ssh: Open a single SSH session per machine....Ludovic Courtès 2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer 2021-06-20services: openssh: Replace 'without-password' by 'prohibit-password'....Brice Waegeneire 2021-06-03machine: ssh: Respect calling convention for monadic procedures....Ludovic Courtès 2021-06-01machine: ssh: Gracefully handle failure of the effectful bits....Ludovic Courtès 2021-02-25machine: ssh: Use 'formatted-message'....Ludovic Courtès 2021-01-04machine: ssh: Do not import the host (guix config), really....Ludovic Courtès 2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas