aboutsummaryrefslogtreecommitdiff
Based on the upstream fix for the java8 compilation issue.
Simplified patch.
Upstream version of patch does not work with this source tree.

The issue is that in java8 it is an error to pass null to
removeAll. Results in null pointer exception. java7
behaviour was to return the list unmodified.

From 43867d50c05d1c06ab7220eb974a8874ae10c308 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= <boskovits@gmail.com>
Date: Fri, 5 Jan 2018 19:08:24 +0100
Subject: [PATCH] Fix java8 complilation error.

---
 tool/src/main/java/org/antlr/tool/CompositeGrammar.java | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java
index f34ea73..63740a6 100644
--- a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java
+++ b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java
@@ -226,7 +226,9 @@ public class CompositeGrammar {
 	public List<Grammar> getIndirectDelegates(Grammar g) {
 		List<Grammar> direct = getDirectDelegates(g);
 		List<Grammar> delegates = getDelegates(g);
-		delegates.removeAll(direct);
+		if(direct != null) {
+		        delegates.removeAll(direct);
+		}
 		return delegates;
 	}
 
-- 
2.15.1

cent Prat 2023-05-23gnu: Add python-vulture....* gnu/packages/python-check.scm (python-vulture): New variable. Signed-off-by: jgart <jgart@dismail.de> Antero Mejr 2023-05-14gnu: python-pytest-httpx: Update to 0.22.0, fix build....* gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.22.0. [build-system]: Switch to pyproject-build-system. [arguments]: Do not override the 'check phase. Signed-off-by: Vinicius Monego <monego@posteo.net> Sharlatan Hellseher 2023-05-11Revert "gnu: Add python-pytest-enabler."...This reverts commit 0a8c46e89f095a9ec3632d43920ac3cce49f16d5. An older version of python-pytest-enabler already exists in (gnu packages check). Ricardo Wurmus 2023-05-11gnu: Add python-pytest-enabler....* gnu/packages/python-check.scm (python-pytest-enabler): New variable. Ricardo Wurmus 2023-05-08gnu: python-pytest-mpl: Update to 0.16.1....* gnu/packages/python-check.scm (python-pytest-mpl): Update to 0.16.1. [build-system]: Use pyproject-build-system. [arguments]<phases>: Simplify phases by removing redundant modification and use <test-flags> instead. [propagated-inputs]: Add python-jinja2, python-packaging. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-08gnu: python-pytest-arraydiff: Update to 0.5.0....* gnu/packages/python-check.scm (python-pytest-arraydiff): Update to 0.5.0. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Remove python-six. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-08gnu: python-pytest-remotedata: Update to 0.4.0....* gnu/packages/python-check.scm (python-pytest-remotedata): Update to 0.4.0. [build-system]: Use pyproject-build-system. [arguments]<phases>: Simplify by removing not required phase modification and use <test-flags> instead. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Delete python-six, add python-packaging. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-08gnu: python-pytest-astropy: Simplify package....* gnu/package/python-check.scm (python-pytest-astropy): Simplify package. [arguments]<phases>: Remove remove-requirement phase. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-08gnu: python-pytest-filter-subpackage: Update to 0.1.2....* gnu/packages/python-check.scm (python-pytest-filter-subpackage): Update to 0.1.2. [build-system]: Use pyproject-build-system. [arguments]: Drop no more required phases. [native-inputs]: Add python-setuptools-scm. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-08gnu: python-pytest-doctestplus: Update to 0.12.1....* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to 0.12.1. [build-system]: Use pyproject-build-system. [arguments]<phases>: Remove modify-phases and add test-flags option instead. [native-inputs]: Add python-numpy. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Sharlatan Hellseher 2023-05-07gnu: Add python-memory-profiler....* gnu/packages/python-check.scm (python-memory-profiler): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-05-05gnu: python-atpublic: Update to 3.1.1....* gnu/packages/python-check.scm (python-atpublic): Update to 3.1.1. [build-system]: Switch to pyproject-build-system. [arguments]: Remove #:phases, override build backend. [native-inputs]: Replace nose2 with pytest, add python-pdm-backend, python-sybil and python-pytest-cov. Lars-Dominik Braun 2023-04-25Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-25Revert "gnu: python-pytest-trio: Update to 0.8.0."...Not compatible with python-trio 0.8. This reverts commit 27a4bfbd07022ebabc352a419c7588fcfc881d88. Lars-Dominik Braun 2023-04-19gnu: python-pytest-trio: Update to 0.8.0....* gnu/packages/python-check.scm (python-pytest-trio): Update to 0.8.0. [arguments]: New relax-requirements phase. Delete extraneous add-installed-pythonpath call. Disable two new tests. Maxim Cournoyer 2023-04-19gnu: python-pytest-benchmark: Update to 4.0.0....* gnu/packages/python-check.scm (python-pytest-benchmark): Update to 4.0.0. Maxim Cournoyer 2023-04-17gnu: python-pytest-trio: Update to 0.8.0....* gnu/packages/python-check.scm (python-pytest-trio): Update to 0.8.0. [arguments]: New relax-requirements phase. Delete extraneous add-installed-pythonpath call. Disable two new tests. Reported-by: jgart <jgart@dismail.de> Maxim Cournoyer 2023-04-14gnu: python-pytest-7.1: Deprecate package....The source was adjusted using the following command: $ git grep -rl python-pytest-7.1 | xargs sed -i 's/python-pytest-7.1/python-pytest/g' * gnu/packages/check.scm (python-pytest-7.1): Delete variable. Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-14gnu: python-pytest-subtests: Update to 0.10.0....* gnu/packages/python-check.scm (python-pytest-subtests): Update to 0.10.0. [native-inputs]: Replace python-pytest with python-pytest-7.1. Maxim Cournoyer 2023-04-11gnu: python-pytest-subtests: Update to 0.10.0....* gnu/packages/python-check.scm (python-pytest-subtests): Update to 0.10.0. [native-inputs]: Replace python-pytest with python-pytest-7.1. Maxim Cournoyer