aboutsummaryrefslogtreecommitdiff
This patch removes the hard coded temporary directory (which might not exist on the system)
and replaces it using the Perl preferred method.
--- aegis-4.24/script/aebisect.in	2008-03-14 07:19:27.000000000 +0100
+++ aegis-4.24/script/aebisect.in	2014-01-26 11:03:31.000000000 +0100
@@ -34,7 +34,8 @@
 # @configure_input@
 #
 # Configure additions?
-my $TmpDir   = "/var/tmp";
+use File::Temp qw/ tempdir /;
+my $TmpDir   = tempdir();
 my $ProgramName = "aebisect";
 
 require 5.004;
-12-12 20:24:43 +0100'>2020-12-12gnu: renpy: Use system fribidi and drop generated sources....* gnu/packages/patches/renpy-use-system-fribidi.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it here. * gnu/packages/game-development.scm (renpy)[source]<patches> Use it here. <modules>: Add (guix build utils). <snippet>: Drop generated sources and fribidi sources. (arguments)[phases]: Add fix-include-paths. (inputs): Add fribidi. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Leo Prikler 2020-12-12gnu: pygame-sdl2-for-renpy: Drop generated sources in snippet....* gnu/packages/game-development.scm (pygame-sdl2-for-renpy)[source]<modules>: Add (guix build utils). [#:phases]<drop-generated-files>: Move from here... [source]<snippet>: ... to here. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Leo Prikler 2020-11-23gnu: guile-chickadee: Use Guile 3.0....* gnu/packages/game-development.scm (guile-chickadee): Change Guile inputs to use 3.0 package variants. David Thompson 2020-11-23gnu: guile-chickadee: Update to 0.6.0.David Thompson 2020-11-23gnu: Deprecate guile3.0-chickadee.David Thompson 2020-11-20gnu: tiled: Update to 1.4.3....* gnu/packages/game-development.scm (tiled): Update to 1.4.3. Tobias Geerinckx-Rice 2020-11-18gnu: bennu-game-development: Update to 353....* gnu/packages/game-development.scm (bennu-game-development): Update to 353. Pierre Neidhardt 2020-11-15gnu: tiled: Update to 1.4.2.David Thompson 2020-10-15gnu: Add tsukundere....* gnu/packages/game-development.scm (tsukundere): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Leo Prikler 2020-10-04gnu: godot: Update to 3.2.3....* gnu/packages/game-development.scm (godot): Update to 3.2.3. Tobias Geerinckx-Rice 2020-10-01gnu: nml: Update to 0.5.3....* gnu/packages/game-development.scm (nml): Update to 0.5.3. Tobias Geerinckx-Rice 2020-09-15gnu: surgescript: Update to 0.5.4.4....* gnu/packages/game-development.scm (surgescript): Update to 0.5.4.4. Tobias Geerinckx-Rice 2020-09-09gnu: python-xsge: Update to 2020.09.07....* gnu/packages/game-development.scm (python-xsge): Update to 2020.09.07. [native-inputs]: Add unzip. [propagated-inputs]: Remove python-game, python-six, and python-tmx. Use python-sge instead of python-sge-pygame. [home-page]: Update URL. (python2-xsge): Remove unsupported Python 2 variant. Kei Kebreau 2020-09-09gnu: python-sge: Update to 1.7....* gnu/packages/game-development.scm (python-sge-pygame): Define as deprecated alias for python-sge. (python2-sge-pygame): Remove unsupported Python 2 variant. (python-sge)[source]: Use pypi-uri. [propagated-inputs]: Remove python-six. [home-page]: Update URL. Kei Kebreau 2020-08-06gnu: ode: Update to 0.16.2....* gnu/packages/game-development.scm (ode): Update to 0.16.2. Nicolas Goaziou