aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ots)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages xml)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ots
  (package
    (name "ots")
    (version "0.5.0")
    (source
     (origin
       (method url-fetch)
       ;; libots seems to have left sourceforge and taken their release
       ;; tarballs with them
       (uri (list (string-append "mirror://debian/pool/main/o/ots/ots_"
                                 version ".orig.tar.gz")
                  (string-append "mirror://sourceforge/libots/libots/"
                                 name "-" version "/" name "-" version
                                 ".tar.gz")))
       (sha256
        (base32 "0dz1ccd7ymzk4swz1aly4im0k3pascnshmgg1whd2rk14li8v47a"))
       (patches (search-patches "ots-no-include-missing-file.patch"))))

    (build-system gnu-build-system)
    (arguments
     ;; With '-jN', the rule to build the 'ots' command can be triggered
     ;; before libots-1.la has been built.
     '(#:parallel-build? #f

       #:phases
       (modify-phases %standard-phases
         (add-after 'configure 'set-shared-lib-extension
           (lambda _
             ;; For some reason, the 'libtool' script (from Libtool
             ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
             ;; 'shrext' for the shared library file name extension.
             ;; This leads to the creation of 'libots-1' instead of
             ;; 'libots-1.so'.  Fix that.
             (substitute* "libtool"
               (("shrext_cmds") "shrext"))
             #t)))))
    (inputs
      (list glib popt libxml2 zlib))
    (native-inputs
      `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)))
    (synopsis "Tool for summarizing texts")
    (description
      "The Open Text Summarizer is a library and command-line tool for
summarizing texts.  The program reads a text and decides which sentences are
important and which are not.  OTS will create a short summary or will
highlight the main ideas in the text.

The program can either print the summarized text as plain text or HTML.  If in
HTML, the important sentences are highlighted.

The program is multi lingual and works with UTF-8 encoding.")
    (home-page "http://libots.sourceforge.net/")
    (license license:gpl2+)))
3-17gnu: Use autoconf instead of autoconf-wrapper when possible....This should reduce confusion on when to use the "autoconf" package and when to use "autoconf-wrapper" instead in package definitions. Fixes <https://bugs.gnu.org/46564>. * gnu/packages/autotools.scm (autoconf-wrapper): advise to use the "autoconf" package instead where possible. * gnu/packages/game-development.scm (tsukundere)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/gimp.scm (glimpse)[native-inputs]: likewise. (gimp-resynthesizer)[native-inputs]: add comment on why "autoconf-wrapper" is used. * gnu/packages/gnunet.scm (gnunet)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/gnupg.scm (signing-party)[native-inputs]: add comment on why "autoconf-wrapper" is used. * gnu/packages/guile-xyz.scm (guile-bash,guile-filesystem,guile-ics,guile-udev)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/libevent.scm (libuv)[native-inputs]: indicates "autoconf-wrapper" needs to be replaced with "autoconf" on core-updates. * gnu/packages/logging.scm (glog)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/mail.scm (libetpan)[native-inputs]: likewise. * gnu/packages/mate.scm (mate-icon-theme-faenza)[native-inputs]: add comment on why "autoconf-wrapper" is used. (mate-screensaver)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/package-management.scm (guix)[native-inputs]: likewise. * gnu/packages/sawfish.scm (librep)[native-inputs]: likewise. * gnu/packages/video.scm (motion)[native-inputs]: likewise. * gnu/packages/zile.scm (zile)[native-inputs]: likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-03-06gnu: surgescript: Do not want static libraries....* gnu/packages/game-development.scm (surgescript)[arguments]: Add "-DWANT_STATIC=NO" to #:configure-flags. Tobias Geerinckx-Rice 2021-03-06gnu: surgescript: Update to 0.5.5....* gnu/packages/game-development.scm (surgescript): Update to 0.5.5. Tobias Geerinckx-Rice 2021-03-06Merge branch 'master' into core-updatesChristopher Baines 2021-02-28gnu: python2-pygame-sdl2: Use HTTPS home page URI....* gnu/packages/game-development.scm (python2-pygame-sdl2)[home-page]: Use HTTPS URI. Nicolas Goaziou 2021-02-11Merge branch 'master' into core-updatesDanny Milosavljevic 2021-02-07gnu: python2-renpy: Update to 7.4.2....* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.2. [native-inputs]: Add gcc-8. Leo Prikler 2021-02-07gnu: python2-pygame-sdl2: Update to renpy-version 7.4.2....* gnu/packages/game-development.scm (python2-pygame-sdl2): Update to renpy-version 7.4.2. Leo Prikler 2021-02-07gnu: Minor whitespace cleanup....* gnu/packages/game-development.scm: Update copyright line for previous renpy commits. (love-nuklear): Strip space at the end of the line. Leo Prikler 2021-02-07gnu: python2-renpy: Update to 7.4.0....* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.0. (inputs): Move python2-pygame... (propagated-inputs): ... to here. Add python2-future. (#:phases)[install]: Infer python version from input. * gnu/packages/patches/renpy-use-system-fribidi.patch: Update to renpy 7.4.0. python2-renpy: propagate python inputs Leo Prikler 2021-02-07gnu: python2-pygame-sdl2: Update to renpy-version 7.4.0....* gnu/packages/game-development.scm (python2-pygame-sdl2): Update to renpy-version 7.4.0. Leo Prikler 2021-02-03Merge branch 'master' into core-updatesChristopher Baines 2021-02-01gnu: Adjust package collection to Wrap using GUIX_PYTHONPATH....This change was automated using: $ git ls-files | grep .scm | \ xargs sed 's/(getenv "PYTHONPATH")/(getenv "GUIX_PYTHONPATH")/' -i $ git ls-files | grep .scm | \ xargs sed 's/`("PYTHONPATH"/`("GUIX_PYTHONPATH"/' -i * gnu/packages/admin.scm (nmap): (dstat): Wrap using GUIX_PYTHONPATH. * gnu/packages/audio.scm (jack-2): (carla): Likewise. * gnu/packages/benchmark.scm (fio): Likewise. * gnu/packages/bioinformatics.scm (couger): Likewise. (gess, find-circ, filtlong, nanopolish): Likewise. * gnu/packages/cdrom.scm (cdemu-client): Likewise. * gnu/packages/chemistry.scm (avogadro): Likewise. * gnu/packages/connman.scm (econnman): Likewise. * gnu/packages/cups.scm (hplip): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/display-managers.scm (lightdm): Likewise. * gnu/packages/ebook.scm (cozy): Likewise. * gnu/packages/education.scm (anki): Likewise. * gnu/packages/engineering.scm (kicad, volk, freecad): Likewise. * gnu/packages/game-development.scm (renpy): Likewise. * gnu/packages/games.scm (roguebox-adventures) (seahorse-adventures, kajongg): Likewise. * gnu/packages/gimp.scm (gimp, glimpse): Likewise. * gnu/packages/glib.scm (itstool): Likewise. * gnu/packages/gnome.scm (gnome-music, gtg, rhythmbox): Likewise. (eolie, d-feet, gedit, caribou, gnome-shell, authenticator) (gnome-todo, orca, passwordsafe, terminator, setzer) (libratbag, komikku): Likewise. * gnu/packages/gps.scm (gpsd): Likewise. * gnu/packages/gtk.scm (gtk-doc): Likewise. * gnu/packages/ibus.scm (ibus, ibus-libpinyin, ibus-anthy) (ibus-libhangul): Likewise. * gnu/packages/inkscape.scm (inkscape-1.0): Likewise. * gnu/packages/linux.scm (bcc): Likewise. * gnu/packages/mail.scm (notifymuch): Likewise. * gnu/packages/maths.scm (units): Likewise. * gnu/packages/music.scm (solfege): Likewise. * gnu/packages/networking.scm (blueman): Likewise. * gnu/packages/patchutils.scm (patchwork): Likewise. * gnu/packages/photo.scm (rapid-photo-downloader, entangle): Likewise. * gnu/packages/plotutils.scm (asymptote): Likewise. * gnu/packages/presentation.scm (presentty): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/storage.scm (ceph): Likewise. * gnu/packages/syndication.scm (liferea): Likewise. * gnu/packages/task-management.scm (blanket): Likewise. * gnu/packages/text-editors.scm (manuskript): Likewise. * gnu/packages/version-control.scm (gitless, cgit, git-when-merged) (git-imerge): Likewise. * gnu/packages/video.scm (pitivi): Likewise. * gnu/packages/virtualization.scm (criu): Likewise. * gnu/packages/xfce.scm (catfish): Likewise. Maxim Cournoyer 2021-01-28gnu: tsukundere: Update to 0.2.3....* gnu/packages/game-development.scm (tsukundere): Update to 0.2.3. [#:modules] Add guile-build-system for target-guile-effective-version. [#:imported-modules] Likewise. [#:phases] Add patch-command. [native-inputs]: Add texinfo. [description]: Update. Leo Prikler 2021-01-02gnu: deutex: Update to 5.2.2....* gnu/packages/game-development.scm (deutex): Update to 5.2.2. [source]: Change tarball extension. [native-inputs]: Add zstd. Tobias Geerinckx-Rice 2020-12-30gnu: gzochi: Update to 0.13....* gnu/packages/game-development.scm (gzochi): Update to 0.13. [inputs]: Replace guile-2.2 with guile-3.0. Ricardo Wurmus 2020-12-12gnu: renpy: Use system fribidi and drop generated sources....* gnu/packages/patches/renpy-use-system-fribidi.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it here. * gnu/packages/game-development.scm (renpy)[source]<patches> Use it here. <modules>: Add (guix build utils). <snippet>: Drop generated sources and fribidi sources. (arguments)[phases]: Add fix-include-paths. (inputs): Add fribidi. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Leo Prikler 2020-12-12gnu: pygame-sdl2-for-renpy: Drop generated sources in snippet....* gnu/packages/game-development.scm (pygame-sdl2-for-renpy)[source]<modules>: Add (guix build utils). [#:phases]<drop-generated-files>: Move from here... [source]<snippet>: ... to here. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Leo Prikler 2020-11-23gnu: guile-chickadee: Use Guile 3.0....* gnu/packages/game-development.scm (guile-chickadee): Change Guile inputs to use 3.0 package variants. David Thompson 2020-11-23gnu: guile-chickadee: Update to 0.6.0.David Thompson 2020-11-23gnu: Deprecate guile3.0-chickadee.David Thompson 2020-11-20gnu: tiled: Update to 1.4.3....* gnu/packages/game-development.scm (tiled): Update to 1.4.3. Tobias Geerinckx-Rice 2020-11-18gnu: bennu-game-development: Update to 353....* gnu/packages/game-development.scm (bennu-game-development): Update to 353. Pierre Neidhardt 2020-11-15gnu: tiled: Update to 1.4.2.David Thompson 2020-10-15gnu: Add tsukundere....* gnu/packages/game-development.scm (tsukundere): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Leo Prikler 2020-10-04gnu: godot: Update to 3.2.3....* gnu/packages/game-development.scm (godot): Update to 3.2.3. Tobias Geerinckx-Rice 2020-10-01gnu: nml: Update to 0.5.3....* gnu/packages/game-development.scm (nml): Update to 0.5.3. Tobias Geerinckx-Rice 2020-09-15gnu: surgescript: Update to 0.5.4.4....* gnu/packages/game-development.scm (surgescript): Update to 0.5.4.4. Tobias Geerinckx-Rice