aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ots)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages xml)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ots
  (package
    (name "ots")
    (version "0.5.0")
    (source
     (origin
       (method url-fetch)
       ;; libots seems to have left sourceforge and taken their release
       ;; tarballs with them
       (uri (list (string-append "mirror://debian/pool/main/o/ots/ots_"
                                 version ".orig.tar.gz")
                  (string-append "mirror://sourceforge/libots/libots/"
                                 name "-" version "/" name "-" version
                                 ".tar.gz")))
       (sha256
        (base32 "0dz1ccd7ymzk4swz1aly4im0k3pascnshmgg1whd2rk14li8v47a"))
       (patches (search-patches "ots-no-include-missing-file.patch"))))

    (build-system gnu-build-system)
    (arguments
     ;; With '-jN', the rule to build the 'ots' command can be triggered
     ;; before libots-1.la has been built.
     '(#:parallel-build? #f

       #:phases
       (modify-phases %standard-phases
         (add-after 'configure 'set-shared-lib-extension
           (lambda _
             ;; For some reason, the 'libtool' script (from Libtool
             ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
             ;; 'shrext' for the shared library file name extension.
             ;; This leads to the creation of 'libots-1' instead of
             ;; 'libots-1.so'.  Fix that.
             (substitute* "libtool"
               (("shrext_cmds") "shrext"))
             #t)))))
    (inputs
      (list glib popt libxml2 zlib))
    (native-inputs
      `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)))
    (synopsis "Tool for summarizing texts")
    (description
      "The Open Text Summarizer is a library and command-line tool for
summarizing texts.  The program reads a text and decides which sentences are
important and which are not.  OTS will create a short summary or will
highlight the main ideas in the text.

The program can either print the summarized text as plain text or HTML.  If in
HTML, the important sentences are highlighted.

The program is multi lingual and works with UTF-8 encoding.")
    (home-page "http://libots.sourceforge.net/")
    (license license:gpl2+)))
27b4117daa7a7f5cdd84e0211c3acb778e9246b'>Merge branch 'master' into stagingMarius Bakke 2022-08-30gnu: rust: Don't ask to run tests when cross-compiling....Maxime Devos 2022-08-04gnu: rust: Use rust-1.60.0...Jim Newsome 2022-08-04gnu: rust: decouple rust-1.57 and "rust"...Jim Newsome 2022-07-10gnu: rust-1.55: Fix building on riscv64-linux....Efraim Flashner 2022-07-10gnu: rust-bootstrap: Add support for riscv64-linux....Efraim Flashner 2022-07-05gnu: rust: Add correct triplet for riscv64-linux....Efraim Flashner 2022-07-05gnu: rust: Bootstrap with rust-1.54.0....Efraim Flashner 2022-05-09gnu: mrustc: Update to 0.10....Pierre Langlois 2022-02-01gnu: LLVM: Switch to 13 as the default....Marius Bakke 2022-01-22gnu: rust-analyzer: Make it work out of the box....Z572 via Guix-patches via 2022-01-10gnu: rust: Do not generate doc....Maxim Cournoyer 2022-01-10gnu: rust: Use rust-1.57.0....Maxim Cournoyer 2022-01-10gnu: rust-1.39: Update mrustc to commit c70665....Maxim Cournoyer 2022-01-08gnu: rust-1.40: Fix spelling....Vagrant Cascadian 2021-12-27gnu: Add rust-1.57....(unmatched parenthesis 2021-12-27gnu: Add rust-1.56....(unmatched parenthesis 2021-12-27gnu: Add rust-1.55....(unmatched parenthesis 2021-11-27gnu: rust: Add 'supported-systems' field....Ludovic Courtès 2021-11-11gnu: Build all Rust packages using the latest rustc....Maxim Cournoyer 2021-11-11gnu: rust: Add rust 1.54 and move all non-bootstrapping logic to it....Maxim Cournoyer 2021-11-11gnu: rust: Bootstrap rust from 1.39.0 and optimize build time....Maxim Cournoyer 2021-11-11gnu: rust: Update to 1.50....Jakub Kądziołka 2021-07-24gnu: Use 'search-input-file' when looking for executables....Ludovic Courtès 2021-07-24gnu: Use 'search-input-file' when looking for *.so and *.a....Ludovic Courtès 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-08mailmap: Update entries for Matthew James Kraai....Matthew James Kraai 2021-05-22Merge branch 'master' into core-updatesMarius Bakke 2021-05-19gnu: Add Rust 1.52.1....Jakub Kądziołka 2021-05-13gnu: Rust: Export all versions....Marius Bakke 2021-05-04gnu: rust: Re-use llvm versions....Efraim Flashner 2021-04-16Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner