aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages orpheus)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages mp3)
  #:use-module (gnu packages base)
  #:use-module (gnu packages xiph)
  #:use-module (gnu packages xml)
  #:use-module (ice-9 match))

(define-public orpheus
  (package
    (name "orpheus")
    (version "1.6")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "http://thekonst.net/download/orpheus-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1xbgxq8fybwhm51nw9hvvrgi873qzkc2qvmy15d2m2hw2yqa99hq"))
      (patches (search-patches "orpheus-cast-errors-and-includes.patch"))))
    (build-system gnu-build-system)
    (inputs
     (list ncurses
           libvorbis
           vorbis-tools
           mpg321
           ;; TODO: add ghttp
           libxml2
           which))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             ;; This old `configure' script does not support variables passed as
             ;; arguments.
             (let ((out (assoc-ref outputs "out")))
               (setenv "CONFIG_SHELL" (which "bash"))
               (setenv "SHELL" (which "bash"))
               (setenv "LIBS" "-logg")     ;doesn't declare its use of libogg
               (invoke "./configure"
                       (string-append "--prefix=" out)
                       ,@(match (%current-system)
                                ("mips64el-linux"
                                 '("--host=mips64el-unknown-linux-gnu"))
                                ("aarch64-linux"
                                 '("--build=aarch64-unknown-linux-gnu"))
                                (_ `()))))))
         (add-after 'configure 'configure-players
           (lambda* (#:key inputs #:allow-other-keys)
             ;; To avoid propagating the mpg321 and vorbis-tools inputs, we can
             ;; make the orpheus application execute the needed players from the
             ;; store.
             (let ((ogg123 (search-input-file inputs "/bin/ogg123"))
                   (mpg321 (search-input-file inputs "/bin/mpg321"))
                   (which  (search-input-file inputs "/bin/which")))
               (substitute* "src/orpheusconf.cc"
                 (("ogg123") ogg123)
                 (("which")  which)
                 (("mpg321") mpg321))
               #t)))
         (add-before 'build 'patch-shells
           (lambda _
             (substitute* '("src/mp3track.cc"
                            "src/streamtrack.cc"
                            "src/oggtrack.cc")
               (("/bin/sh") (which "sh")))
             #t)))))
    (home-page "http://thekonst.net/en/orpheus")
    (synopsis "Text-mode audio player")
    (description
     "Orpheus is a light-weight text mode menu- and window-driven audio player
application for CDs, internet stream broadcasts, and files in MP3 and Vorbis
OGG format.")
    (license gpl2+)))
xyz.scm?id=14be341953399e2b7656c118191d82f257c6021f'>gnu: Add erlang-epam....* gnu/packages/erlang-xyz.scm (erlang-epam): New variable. Change-Id: I09e50e3ad2476bf0f96363a20c4b15f2756fe368 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-yconf....* gnu/packages/erlang-xyz.scm (erlang-yconf): New variable. Change-Id: I01618befa77933613a60defca2a8c25067754e49 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-fast-yaml....* gnu/packages/erlang-xyz.scm (erlang-fast-yaml): New variable. Change-Id: I81cb9dab74a81af9f6a901fa2674ac9f77318cd4 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-fast-xml....* gnu/packages/erlang-xyz.scm (erlang-fast-xml): New variable. Change-Id: Id005f375b99f77b8e9e8e318b6c82d1f256a5fd2 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-stun....* gnu/packages/erlang-xyz.scm (erlang-stun): New variable. Change-Id: I3549fd1ddbae2490ea454c56bdca804d1030ceec Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-fast-tls....* gnu/packages/erlang-xyz.scm (erlang-fast-tls): New variable. Change-Id: Ibda856e308b68f5e1dba4a7a541e0f2438aae737 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-ezlib....* gnu/packages/erlang-xyz.scm (erlang-ezlib): New variable. Change-Id: I342ece260f9bd2d594343ab3afe91cfbced049fd Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-pkix....* gnu/packages/erlang-xyz.scm (erlang-pkix): New variable. Change-Id: Ie78bdaebbdafb22964e40a153aff76f5a23af7e2 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-p1-oauth2....* gnu/packages/erlang-xyz.scm (erlang-p1-oauth2): New variable. Change-Id: I4d059e3c1fa644845787e70c3a4f7b0a3ebb4711 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-jiffy....* gnu/packages/erlang-xyz.scm (erlang-jiffy): New variable. Change-Id: I44918d5f1c3ed158cc6c65bad05b684744ebecd9 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-mqtree....* gnu/packages/erlang-xyz.scm (erlang-mqtree): New variable. Change-Id: I9e7217185659ce8ea129645e399e11109c119fd4 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-eimp....* gnu/packages/erlang-xyz.scm (erlang-eimp): New variable. Change-Id: Ic0c9c371f7dc35f36a2903e096618e1cd9bd5d36 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-cache-tab....* gnu/packages/erlang-xyz.scm (erlang-cache-tab): New variable. Change-Id: I017a01c95eba176a2d77e5f88fb2f0b0c19170f3 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-stringprep....* gnu/packages/erlang-xyz.scm (erlang-stringprep): New variable. Change-Id: I83ae7c53fc83eec756b208ed2d539a0976c72611 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-idna....* gnu/packages/erlang-xyz.scm (erlang-idna): New variable. Change-Id: I068e15dd505ceff0e66c97936445eaa3c980f803 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-unicode-util-compat....* gnu/packages/erlang-xyz.scm (erlang-unicode-util-compat): New variable. Change-Id: Ie401c5c0d3d851d2fdc4ae0232f4dc67bcc5c5ef Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-p1-utils....* gnu/packages/erlang-xyz.scm (erlang-p1-utils): New variable. Change-Id: I90bb3816c2c29c5c2f7a9eec3656967f63ae58b1 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-luerl....* gnu/packages/erlang-xyz.scm (erlang-luerl): New variable. Change-Id: I6864986aab58ee970a8313a81dd4b045711365e9 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-jose....* gnu/packages/erlang-xyz.scm (erlang-jose): New variable. Change-Id: I2f7bc3249098a2a36dcb42a4cf62ac15d03db533 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via 2024-08-05gnu: Add erlang-base64url....* gnu/packages/erlang-xyz.scm (erlang-base64url): New variable. Change-Id: I2b7b44631408138576e4a1498a39c64810cb0582 Signed-off-by: Andrew Tropin <andrew@trop.in> Igor Goryachev via Guix-patches via