aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages openbox)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages xdisorg)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public openbox
  (package
    (name "openbox")
    (version "3.6.1")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "http://openbox.org/dist/openbox/" name "-"
                    version ".tar.xz"))
              (sha256
               (base32
                "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))
              (patches (search-patches "openbox-python3.patch"))))
    (build-system gnu-build-system)
    (arguments
     (list #:phases
           #~(modify-phases %standard-phases
               (add-after 'unpack 'force-reconfigure
                 ;; This is made necessary by the openbox-python3 patch.
                 (lambda _
                   (delete-file "configure"))))))
    (native-inputs (list autoconf automake gettext-minimal libtool pkg-config))
    (propagated-inputs (list python-pyxdg))
    (inputs (list imlib2
                  libxml2
                  (librsvg-for-system)
                  libsm
                  libxcursor
                  libxinerama
                  libxml2
                  libxrandr
                  libxft
                  pango
                  python-wrapper))
    (synopsis "Box style window manager")
    (description
     "Openbox is a highly configurable, next generation window manager with
extensive standards support.  The *box visual style is well known for its
minimalistic appearance.  Openbox uses the *box visual style, while providing
a greater number of options for theme developers than previous *box
implementations.")
    (home-page "http://openbox.org/wiki/Main_Page")
    (license gpl2+)))

(define-public obconf
  (package
    (name "obconf")
    (version "2.0.4")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://openbox.org/dist/" name
                           "/" name "-" version ".tar.gz"))
       (sha256
        (base32
         "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
    (inputs
     `(("gtk+-2" ,gtk+-2)
       ("imlib2" ,imlib2)
       ("libglade" ,libglade)
       ("openbox" ,openbox)
       ("startup-notification" ,startup-notification)
       ("libsm" ,libsm)
       ("librsvg" ,(librsvg-for-system))
       ("libxft" ,libxft)))
    (native-inputs
     `(("gettext" ,gettext-minimal)
       ("pkg-config" ,pkg-config)))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags (list "--enable-nls")))
    (home-page "http://openbox.org/wiki/ObConf:About")
    (synopsis "Openbox configuration tool")
    (description
     "Obconf is a tool for configuring the Openbox window manager.
You can configure its appearance, themes, and much more.")
    (license gpl2+)))

;;; openbox.scm ends here
ame. * gnu/packages/maths.scm (hypre)[native-inputs]: Use new name. Re-order alphabetically. * gnu/packages/sphinx.scm (python-sphinx)[propagated-inputs]: Use new name. Re-order alphabetically. Nicolas Goaziou 2023-07-18gnu: texlive-latex-tabulary -> texlive-tabulary....* gnu/packages/tex.scm (texlive-tabulary): New variable. (texlive-latex-tabulary): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-parskip -> texlive-parskip....* gnu/packages/tex.scm (texlive-parskip): New variable. (texlive-latex-parskip): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-float -> texlive-float....* gnu/packages/tex.scm (texlive-float): New variable. (texlive-latex-float): Deprecate variable. (texlive-showexpl): (texlive-minted): (texlive-apa6): * gnu/packages/docbook.scm (dblatex): * gnu/packages/maths.scm (hypre): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-cmap -> texlive-cmap....* gnu/packages/tex.scm (texlive-cmap): New variable. (texlive-latex-cmap): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-upquote -> texlive-upquote....* gnu/packages/tex.scm (texlive-upquote): New variable. (texlive-latex-upquote): Deprecate variable. * gnu/packages/cran.scm (r-prereg): * gnu/packages/maths.scm (hypre): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): * gnu/packages/statistics.scm (r-with-tests): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-geometry -> texlive-geometry....* gnu/packages/tex.scm (texlive-geometry): New variable. (texlive-latex-geometry): Deprecate variable. (texlive-xindy): * gnu/packages/chemistry.scm (yaehmop): * gnu/packages/cran.scm (r-prereg): * gnu/packages/graphviz.scm (dot2tex): * gnu/packages/maths.scm (hypre): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-framed -> texlive-framed....* gnu/packages/tex.scm (texlive-framed): New variable. (texlive-latex-framed): Deprecate variable. (texlive-minted): * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-07-18gnu: texlive-latex-fncychap -> texlive-fncychap....* gnu/packages/tex.scm (texlive-fncychap): New variable. (texlive-latex-fncychap): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name. Nicolas Goaziou 2023-05-13gnu: python-sphinx-panels: Use older docutils....* gnu/packages/sphinx.scm (python-sphinx-panels)[propagated-inputs]: Replace python-docutils with python-docutils-0.15. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. Ricardo Wurmus 2023-05-07gnu: python-sphinx-4: Fix sanity-check failure...* gnu/packages/sphinx.scm (python-sphinx-4)[propagated-inputs]: Downgrades python-docutils to v0.15 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Zongyuan Li 2023-04-16gnu: sphinx: Update minimum docutils version to 0.19.... * gnu/packages/sphinx.scm (python-sphinx-rtd-theme)[allow-newer-docutil]: New phase. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Brian Cully 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-13gnu: python-breathe: Update to 4.35.0....* gnu/packages/sphinx.scm (python-breathe): Update to 4.35.0. Signed-off-by: Christopher Baines <mail@cbaines.net> Antero Mejr