aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages openbox)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages image)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages xdisorg)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))

(define-public openbox
  (package
    (name "openbox")
    (version "3.6.1")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "http://openbox.org/dist/openbox/" name "-"
                    version ".tar.xz"))
              (sha256
               (base32
                "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))
              (patches (search-patches "openbox-python3.patch"))))
    (build-system gnu-build-system)
    (arguments
     (list #:phases
           #~(modify-phases %standard-phases
               (add-after 'unpack 'force-reconfigure
                 ;; This is made necessary by the openbox-python3 patch.
                 (lambda _
                   (delete-file "configure"))))))
    (native-inputs (list autoconf automake gettext-minimal libtool pkg-config))
    (propagated-inputs (list python-pyxdg))
    (inputs (list imlib2
                  libxml2
                  (librsvg-for-system)
                  libsm
                  libxcursor
                  libxinerama
                  libxml2
                  libxrandr
                  libxft
                  pango
                  python-wrapper))
    (synopsis "Box style window manager")
    (description
     "Openbox is a highly configurable, next generation window manager with
extensive standards support.  The *box visual style is well known for its
minimalistic appearance.  Openbox uses the *box visual style, while providing
a greater number of options for theme developers than previous *box
implementations.")
    (home-page "http://openbox.org/wiki/Main_Page")
    (license gpl2+)))

(define-public obconf
  (package
    (name "obconf")
    (version "2.0.4")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://openbox.org/dist/" name
                           "/" name "-" version ".tar.gz"))
       (sha256
        (base32
         "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
    (inputs
     `(("gtk+-2" ,gtk+-2)
       ("imlib2" ,imlib2)
       ("libglade" ,libglade)
       ("openbox" ,openbox)
       ("startup-notification" ,startup-notification)
       ("libsm" ,libsm)
       ("librsvg" ,(librsvg-for-system))
       ("libxft" ,libxft)))
    (native-inputs
     `(("gettext" ,gettext-minimal)
       ("pkg-config" ,pkg-config)))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags (list "--enable-nls")))
    (home-page "http://openbox.org/wiki/ObConf:About")
    (synopsis "Openbox configuration tool")
    (description
     "Obconf is a tool for configuring the Openbox window manager.
You can configure its appearance, themes, and much more.")
    (license gpl2+)))

;;; openbox.scm ends here
s='msg-avail'>...* gnu/packages/serialization.scm (cereal)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-01-26gnu: jsoncpp: Fix cross-compilation....* gnu/packages/serialization.scm (jsoncpp)[arguments]: Add configure flag to prevent running a test during the build process. Marius Bakke 2020-01-25gnu: cmake-minimal: Remove bundled jsoncpp....* gnu/packages/cmake.scm (cmake-minimal)[source](snippet): New field. Purge bundled jsoncpp. [inputs]: Add JSONCPP. [arguments]: Adjust accordingly. * gnu/packages/serialization.scm (jsoncpp)[arguments]: For native builds, use CMAKE-BOOTSTRAP. Marius Bakke 2020-01-12gnu: jsoncpp: Fix test failure on armhf-linux and aarch64-linux....* gnu/packages/patches/jsoncpp-fix-inverted-case.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/serialization.scm (jsoncpp)[source](patches): New field. Marius Bakke 2020-01-07gnu: googletest: Update to 1.10.0....* gnu/packages/check.scm (googletest): Update to 1.10.0. (googletest-1.8): New public variable. * gnu/packages/audio.scm (cli-visualizer)[inputs]: Change from GOOGLETEST to GOOGLETEST-1.8. * gnu/packages/serialization.scm (msgpack)[native-inputs]: Likewise. Marius Bakke 2019-12-25gnu: msgpack: Update to 3.2.1....* gnu/packages/serialization.scm (msgpack): Update to 3.2.1. Tobias Geerinckx-Rice 2019-12-04gnu: Remove duplicate nlohmann-json-cpp package....* gnu/packages/serialization.scm (nlohmann-json-cpp): Move variable ... * gnu/packages/cpp.scm (nlohmann-json-cpp): ... here. Mark as deprecated by JSON-MODERN-CXX. * gnu/packages/jupyter.scm (xeus)[inputs]: Change NLOHMANN-JSON-CPP to JSON-MODERN-CXX. * gnu/packages/video.scm (mkvtoolnix)[inputs]: Likewise. Marius Bakke 2019-12-04gnu: python-pandas: Move to (gnu packages python-science)....* gnu/packages/python-xyz.scm (python-pandas, python2-pandas): Move from here... * gnu/packages/python-science.scm (python-pandas, python2-pandas): ...to here. * gnu/packages/benchmark.scm, gnu/packages/databases.scm, gnu/packages/graph.scm, gnu/packages/parallel.scm, gnu/packages/serialization.scm: Import (gnu packages python-science). Ricardo Wurmus 2019-11-21gnu: jsoncpp: Update to 1.9.2....* gnu/packages/serialization.scm (jsoncpp): Update to 1.9.2. * gnu/packages/games.scm (minetest)[source](snippet): Add substitution. Marius Bakke 2019-11-03gnu: yaml-cpp: Don't use unstable tarball....* gnu/packages/serialization.scm (yaml-cpp)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-11-03gnu: yaml-cpp: Update to 0.6.3....* gnu/packages/serialization.scm (yaml-cpp): Update to 0.6.3. [arguments]: Update #:configure-flags. Remove obsolete ‘dont-install-gtest-libraries’ phase. Tobias Geerinckx-Rice 2019-10-31gnu: Remove python2-feather-format....This trivial package fails to build and has no reverse dependencies. * gnu/packages/serialization.scm (python2-feather-format): Remove variable. Marius Bakke 2019-10-29gnu: cereal: Don't use unstable tarball....* gnu/packages/serialization.scm (cereal)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-10-06Merge branch 'master' into core-updatesRicardo Wurmus 2019-10-06gnu: lua-libmpack: Update to 1.0.8....* gnu/packages/serialization.scm (lua-libmpack): Update to 1.0.8. Tobias Geerinckx-Rice 2019-10-06gnu: lua-libmpack: Don't use unstable tarball....* gnu/packages/serialization.scm (lua-libmpack)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-10-06gnu: libmpack: Don't use unstable tarball....* gnu/packages/serialization.scm (libmpack)[source]: Use GIT-FETCH and GIT-FILE-NAME. (lua-libmpack)[arguments]: Adjust ‘unpack-mpack-sources’ phase. Tobias Geerinckx-Rice 2019-09-24Merge branch 'master' into core-updatesLudovic Courtès 2019-09-18gnu: nlohmann-json-cpp: Update to 3.7.0....* gnu/packages/serialization.scm (nlohmann-json-cpp): Update to 3.7.0. [source]: Use 'git-fetch'. [native-inputs, arguments]: New fields. Ludovic Courtès 2019-07-22Merge branch 'master' into core-updatesMarius Bakke 2019-07-22gnu: jsoncpp: Update to 1.9.1....* gnu/packages/serialization.scm (jsoncpp): Update to 1.9.1. Marius Bakke 2019-07-15gnu: msgpack: Update to 3.2.0....* gnu/packages/serialization.scm (msgpack): Update to 3.2.0. [build-system]: Change to CMAKE-BUILD-SYSTEM. [native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL. Marius Bakke 2019-07-15gnu: lua-libmpack: Update to 1.0.8....* gnu/packages/serialization.scm (lua-libmpack): Update to 1.0.8. Marius Bakke 2019-07-15gnu: lua-libmpack: Do not use unstable source tarball....* gnu/packages/serialization.scm (lua-libmpack)[source]: Change to GIT-FETCH. Marius Bakke 2019-07-06gnu: jsoncpp: Update to 1.9.0....* gnu/packages/serialization.scm (jsoncpp): Update to 1.9.0. Marius Bakke 2019-07-06gnu: jsoncpp: Fetch sources through git....* gnu/packages/serialization.scm (jsoncpp)[source]: Switch to GIT-FETCH. Marius Bakke 2019-04-08gnu: Add jsoncpp-for-tensorflow....* gnu/packages/serialization.scm (jsoncpp-for-tensorflow): New variable. Ricardo Wurmus