aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2017, 2018, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages onc-rpc)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages pkg-config)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public libtirpc
  (package
    (name "libtirpc")
    (version "1.3.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
                                  version "/libtirpc-"
                                  version ".tar.bz2"))
              (patches (search-patches "libtirpc-CVE-2021-46828.patch"))
              (sha256
               (base32
                "05zf16ilwwkzv4cccaac32nssrj3rg444n9pskiwbgk6y359an14"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--disable-static")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'adjust-netconfig-reference
           (lambda* (#:key outputs #:allow-other-keys)
             (substitute* '("man/netconfig.5"
                            "man/getnetconfig.3t"
                            "man/getnetpath.3t"
                            "man/rpc.3t"
                            "src/getnetconfig.c"
                            "tirpc/netconfig.h")
               (("/etc/netconfig") (string-append (assoc-ref outputs "out")
                                                  "/etc/netconfig")))))
         ,@(if (%current-target-system)
             `((add-after 'unpack 'adjust-pkg-config
                 (lambda* (#:key inputs #:allow-other-keys)
                   (substitute* "libtirpc.pc.in"
                     (("-ltirpc")
                      (string-append "-ltirpc"
                                     " -L" (dirname (search-input-file
                                                      inputs "/lib/libkrb5.so"))
                                     " -lkrb5"))))))
             `()))))
    (native-inputs (list mit-krb5)) ;; for cross-compilation
    (inputs (list mit-krb5))
    (home-page "https://sourceforge.net/projects/libtirpc/")
    (synopsis "Transport-independent Sun/ONC RPC implementation")
    (description
     "This package provides a library that implements the Sun/ONC RPC (remote
procedure calls) protocol in a transport-independent manner.  It supports both
IPv4 and IPv6.  ONC RPC is notably used by the network file system (NFS).")
    (license bsd-3)))

(define-public libtirpc/hurd
  (package/inherit libtirpc
    (name "libtirpc-hurd")
    (source (origin (inherit (package-source libtirpc))
                    (patches (search-patches "libtirpc-hurd.patch"
                                             "libtirpc-CVE-2021-46828.patch"))))
    (arguments
     (substitute-keyword-arguments (package-arguments libtirpc)
       ((#:configure-flags flags ''())
        ;; When cross-building the target system's krb5-config should be used.
        #~(list (string-append "ac_cv_prog_KRB5_CONFIG="
                               #$(this-package-input "mit-krb5")
                               "/bin/krb5-config")))))))

(define-public rpcbind
  (package
    (name "rpcbind")
    (version "1.2.6")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://sourceforge/" name "/" name "/"
                          version "/"
                          name "-" version ".tar.bz2"))
      (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
      (sha256
       (base32 "1pp8xvprsfz8nlmmvxf829gilx0ibb08bfs3lhisxrfai5j784sn"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
    (inputs
     (list libnsl libtirpc))
    (native-inputs
     (list pkg-config))
    (home-page "http://rpcbind.sourceforge.net/")
    (synopsis "Server to convert RPC program numbers into universal addresses")
    (description
     "@command{Rpcbind} is a server that converts RPC program numbers into
universal addresses.")
    (license bsd-3)))

(define-public rpcsvc-proto
  (package
    (name "rpcsvc-proto")
    (version "1.4")
    (home-page "https://github.com/thkukuk/rpcsvc-proto")
    (source (origin
              (method url-fetch)
              (uri (string-append home-page "/releases/download/v" version
                                  "/rpcsvc-proto-" version ".tar.xz"))
              (sha256
               (base32
                "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
    (build-system gnu-build-system)
    (synopsis "RPCSVC protocol definitions")
    (description
     "This package provides @code{rpcsvc} @file{protocol.x} files and headers
that are not included with the @code{libtirpc} package.  Additionally it
contains @command{rpcgen}, which is used to produce header files and sources
from the protocol files.")
    (license bsd-3)))

(define-public libnsl
  (package
    (name "libnsl")
    (version "1.3.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/thkukuk/libnsl")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1dayj5i4bh65gn7zkciacnwv2a0ghm6nn58d78rsi4zby4lyj5w5"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--disable-static")))
    (native-inputs
     `(("autoconf" ,autoconf)
       ("automake" ,automake)
       ("gettext" ,gettext-minimal)
       ("libtool" ,libtool)
       ("pkg-config" ,pkg-config)))
    (inputs
     (list libtirpc))
    (synopsis "Public client interface for NIS(YP) and NIS+")
    (description "Libnsl is the public client interface for the Network
Information Service / Yellow Pages (NIS/YP) and NIS+.  It includes IPv6 support.
This library was part of glibc < 2.26, but is now distributed separately.")
    (home-page "https://github.com/thkukuk/libnsl")
    ;; The package is distributed under the LGPL 2.1. Some files in
    ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
    (license lgpl2.1)))
f='/guix/commit/gnu/packages/admin.scm?id=38027458023bbcc4b1f95fffb329e80e0003d966'>gnu: inxi-minimal: Update to 3.3.30-1....* gnu/packages/admin.scm (inxi-minimal): Update to 3.3.30-1. Tobias Geerinckx-Rice 2023-09-24gnu: nmrpflash: Use G-expressions....* gnu/packages/admin.scm (nmrpflash)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-09-24gnu: nmrpflash: Update to 0.9.21....* gnu/packages/admin.scm (nmrpflash): Update to 0.9.21. Tobias Geerinckx-Rice 2023-09-25gnu: guile-fibers: Remove version from latest package....As I think this makes more sense, the version is only specified when you need a specific previous release. * gnu/packages/guile-xyz.scm (guile-fibers): Rename to guile-fibers-1.0. (guile-fibers-1.3): Rename to guile-fibers. (guile-fibers-1.1): Inherit from guile-fibers. * gnu/packages/admin.scm (shepherd-0.10)[native-inputs]: Replace guile-fibers-1.3 with guile-fibers. * gnu/packages/ci.scm (cuirass)[inputs]: Likewise. * gnu/packages/gnunet.scm (gnunet-scheme)[propagated-inputs,native-inputs]: Likewise. * gnu/packages/package-management.scm (guix-build-coordinator) [inputs,propagated-inputs]: Likewise. * gnu/packages/package-management.scm (nar-herder)[inputs,propagated-inputs]: Likewise. * gnu/packages/web.scm (guix-data-service)[propagated-inputs]: Likewise. Christopher Baines 2023-09-22gnu: uwufetch: Avoid top-level package references....* gnu/packages/admin.scm (uwufetch)[arguments]: Use the grep and gawk provided by INPUTS, instead of the top-level variables. Marius Bakke 2023-09-17gnu: pfetch: Update to 0.7.0-1.a906ff8....* gnu/packages/admin.scm (pfetch): Update to 0.7.0-1.a906ff8. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2023-09-18gnu: swineherd: Propagate inputs....Swineherd does not wrap its inputs, so it needs to drag along all its Guile inputs when installed. * gnu/packages/admin.scm (swineherd)[inputs]: Move all from here... [propagated-inputs]: ...to here. Ricardo Wurmus 2023-09-17gnu: Remove extraneous imports....Found by running 'guild compile -W3 gnu/packages/$module.scm', using guild from the upcoming Guile. * gnu/packages/admin.scm: Remove extraneous imports. * gnu/packages/avr.scm: Likewise. * gnu/packages/base.scm: Likewise. * gnu/packages/bootloaders.scm: Likewise. * gnu/packages/firmware.scm: Likewise. * gnu/packages/linphone.scm: Likewise. * gnu/packages/telephony.scm: Likewise. * gnu/packages/cran.scm: Likewise. * gnu/packages/kde.scm: Likewise. * gnu/packages/libcanberra.scm: Likewise. * gnu/packages/libreoffice.scm: Likewise. * gnu/packages/mes.scm: Likewise. * gnu/packages/mingw.scm: Likewise. * gnu/packages/serialization.scm: Likewise. * gnu/packages/sync.scm: Likewise. * gnu/packages/syncthing.scm: Likewise. * gnu/packages/terminals.scm: Likewise. * gnu/packages/version-control.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/emulators.scm: Likewise. Reviewed-by: Ludovic Courtès <ludo@gnu.org> Maxim Cournoyer 2023-09-10gnu: nnn: Update to 4.9....* gnu/packages/admin.scm (nnn): Update to 4.9. Tobias Geerinckx-Rice 2023-09-10gnu: inxi-minimal: Update to 3.3.29-1....* gnu/packages/admin.scm (inxi-minimal): Update to 3.3.29-1. Tobias Geerinckx-Rice 2023-09-10gnu: nmon: Update to 16p....* gnu/packages/admin.scm (nmon): Update to 16p. Tobias Geerinckx-Rice 2023-09-10gnu: dmidecode: Update to 3.5....* gnu/packages/admin.scm (dmidecode): Update to 3.5. Tobias Geerinckx-Rice 2023-09-10gnu: bfs: Update to 3.0.2....* gnu/packages/admin.scm (bfs): Update to 3.0.2. Tobias Geerinckx-Rice 2023-09-14gnu: rottlog: Add gawk as an input....This avoids an issue where rottlog will delete the entire /tmp directory if gawk is not installed. See <https://issues.guix.gnu.org/65793>. * gnu/packages/admin.scm (rottlog): Add gawk input, also update the patch-paths build phase for awk invocations. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Skyler 2023-09-14gnu: neofetch: Fix cross-compiling....* gnu/packages/admin.scm (neofetch): Fix cross-compiling. [arguments]: Use Gexp. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zheng Junjie 2023-09-12gnu: Add swineherd....* gnu/packages/admin.scm (swineherd): New variable. Ricardo Wurmus 2023-09-08gnu: shepherd: Switch back to Fibers 1.1 on Arm machines....Fixes <https://issues.guix.gnu.org/64966>. * gnu/packages/admin.scm (shepherd-0.10)[native-inputs]: Use GUILE-FIBERS-1.1 when ‘target-arm?’ is true. Reported-by: Timotej Lazar <timotej.lazar@araneo.si> Reported-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Reported-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Ludovic Courtès 2023-09-01gnu: Add tcptrack....* gnu/packages/admin.scm (tcptrack): New variable. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Reviewed-by: Jelle Licht <jlicht@fsfe.org> Jakob Kirsch 2023-08-29gnu: hyfetch: Update to 1.4.10....* gnu/packages/admin.scm (hyfetch): Update to 1.4.10. Signed-off-by: Christopher Baines <mail@cbaines.net> Hilton Chain 2023-08-20gnu: Add bfs....* gnu/packages/admin.scm (bfs): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tobias Kortkamp 2023-08-16Update email addresses for Juliana Sims....* .mailmap: Add an entry for Juliana. * gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/build-tools.scm, gnu/packages/scheme.scm: Update Juliana's email. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Juliana Sims 2023-08-12gnu: uwufetch: Add and use missing inputs....* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs. [phases]: Use the fully-qualified paths of the input gawk and grep. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Juliana Sims 2023-08-08gnu: uwufetch: Manually create missing include dir....* gnu/packages/admin.scm (uwufetch) [arguments]: Manually create missing include dir. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Juliana Sims 2023-08-08gnu: uwufetch: Fix typo in build phase name....* gnu/packages/admin.scm (uwufetch) [arguments]: Fix typo in build phase name. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Juliana Sims 2023-07-30gnu: lynis: Use G-expressions....* gnu/packages/admin.scm (lynis)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-30gnu: lynis: Update to 3.0.9....* gnu/packages/admin.scm (lynis): Update to 3.0.9. Tobias Geerinckx-Rice 2023-07-30gnu: acpica: Update to 20230628....* gnu/packages/admin.scm (acpica): Update to 20230628. Tobias Geerinckx-Rice 2023-07-30gnu: sudo: Update to 1.9.14p3....* gnu/packages/admin.scm (sudo): Update to 1.9.14p3. Tobias Geerinckx-Rice 2023-07-30gnu: jc: Update to 1.23.4....* gnu/packages/admin.scm (jc): Update to 1.23.4. Tobias Geerinckx-Rice 2023-07-23gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users. Tobias Geerinckx-Rice