aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages nvi)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages dbm)
  #:use-module (gnu packages ncurses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (guix utils))

(define-public nvi
  (package
    (name "nvi")
    (version "1.81.6")
    (source
      (origin
        (method url-fetch)
        (uri          ;; sites.google.coma/bostic.com/keithbostic/vi is stale.
          (string-append "http://harrier.slackbuilds.org/misc/nvi-" version
                         ".tar.bz2"))
        (sha256
          (base32 "0nbbs1inyrqds0ywn3ln5slv54v5zraq7lszkg8nsavv4kivhh9l"))
        (patches (search-patches "nvi-assume-preserve-path.patch"
                                 "nvi-dbpagesize-binpower.patch"
                                 "nvi-db4.patch"))
        (modules '((guix build utils)))
        (snippet
          ;; Create a wrapper for the configure script, make it executable.
          '(let ((conf-wrap (open-output-file "configure")))
             (display "#!/bin/sh" conf-wrap)
             (newline conf-wrap)
             (display
               "../nvi-1.81.6/dist/configure --srcdir=../nvi-1.81.6/dist $@"
               conf-wrap)
             (newline conf-wrap)
             (close-output-port conf-wrap)
             (chmod "configure" #o0755)

             ;; Glibc 2.30 removed the deprecated <sys/stropts.h>, so fall back
             ;; to the internal PTY allocation logic.
             (substitute* "ex/ex_script.c"
               (("#ifdef HAVE_SYS5_PTY")
                "#if defined(HAVE_SYS5_PTY) && !defined(__GLIBC__)"))
             #t))))

    (build-system gnu-build-system)
    (arguments
      `(#:out-of-source? #t
        #:configure-flags
        '("--enable-widechar"
          ,@(if (%current-target-system)
                '("vi_cv_sprintf_count=yes")
                '()))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'fix-configure
            (lambda* (#:key inputs native-inputs #:allow-other-keys)
              ;; Replace outdated config.sub and config.guess:
              (with-directory-excursion "dist"
                (for-each (lambda (file)
                            (chmod file #o755)
                            (install-file
                             (string-append
                              (assoc-ref
                               (or native-inputs inputs) "automake")
                              "/share/automake-"
                              ,(version-major+minor
                                (package-version automake))
                              "/" file) "."))
                          '("config.sub")))
              #t)))))
    (inputs
      (list bdb ncurses))
    (native-inputs
     (list automake)) ;Up to date 'config.guess' and 'config.sub'.
    (synopsis "The Berkeley Vi Editor")
    (description
      "Vi is the original screen based text editor for Unix systems.  It is
considered the standard text editor, and is available on almost all Unix
systems.  Nvi is intended as a \"bug-for-bug compatible\" clone of the
original BSD vi editor.  As such, it doesn't have a lot of snazzy features as
do some of the other vi clones such as elvis and vim.  However, if all you
want is vi, this is the one to get.")
    (home-page "https://sites.google.com/a/bostic.com/keithbostic/vi")
    (license bsd-3)))
n-xyz.scm, gnu/packages/qt.scm, gnu/packages/radio.scm, gnu/packages/rails.scm, gnu/packages/rdf.scm, gnu/packages/rednotebook.scm, gnu/packages/rpc.scm, gnu/packages/rsync.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/security-token.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/shellutils.scm, gnu/packages/simh.scm, gnu/packages/sml.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-07-01gnu: premake@5: Update to 5.0.0-alpha15....* gnu/packages/build-tools.scm (premake5): Update to 5.0.0-alpha15. [arguments]: Modify ‘enter-source’ phase. Tobias Geerinckx-Rice 2020-06-22gnu: gn: Update to 0.0-1794.eb997b5....* gnu/packages/build-tools.scm (gn): Update to 0.0-1794.eb997b5. Marius Bakke 2020-06-16gnu: tup: Update to 0.7.9....* gnu/packages/build-tools.scm (tup): Update to 0.7.9. Tobias Geerinckx-Rice 2020-06-14gnu: Add tup....* gnu/packages/build-tools.scm (tup): New variable. * gnu/packages/patches/tup-unbundle-dependencies.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new file. Jakub Kądziołka 2020-05-28gnu: Add compiledb....* gnu/packages/build-tools.scm (compiledb): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Yuval Kogman 2020-04-13Merge branch 'master' into core-updatesMarius Bakke 2020-04-12gnu: gn: Update to 0.0-1736.ec938dd....* gnu/packages/build-tools.scm (gn): Update to 0.0-1736.ec938dd. [arguments]: Adjust last_commit_position.h for upstream changes. Marius Bakke 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-20gnu: add premake5....* gnu/packages/build-tools.scm (premake5): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Leo Prikler 2020-03-05gnu: meson: Update to 0.53.2....* gnu/packages/build-tools.scm (meson): Update to 0.53.2. Marius Bakke 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-18gnu: bear: Update to 2.4.3....* gnu/packages/build-tools.scm (bear): Update to 2.4.3. Tobias Geerinckx-Rice 2020-01-24gnu: meson: Update to 0.53.1....* gnu/packages/build-tools.scm (meson): Update to 0.53.1. Marius Bakke 2020-01-08gnu: meson: Update to 0.53.0....* gnu/packages/build-tools.scm (meson): Update to 0.53.0. Marius Bakke 2019-12-31Merge remote-tracking branch 'master' into core-updates.Mathieu Othacehe 2019-12-19Update email for Brett Gilio....* .mailmap: Add name and email for Brett Gilio. * gnu/local.mk, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/bittorrent.scm, gnu/packages/build-tools.scm, gnu/packages/cran.scm, gnu/packages/emacs-xyz.scm, gnu/packages/messaging.scm, gnu/packages/python-xyz.scm, gnu/packages/sml.scm, gnu/packages/terminals.scm, gnu/packages/wm.scm: Update email for Brett Gilio. Brett Gilio 2019-12-05gnu: meson: Update to 0.52.1....* gnu/packages/build-tools.scm (meson): Update to 0.52.1. Marius Bakke 2019-11-22gnu: bear: Update to 2.4.2....* gnu/packages/build-tools.scm (bear): Update to 2.4.2. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Brett Gilio 2019-11-15gnu: gn: Enable tests....* gnu/packages/build-tools.scm (gn)[arguments]: Remove #:tests?. Override 'check' phase. Marius Bakke 2019-11-15gnu: gn: Update to 0.0-1666.6e5ba2e....* gnu/packages/build-tools.scm (gn): Update to 0.0-1666.6e5ba2e. [arguments]: Do not override LDFLAGS. Marius Bakke 2019-07-17Merge branch 'master' into core-updatesLudovic Courtès 2019-07-16gnu: osc: Update to 0.165.2....* gnu/packages/build-tools.scm (osc): Update to 0.165.2. Tobias Geerinckx-Rice 2019-06-30Revert "gnu: meson: Update to 0.51.0."...Meson 0.51.0 has problems with PKG_CONFIG_PATH. See <https://bugs.gnu.org/36386>. This reverts commit 70530036b8313d5273fca286cd62c73bd2225110. Marius Bakke 2019-06-20gnu: meson: Update to 0.51.0....* gnu/packages/build-tools.scm (meson): Update to 0.51.0. Marius Bakke 2019-06-13Merge branch 'master' into core-updatesLudovic Courtès 2019-06-07gnu: osc: Update to 0.165.1....* gnu/packages/build-tools.scm (osc): Update to 0.165.1. Tobias Geerinckx-Rice 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-11gnu: osc: Update to 0.165.0....* gnu/packages/build-tools.scm (osc): Update to 0.165.0. [source]: Use git-fetch. [arguments]: Use python3. osc_hotshot.py is gone. So, do not attempt to delete it. Rename fix-filename-and-remove-unused phase to fix-filename phase. [inputs]: Add rpm. Remove python2-urlgrabber. Replace python2-m2crypto and python2-pycurl with python-m2crypto and python-pycurl. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net> Jonathan Brielmaier 2019-05-04gnu: meson: Update to 0.50.1....* gnu/packages/build-tools.scm (meson): Update to 0.50.1. Marius Bakke 2019-03-15gnu: meson: Update to 0.50.0....* gnu/packages/build-tools.scm (meson): Update to 0.50.0. * gnu/packages/patches/at-spi2-core-meson-compat.patch, gnu/packages/patches/totem-meson-compat.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gnome.scm (totem)[source](patches): Add totem-meson.compat.patch. * gnu/packages/gtk.scm (at-spi2-core)[source](patches): New field. Marius Bakke 2019-02-24Merge branch 'master' into stagingMarius Bakke 2019-02-22gnu: gn: Update to commit 1ab6fa2cab7ec64840db720a56018ca8939329f9....* gnu/packages/build-tools.scm (gn): Update to 0.0-1530.1ab6fa2. [arguments]: Add LDFLAGS. Remove obsolete configure flag. Marius Bakke 2019-02-20gnu: bear: Update to 2.3.13....* gnu/packages/build-tools.scm (bear): Update to 2.3.13. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Brett Gilio 2019-02-10gnu: meson: Update to 0.49.2....* gnu/packages/build-tools.scm (meson): Update to 0.49.2. Marius Bakke 2018-12-12gnu: meson: Update to 0.49.0....* gnu/packages/build-tools.scm (meson): Update to 0.49.0. Marius Bakke 2018-12-04gnu: meson: Update to 0.48.2...* gnu/packages/build-tools.scm (meson): Update to 0.48.2. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Brett Gilio 2018-11-22Merge branch 'master' into core-updatesMarius Bakke 2018-11-22gnu: bam: Update to 0.5.1....* gnu/packages/build-tools.scm (bam): Update to 0.5.1. [source]: Switch to git-fetch. [arguments]: Use newly provided Makefile. [inputs]: Add lua. Alex Vong