aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages nutrition)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix build-system python)
  #:use-module (gnu packages)
  #:use-module (gnu packages check)
  #:use-module (gnu packages databases)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages gstreamer)
  #:use-module (gnu packages image)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-crypto)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages time)
  #:use-module (gnu packages xorg)
  #:use-module (gnu packages xml))

(define-public python-scrape-schema-recipe
  (package
    (name "python-scrape-schema-recipe")
    (version "0.2.0")
    ;; The PyPI archive lacks a VERSION file as well as the test suite.
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/micahcochran/scrape-schema-recipe")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "044c6qwhb4c710ksgiw29cd0qcp84h1m4y8yr2g4c8vdlm3kkqh5"))))
    (build-system python-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (substitute* "test_scrape.py"
                  (("DISABLE_NETWORK_TESTS = False")
                   "DISABLE_NETWORK_TESTS = True"))
                (invoke "pytest" "-vv")))))))
    (native-inputs (list python-pytest))
    (propagated-inputs
     (list python-extruct
           python-importlib-resources
           python-isodate
           python-requests))
    (home-page "https://github.com/micahcochran/scrape-schema-recipe")
    (synopsis "HTML Recipe format extractor")
    (description "This tool extracts cooking recipe from HTML structured data
in the @url{https://schema.org/Recipe} format.")
    (license asl2.0)))

(define-public gourmet
  ;; Use the latest commit to gain Python 3 support.
  (let ((revision "0")
        (commit "8af29c8ded24528030e5ae2ea3461f61c1e5a575"))
    (package
      (name "gourmet")
      (version (git-version "0.17.4" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/thinkle/gourmet")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32
           "08fbw6zp32ws6w9czwy2sqc9c9izlkglsskshj2114d0l79z4gj8"))
         (patches (search-patches "gourmet-sqlalchemy-compat.patch"))))
      (build-system python-build-system)
      (arguments
       (list
        #:modules `((guix build utils)
                    (guix build python-build-system)
                    (ice-9 ftw)
                    (srfi srfi-26))
        #:phases
        #~(modify-phases %standard-phases
            (add-before 'check 'prepare-x
              ;; Both the tests and the sanity-check phase need an X server to
              ;; succeed.
              (lambda _
                (system "Xvfb &")
                (setenv "DISPLAY" ":0")))
            (replace 'check
              (lambda* (#:key tests? #:allow-other-keys)
                (when tests?
                  (setenv "HOME" "/tmp") ;needed by tests
                  (apply invoke "pytest" "-vv"
                         ;; XXX: This is needed because some tests in deeper
                         ;; directories or otherwise discovered by Pytest are
                         ;; broken.
                         (map (cut string-append "gourmet/tests/" <>)
                              (scandir "gourmet/tests"
                                       (cut string-prefix? "test_" <>)))))))
            (add-after 'install 'install-dekstop-file-and-icons
              (lambda _
                (define share (string-append #$output "/share"))
                (install-file ".flatpak/io.github.thinkle.Gourmet.desktop"
                              (string-append share "/applications"))
                (install-file ".flatpak/io.github.thinkle.Gourmet.svg"
                              (string-append share "/icons/Gourmet")))))))
      (native-inputs
       (list python-dogtail
             python-pytest
             python-selenium
             xorg-server-for-tests))
      (inputs
       (list gtk+
             python-argcomplete
             python-beautifulsoup4
             python-gst
             python-keyring
             python-lxml
             python-pillow
             python-pycairo
             python-pyenchant
             python-pygobject
             python-requests
             python-scrape-schema-recipe
             python-sqlalchemy
             python-toml))
      (home-page "https://thinkle.github.io/gourmet/")
      (synopsis "Recipe organizer")
      (description
       "Gourmet Recipe Manager is a recipe organizer that allows you to collect,
search, organize, and browse your recipes.  Gourmet can also generate shopping
lists and calculate nutritional information.  It imports Mealmaster,
MasterCook and KRecipe files and exports PDFs, webpages, and other formats.")
      (license gpl2+))))
(native-inputs (list python-wrapper zip)) (synopsis "Block unwanted content from web sites") (description "uBlock Origin is a @dfn{wide spectrum blocker} for IceCat and ungoogled-chromium.") (license license:gpl3+))) (define-public ublock-origin/chromium (make-chromium-extension ublock-origin "chromium")) (define-public ublock-origin/icecat (make-icecat-extension ublock-origin "firefox")) (define-public passff-host (package (name "passff-host") (version "1.2.4") (home-page "https://github.com/passff/passff-host") (source (origin (method git-fetch) (uri (git-reference (url home-page) (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1lcwa1qzfxlifmj33qndp1wgi6yx6vj21ir0az79vhm5k03p961z")))) (build-system copy-build-system) (arguments (let ((native-manifests "lib/icecat/native-messaging-hosts")) (list #:install-plan `'(("src" ,native-manifests #:include ("passff.json" "passff.py"))) #:phases #~(modify-phases %standard-phases (add-after 'unpack 'substitute (lambda _ (substitute* "src/passff.json" (("PLACEHOLDER") (format #f "~a/~a/passff.py" #$output #$native-manifests))) (substitute* "src/passff.py" (("_VERSIONHOLDER_") #$version) (("^COMMAND = .*") (format #f "COMMAND = \"~a/bin/pass\"~%" #$(this-package-input "password-store")))) (patch-shebang "src/passff.py"))))))) (inputs (list password-store python)) (synopsis "Host app for the WebExtension PassFF") (description "This piece of software wraps around the zx2c4 pass shell command. It has to be installed for the PassFF browser extension to work properly.") (license license:gpl2+))) (define passff (package (name "passff") (version "1.16") (home-page "https://github.com/passff/passff") (source (origin (method git-fetch) (uri (git-reference (url home-page) (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "0y3cbgy89lgvq6lfabp7mi1zhphdvihcccn3yw5mmaql9yrdm5kc")))) (propagated-inputs (list passff-host)) (build-system copy-build-system) (properties '((addon-id . "passff@invicem.pro"))) (arguments `(#:install-plan '(("src" ,(assq-ref properties 'addon-id))) #:phases (modify-phases %standard-phases (add-after 'unpack 'substitute-placeholder (lambda _ (substitute* "src/manifest.json" (("_VERSIONHOLDER_") ,version))))))) (synopsis "Pass management extension for Mozilla Firefox") (description "This extension will allow you to access your zx2c4 pass repository directly from your web browser. You can choose to automatically fill and submit login forms if a matching password entry is found.") (license license:gpl2+))) (define-public passff/icecat (make-icecat-extension passff)) (define keepassxc-browser (package (name "keepassxc-browser") (version "1.8.10") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/keepassxreboot/keepassxc-browser") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1059kcb95ig18izbchwlb7pz41l4l3vjwzlmhz3w8zw2qxm6hrvx")))) (build-system copy-build-system) (properties '((addon-id . "keepassxc-browser@keepassxc.org"))) (arguments `(#:install-plan '(("keepassxc-browser" ,(assq-ref properties 'addon-id))))) (synopsis "Browser extension for the KeePassXC password manager") (description "This package provides an extension allow the browser to work together with the @uref{https://keepassxc.org, KeePassXC} password manager.") (home-page "https://keepassxc.org") (license license:gpl3+))) (define-public keepassxc-browser/icecat (make-icecat-extension keepassxc-browser)) (define livemarks (package (name "livemarks") (version "3.5") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/nt1m/livemarks") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "02p2080lgnb2xy4n781ydjdywkg7g7hmz6cpnbh6icldbjy5xa5i")))) (build-system copy-build-system) (arguments (list #:install-plan #~'(("." #$(assq-ref (package-properties this-package) 'addon-id))))) (home-page "https://github.com/nt1m/livemarks") (synopsis "RSS feed bookmark folders") (description "This browser extension provides auto-updated RSS feed bookmark folders.") (license license:expat) (properties '((addon-id . "{c5867acc-54c9-4074-9574-04d8818d53e8}"))))) (define-public livemarks/icecat (make-icecat-extension livemarks)) (define noscript (package (name "noscript") (version "12.1.1") (source (origin (method url-fetch/zipbomb) (uri (string-append "https://noscript.net/download/releases/noscript-" version ".xpi")) (sha256 (base32 "06pk3zf353yh7c8bv3xvl1jwmc2bd7v4y3p0dl1m5hygzxirwqzr")))) (build-system copy-build-system) (properties '((addon-id . "{73a6fe31-595d-460b-a920-fcc0f8843232}"))) (arguments `(#:install-plan '(("." ,(assq-ref properties 'addon-id))))) (home-page "https://noscript.net") (synopsis "Software providing extra protection for various browsers") (description "The NoScript Security Suite is a software providing extra protection for web browsers.") (license license:gpl3+))) (define-public noscript/icecat (make-icecat-extension noscript)) (define privacy-redirect (package (name "privacy-redirect") (version "1.1.49") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/SimonBrazell/privacy-redirect") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "13j5i6vh4lq9hcqmqbmn8fnymnplwra5rm696h6magbjxnj3nkyz")))) (build-system copy-build-system) (arguments (list #:install-plan #~'(("src" #$(assq-ref (package-properties this-package) 'addon-id))))) (home-page "https://github.com/SimonBrazell/privacy-redirect") (synopsis "Redirect to privacy friendly alternative frontends") (description "This package provides a browser extension that redirects sites to their privacy friendly alternative frontends. It's possible to toggle all redirects on and off and the extension will default to using random instances if none are selected.") (license license:gpl3) (properties '((addon-id . "{b7f9d2cd-d772-4302-8c3f-eb941af36f76}"))))) (define-public privacy-redirect/icecat (make-icecat-extension privacy-redirect))