aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ntp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages libevent)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages nettle)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages ruby)
  #:use-module (gnu packages tls)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (srfi srfi-1))

(define-public chrony
  (package
    (name "chrony")
    (version "4.5")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://gitlab.com/chrony/chrony")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0w6wgpgvwidsfc4mmi5zb73y9lydzwgwxpj0q5r1m47gd1qxa24n"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:modules
      '((srfi srfi-26)
        (guix build utils)
        (guix build gnu-build-system))
      #:configure-flags
      #~(list "--enable-scfilter"
              "--with-sendmail=sendmail"
              "--with-user=chrony")
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'set-CC
            (lambda _
              (setenv "CC" #$(cc-for-target))))
          (add-after 'unpack 'stay-inside-out
            ;; Simply setting CHRONYVARDIR to something nonsensical at install
            ;; time would result in nonsense file names in man pages.
            (lambda _
              (substitute* "Makefile.in"
                (("mkdir -p \\$\\(DESTDIR\\)\\$\\(CHRONYVARDIR\\)") ":"))))
          (add-after 'install 'install-more-documentation
            (lambda _
              (let* ((doc (string-append #$output "/share/doc/"
                                         #$name "-" #$version)))
                (for-each (cut install-file <> doc)
                          (list "README"))
                (copy-recursively "examples"
                                  (string-append doc "/examples"))))))))
    (native-inputs
     (list bison ruby-asciidoctor pkg-config))
    (inputs
     (list gnutls libcap libseccomp nettle))
    (home-page "https://chrony-project.org/")
    (synopsis "System clock synchronization service that speaks NTP")
    (description
     "Chrony keeps your system time accurate.  It synchronises your computer's
clock with @acronym{NTP, Network Time Protocol} servers, reference clocks such
as GPS receivers, or even manual input of the correct time from a wristwatch.

Chrony will determine the rate at which the computer gains or loses time, and
compensate for it.  It can also operate as an
NTPv4 (@url{https://www.rfc-editor.org/rfc/rfc5905, RFC 5905}) server and peer to
tell time to other computers on the network.

It's designed to perform well even under adverse conditions: congested
networks, unreliable clocks drifting with changes in temperature, and devices
or virtual machines that are frequently turned off and connect to the Internet
for only a few minutes at a time.

Typical accuracy when synchronised over the Internet is several milliseconds.
On a local network this can reach tens of microseconds.  With hardware
time-stamping or reference clock, sub-microsecond accuracy is possible.")
    (license l:gpl2)))

(define-public ntp
  (package
   (name "ntp")
   (version "4.2.8p17")
   (source
     (origin
       (method url-fetch)
       (uri (list (string-append
                   "https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-"
                   (version-major+minor version)
                   "/ntp-" version ".tar.gz")
                  (string-append
                   "http://archive.ntp.org/ntp4/ntp-"
                   (version-major+minor version)
                   "/ntp-" version ".tar.gz")))
       (sha256
        (base32 "0rm8sf4qwcip49wgpgcp2dpwspsm0ad5xkkxy26mnv56wrrd4g8h"))
       (modules '((guix build utils)))
       (snippet
        '(begin
           ;; Remove the bundled copy of libevent, but we must keep
           ;; sntp/libevent/build-aux since configure.ac contains
           ;; AC_CONFIG_AUX_DIR([sntp/libevent/build-aux])
           (rename-file "sntp/libevent/build-aux"
                        "sntp/libevent:build-aux")
           (delete-file-recursively "sntp/libevent")
           (mkdir "sntp/libevent")
           (rename-file "sntp/libevent:build-aux"
                        "sntp/libevent/build-aux")))))
   (native-inputs (list which pkg-config))
   (inputs
    (cons* openssl-1.1
           libevent
           ;; Build with POSIX capabilities support on GNU/Linux.  This allows
           ;; 'ntpd' to run as non-root (when invoked with '-u'.)
           (if (target-linux?)
               (list libcap)
               '())))
   (arguments
    (list
     ;; Pass "--with-yielding-select=yes" so that 'configure' knows whether
     ;; 'select' yields when using pthreads in a cross-compilation context.
     #:configure-flags
     #~(list "--with-yielding-select=yes")
     #:phases
     #~(modify-phases %standard-phases
         (add-after 'unpack 'disable-network-test
           (lambda _
             (substitute* "tests/libntp/Makefile.in"
               (("test-decodenetnum\\$\\(EXEEXT\\) ") "")))))))
   (build-system gnu-build-system)
   (synopsis "Real time clock synchronization system")
   (description "NTP is a system designed to synchronize the clocks of
computers over a network.")
   (license (l:x11-style
             "https://www.eecis.udel.edu/~mills/ntp/html/copyright.html"
             "A non-copyleft free licence from the University of Delaware"))
   (home-page "https://www.ntp.org")))

(define-public openntpd
  (package
    (name "openntpd")
    (version "6.8p1")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "mirror://openbsd/OpenNTPD/openntpd-" version ".tar.gz"))
              (sha256
               (base32
                "0ijsylc7a4jlpxsqa0jq1w1c7333id8pcakzl7a5749ria1xp0l5"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (let* ((libressl (assoc-ref %build-inputs "libressl"))
              (libressl-version ,(package-version
                                  (car (assoc-ref (package-inputs this-package)
                                                  "libressl")))))
         (list "--with-privsep-user=ntpd"
               "--localstatedir=/var"
               (string-append "--with-cacert=" libressl
                              "/share/libressl-" libressl-version
                              "/cert.pem")))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'modify-install-locations
           (lambda _
             ;; Don't try to create /var/run or /var/db
             (substitute* "src/Makefile.in"
               (("DESTDIR\\)\\$\\(localstatedir") "TMPDIR"))
             #t)))))
    (inputs
     (list libressl)) ; enable TLS time constraints. See ntpd.conf(5).
    (home-page "https://www.openntpd.org/")
    (synopsis "NTP client and server by the OpenBSD Project")
    (description "OpenNTPD is the OpenBSD Project's implementation of a client
and server for the Network Time Protocol.  Its design goals include being
secure, easy to configure, and accurate enough for most purposes, so it's more
minimalist than ntpd.")
    (properties
     '((release-monitoring-url . "https://cdn.openbsd.org/pub/OpenBSD/OpenNTPD")))
    ;; A few of the source files are under bsd-3.
    (license (list l:isc l:bsd-3))))
))) ; TODO: Enable the tests
@@ -924,13 +924,13 @@ consume data received from the server, or both.")))
(define-public qtsensors
(package (inherit qtsvg)
(name "qtsensors")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1sz5mhhmmpqhxjibcr58vl7i6kyb4irsnrvrbxy1b14z9qk4563k"))))
+ "0zlhm4js02niibb23rw87wf4ik0gy4ai08fwprnwy7zf4rm1ss3d"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:parallel-tests? _ #f) #f) ; can lead to race condition
@@ -952,13 +952,13 @@ recognition API for devices.")))
(define-public qtmultimedia
(package (inherit qtsvg)
(name "qtmultimedia")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1m132sag2kkdf1hdnj0rii5bs89hx6f7vhq72h3767sbrinasm92"))
+ "0q76iy1frcgm85mid17lh4p6gnn04n19n6zklgpv4w3md1ng97xw"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -996,13 +996,13 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(define-public qtwayland
(package (inherit qtsvg)
(name "qtwayland")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "04qklfix0sadx3cckq88y83m6src809sy6gzih6gl43nmrrmg4br"))))
+ "0yy8qf9kn15iqsxi2r7jbcsc0vsdyfz7bbxmfn4i9qmz1yvg0jgr"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1043,13 +1043,13 @@ compositor libraries.")))
(define-public qtserialport
(package (inherit qtsvg)
(name "qtserialport")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "107hv5bhbn6ry238lsgvijn87dwyb1zry32pbidpiymk9lby31p5"))))
+ "0xg2djwhrj5jqamawlp75g70nmwbp2ph2hh1pm45s36jkxm0k7al"))))
(native-inputs (list perl))
(inputs
(list qtbase-5 eudev))
@@ -1072,13 +1072,13 @@ interacting with serial ports from within Qt.")))
(define-public qtserialbus
(package (inherit qtsvg)
(name "qtserialbus")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "069say286c6yaii4xvw8ikg4zqfmsw2xh9gsg0fnip8qfbasfpfd"))))
+ "180gm1jvqfn0h3251zafdd1wd3af00phwaa5qljsbrj6s6ywj79j"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases '%standard-phases)
@@ -1101,13 +1101,13 @@ and others.")))
(define-public qtwebchannel
(package (inherit qtsvg)
(name "qtwebchannel")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1mykpxilsc6qqj3liza7z192lmy9xvnqih7x62v5b1pqbzan9lfs"))))
+ "1w8mcpdqlphgg3a6yfq18liwlj2nkwrafv0n80h242x5l2mk3ljf"))))
(native-inputs
(list perl qtdeclarative qtwebsockets))
(inputs (list qtbase-5))
@@ -1120,13 +1120,13 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(define-public qtwebglplugin
(package (inherit qtsvg)
(name "qtwebglplugin")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0xsjvzasy0ihbinnvrximi1qkiz2fazqksdf8mpj5kbnn2wbi470"))))
+ "1m0p4ssykw07lbip2qyv6w34f8ng13bxb63j0w446f5w0492nn9f"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1148,13 +1148,13 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(define-public qtwebview
(package (inherit qtsvg)
(name "qtwebview")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1djq8wmgjb2q60dw05spi5wbp4ipj9iqal41pq7j55qszrvawk30"))))
+ "0arwaky3jy5ql3z4d8f7k7diidzb1kncdans7pn50hsa1bzacfal"))))
(native-inputs
(list perl))
(inputs
@@ -1167,13 +1167,13 @@ native APIs where it makes sense.")))
(define-public qtlocation
(package (inherit qtsvg)
(name "qtlocation")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0b3r6d2m2spc5s6mzxz30ph4279rb0jcq2rvkackq15p17kv42v2"))))
+ "0mlhhhcxx3gpr9kh04c6fljxcj50c2j21r0wb9f7d7nk4flip7b2"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f) ; TODO: Enable the tests
@@ -1193,13 +1193,13 @@ positioning and geolocation plugins.")))
(define-public qttools
(package (inherit qtsvg)
(name "qttools")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0cxkc1gg11mnh5fk5kjgkw7ra0v28mgr668lfd63s3z7va7wyp2c"))))
+ "0v7wkzq9i8w3qrw0z8al7lb6clr57lfisyb1fm9cnhi73fvph1vd"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1215,13 +1215,13 @@ that helps in Qt development.")))
(define-public qtscript
(package (inherit qtsvg)
(name "qtscript")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1ivm71wvbyc7s78w2wag2r5byxwnrccj40q3l98890q328ffassq"))
+ "17yk0p8ci47xlfpllc17arlycng47wrnnskimskzz85bspabc8pm"))
(patches (search-patches "qtscript-disable-tests.patch"))))
(native-inputs
(list perl qttools))
@@ -1235,13 +1235,13 @@ ECMAScript and Qt.")))
(define-public qtquickcontrols
(package (inherit qtsvg)
(name "qtquickcontrols")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0gipsaay2s1krqrvqq85d5p0bshf8vqb4px48qmvrlb8c8gqa2d9"))))
+ "0mjw25wcgd2bvjz9rr4qjydb423c63615rcx1vws4jmydqdihssr"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1255,13 +1255,13 @@ can be used to build complete interfaces in Qt Quick.")))
(define-public qtquickcontrols2
(package (inherit qtsvg)
(name "qtquickcontrols2")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "116lgjx635knk0b9wn7qdigjls1wkyhzbcv1pp8c6hr6jlz4qa19"))))
+ "1cxg4ml07k1zcyi5m4lx06sz8f5l67isb5vhk7nakxm0wnn7p8y4"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1276,13 +1276,13 @@ not available.")))
(define-public qtgraphicaleffects
(package (inherit qtsvg)
(name "qtgraphicaleffects")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0nv4a7j1q9pzh0zlb7bgfdrgs9vl6sp085zq63li05sw90kzrqdx"))))
+ "0xznn5zqp6xrqfgl54l8cig9asqf9m2hz0p3ga514rh8spmdazr3"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1299,13 +1299,13 @@ coloring, and many more.")))
(define-public qtgamepad
(package (inherit qtsvg)
(name "qtgamepad")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0fv0cdhla1yqymxbr2x3v826881aw32ysnhqgyvi0n4j83knjik4"))))
+ "0wa4d8f025hlp4bmdzdy5wcahm9wjg6bkwig8dpw9nrsj3idz5b0"))))
(native-inputs
(list perl pkg-config))
(inputs
@@ -1325,13 +1325,13 @@ and mobile applications targeting TV-like form factors.")))
(define-public qtscxml
(package (inherit qtsvg)
(name "qtscxml")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0z2hzkvw3aa1kkg7axfq75qfcvlbd57f2n8n89xsl0s368g0cmhz"))
+ "0xf5mqsrw16h8xjglymgfc8qg2qa5bi4fgdl4j3dkhvvpr7vrphp"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1339,6 +1339,9 @@ and mobile applications targeting TV-like form factors.")))
;; the scion test refers to the bundled 3rd party test code.
(substitute* "tests/auto/auto.pro"
(("scion") "#"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:tests? _ #f) #f))) ; TODO: Enable the tests
(inputs
(list qtbase-5 qtdeclarative))
(synopsis "Qt SCXML module")
@@ -1351,13 +1354,13 @@ also contains functionality to support data models and executable content.")))
(define-public qtpurchasing
(package (inherit qtsvg)
(name "qtpurchasing")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0aw23r9i3p6c812d0z82c80ynapjrq2w446ajw9rdxg63id25475"))))
+ "04z6mwzn73gg56hgs7gividinfgndx4kmcnp7w6h3wamrdlkfdx7"))))
(inputs
(list qtbase-5 qtdeclarative))
(synopsis "Qt Purchasing module")
@@ -1367,13 +1370,13 @@ purchasing goods and services.")))
(define-public qtcharts
(package (inherit qtsvg)
(name "qtcharts")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0f7f677yrnkw2yvkhg1zsb56w0yq8wmfq3irhachds0l79k3gj9k"))))
+ "0y051i1837bfybkf8cm7cx8k5wjmbi47pxawaaz6wm0hd2z5b4qi"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1396,13 +1399,13 @@ selecting one of the charts themes.")
(define-public qtdatavis3d
(package (inherit qtsvg)
(name "qtdatavis3d")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0jizz4a5iss4bzy65jl2mwdjv63fh1xz3f0ipnrbs6r5qp1x9csd"))))
+ "0sczwqlc36jdywf7bqxz0hm6mr7fn8p1fsnc33jliiqzn9yrg77x"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1419,13 +1422,13 @@ customized by using themes or by adding custom items and labels to them.")
(define-public qtnetworkauth
(package (inherit qtsvg)
(name "qtnetworkauth")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "0714va9qda4qkrzb5zlin6v3wxh3ihhbh4nqqba5l1b152qwjhja"))))
+ "0c7mz715rlpg0cqgs6s0aszmslyamkhnpamc1iij6i571sj5j2f1"))))
(inputs
(list qtbase-5))
(synopsis "Qt Network Authorization module")
@@ -1435,13 +1438,13 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(define-public qtremoteobjects
(package (inherit qtsvg)
(name "qtremoteobjects")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "00f6n4byf129gh0l903dhrdpxm5zch5y7zrsrmm3nayhgvl1ii75"))))
+ "1m0xcqlbxsfn0cd4ajin1h3i4l51dajmkw91v0r4a61xi14i0kks"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1467,13 +1470,13 @@ processes or computers.")))
(define-public qtspeech
(package (inherit qtsvg)
(name "qtspeech")
- (version "5.15.4")
+ (version "5.15.5")
(source (origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "16dg5y19qmyjzlyny34rcbl74h69b8c18ysf797x6gnsa3h8glzk"))))
+ "0xskp9dzjy5nqszygk8gwvjyiylgynx5sq3nk2vi3zwgfdh5jpm4"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1522,14 +1525,14 @@ using the Enchant spell-checking library.")
(package
(inherit qtsvg)
(name "qtwebengine")
- (version "5.15.4")
+ (version "5.15.5")
(source
(origin
(method url-fetch)
(uri (qt5-urls name version))
(sha256
(base32
- "1jhgv9mrn6m40z24a3jil37nyga1m6bgxzch3ycdhi9crwxr0ala"))
+ "0zahr9w6rqdxwh2whsgk3fhcszs7wa9j95lq4sqi8xzin2wcgl17"))
(modules '((ice-9 ftw)
(ice-9 match)
(srfi srfi-1)
@@ -1798,6 +1801,7 @@ using the Enchant spell-checking library.")
libxcb
libxcomposite
libxcursor
+ libxkbfile
libxi
libxkbcommon
;; FIXME: libxml2 needs to built with icu support though it links to