aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages noweb)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages perl))

(define-public noweb
  (package
    (name "noweb")
    (version "2.13")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/nrnrnr/noweb")
             (commit (string-append "v" (string-join (string-split version #\.)
                                                     "_")))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0fwngh7zl9mrjz966pskhi4zvk26j6vsm85x99df9194nv51drq8"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:make-flags
      #~(list (string-append "BIN=" #$output "/bin")
              (string-append "LIB=" #$output "/lib")
              (string-append "MAN=" #$output "/share/man")
              (string-append "TEXINPUTS=" #$output
                             "/share/texmf/tex/latex"))
      #:modules
      '((guix build gnu-build-system)
        (guix build utils)
        (srfi srfi-26))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'enter-source-directory
            (lambda _
              (chdir "src")))
          (add-after 'enter-source-directory 'bind-early
            (lambda _
              (substitute* (list "lib/nwmtime"
                                 "shell/htmltoc")
                (("exec perl ")
                 (string-append "exec " (which "perl") " ")))
              (substitute* "shell/noweb"
                ((" cpif ")
                 (string-append " " #$output "/bin/cpif ")))))
          (delete 'configure)           ; no configure script
          (add-before 'install 'create-latex-directory
            (lambda _
              (mkdir-p (string-append #$output "/share/texmf/tex/latex"))))
          (add-after 'install 'refer-to-inputs
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion #$output
                (for-each (lambda (program)
                            (substitute* program
                              (("nawk")
                               (search-input-file inputs "bin/awk"))))
                          (append (map (cut string-append "bin/" <>)
                                       '("noweb" "nountangle"
                                         "noroots" "noroff"
                                         "noindex"))
                                  (map (cut string-append "lib/" <>)
                                       '("btdefn" "emptydefn" "noidx"
                                         "pipedocs" "toascii" "tohtml"
                                         "toroff" "totex" "unmarkup"))))
                (substitute* "bin/cpif"
                  (("^PATH=.*$")
                   (string-append "PATH="
                                  (dirname (search-input-file
                                            inputs"bin/basename")) ":"
                                  (dirname (search-input-file
                                            inputs "bin/cmp"))
                                  "\n")))))))
      #:tests? #f))                              ; no tests
    (inputs
     (list perl))
    (home-page "https://www.cs.tufts.edu/~nr/noweb/")
    (synopsis "Literate programming tool")
    (description
     "Noweb is designed to meet the needs of literate programmers while
remaining as simple as possible.  Its primary advantages are simplicity,
extensibility, and language-independence—especially noticeable when compared
with other literate-programming tools.  noweb uses 5 control sequences to
WEB's 27.  The noweb manual is only 4 pages; an additional page explains how
to customize its LaTeX output.  noweb works “out of the box” with any
programming language, and supports TeX, LaTeX, HTML, and troff back ends.")
    (license
     (list bsd-2                        ; dual-licenced under this and…
           (fsf-free "https://www.cs.tufts.edu/~nr/noweb/#copyright")))))
, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-07-01gnu: premake@5: Update to 5.0.0-alpha15....* gnu/packages/build-tools.scm (premake5): Update to 5.0.0-alpha15. [arguments]: Modify ‘enter-source’ phase. Tobias Geerinckx-Rice 2020-06-22gnu: gn: Update to 0.0-1794.eb997b5....* gnu/packages/build-tools.scm (gn): Update to 0.0-1794.eb997b5. Marius Bakke 2020-06-16gnu: tup: Update to 0.7.9....* gnu/packages/build-tools.scm (tup): Update to 0.7.9. Tobias Geerinckx-Rice 2020-06-14gnu: Add tup....* gnu/packages/build-tools.scm (tup): New variable. * gnu/packages/patches/tup-unbundle-dependencies.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new file. Jakub Kądziołka 2020-05-28gnu: Add compiledb....* gnu/packages/build-tools.scm (compiledb): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Yuval Kogman 2020-04-13Merge branch 'master' into core-updatesMarius Bakke 2020-04-12gnu: gn: Update to 0.0-1736.ec938dd....* gnu/packages/build-tools.scm (gn): Update to 0.0-1736.ec938dd. [arguments]: Adjust last_commit_position.h for upstream changes. Marius Bakke 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-20gnu: add premake5....* gnu/packages/build-tools.scm (premake5): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Leo Prikler 2020-03-05gnu: meson: Update to 0.53.2....* gnu/packages/build-tools.scm (meson): Update to 0.53.2. Marius Bakke 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-18gnu: bear: Update to 2.4.3....* gnu/packages/build-tools.scm (bear): Update to 2.4.3. Tobias Geerinckx-Rice 2020-01-24gnu: meson: Update to 0.53.1....* gnu/packages/build-tools.scm (meson): Update to 0.53.1. Marius Bakke 2020-01-08gnu: meson: Update to 0.53.0....* gnu/packages/build-tools.scm (meson): Update to 0.53.0. Marius Bakke 2019-12-31Merge remote-tracking branch 'master' into core-updates.Mathieu Othacehe 2019-12-19Update email for Brett Gilio....* .mailmap: Add name and email for Brett Gilio. * gnu/local.mk, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/bittorrent.scm, gnu/packages/build-tools.scm, gnu/packages/cran.scm, gnu/packages/emacs-xyz.scm, gnu/packages/messaging.scm, gnu/packages/python-xyz.scm, gnu/packages/sml.scm, gnu/packages/terminals.scm, gnu/packages/wm.scm: Update email for Brett Gilio. Brett Gilio 2019-12-05gnu: meson: Update to 0.52.1....* gnu/packages/build-tools.scm (meson): Update to 0.52.1. Marius Bakke 2019-11-22gnu: bear: Update to 2.4.2....* gnu/packages/build-tools.scm (bear): Update to 2.4.2. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Brett Gilio 2019-11-15gnu: gn: Enable tests....* gnu/packages/build-tools.scm (gn)[arguments]: Remove #:tests?. Override 'check' phase. Marius Bakke 2019-11-15gnu: gn: Update to 0.0-1666.6e5ba2e....* gnu/packages/build-tools.scm (gn): Update to 0.0-1666.6e5ba2e. [arguments]: Do not override LDFLAGS. Marius Bakke 2019-07-17Merge branch 'master' into core-updatesLudovic Courtès 2019-07-16gnu: osc: Update to 0.165.2....* gnu/packages/build-tools.scm (osc): Update to 0.165.2. Tobias Geerinckx-Rice 2019-06-30Revert "gnu: meson: Update to 0.51.0."...Meson 0.51.0 has problems with PKG_CONFIG_PATH. See <https://bugs.gnu.org/36386>. This reverts commit 70530036b8313d5273fca286cd62c73bd2225110. Marius Bakke 2019-06-20gnu: meson: Update to 0.51.0....* gnu/packages/build-tools.scm (meson): Update to 0.51.0. Marius Bakke 2019-06-13Merge branch 'master' into core-updatesLudovic Courtès 2019-06-07gnu: osc: Update to 0.165.1....* gnu/packages/build-tools.scm (osc): Update to 0.165.1. Tobias Geerinckx-Rice 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-11gnu: osc: Update to 0.165.0....* gnu/packages/build-tools.scm (osc): Update to 0.165.0. [source]: Use git-fetch. [arguments]: Use python3. osc_hotshot.py is gone. So, do not attempt to delete it. Rename fix-filename-and-remove-unused phase to fix-filename phase. [inputs]: Add rpm. Remove python2-urlgrabber. Replace python2-m2crypto and python2-pycurl with python-m2crypto and python-pycurl. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net> Jonathan Brielmaier 2019-05-04gnu: meson: Update to 0.50.1....* gnu/packages/build-tools.scm (meson): Update to 0.50.1. Marius Bakke 2019-03-15gnu: meson: Update to 0.50.0....* gnu/packages/build-tools.scm (meson): Update to 0.50.0. * gnu/packages/patches/at-spi2-core-meson-compat.patch, gnu/packages/patches/totem-meson-compat.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gnome.scm (totem)[source](patches): Add totem-meson.compat.patch. * gnu/packages/gtk.scm (at-spi2-core)[source](patches): New field. Marius Bakke 2019-02-24Merge branch 'master' into stagingMarius Bakke 2019-02-22gnu: gn: Update to commit 1ab6fa2cab7ec64840db720a56018ca8939329f9....* gnu/packages/build-tools.scm (gn): Update to 0.0-1530.1ab6fa2. [arguments]: Add LDFLAGS. Remove obsolete configure flag. Marius Bakke 2019-02-20gnu: bear: Update to 2.3.13....* gnu/packages/build-tools.scm (bear): Update to 2.3.13. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Brett Gilio 2019-02-10gnu: meson: Update to 0.49.2....* gnu/packages/build-tools.scm (meson): Update to 0.49.2. Marius Bakke 2018-12-12gnu: meson: Update to 0.49.0....* gnu/packages/build-tools.scm (meson): Update to 0.49.0. Marius Bakke 2018-12-04gnu: meson: Update to 0.48.2...* gnu/packages/build-tools.scm (meson): Update to 0.48.2. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Brett Gilio 2018-11-22Merge branch 'master' into core-updatesMarius Bakke 2018-11-22gnu: bam: Update to 0.5.1....* gnu/packages/build-tools.scm (bam): Update to 0.5.1. [source]: Switch to git-fetch. [arguments]: Use newly provided Makefile. [inputs]: Add lua. Alex Vong 2018-10-22Merge branch 'master' into core-updatesMarius Bakke 2018-10-22gnu: Add GN....* gnu/packages/build-tools.scm (gn): New public variable. Marius Bakke 2018-09-09gnu: meson: Update to 0.47.2....* gnu/packages/build-tools.scm (meson): Update to 0.47.2. Marius Bakke 2018-08-13Merge branch 'staging' into core-updatesRicardo Wurmus