aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages noweb)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages perl))

(define-public noweb
  (package
    (name "noweb")
    (version "2.13")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/nrnrnr/noweb")
             (commit (string-append "v" (string-join (string-split version #\.)
                                                     "_")))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0fwngh7zl9mrjz966pskhi4zvk26j6vsm85x99df9194nv51drq8"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:make-flags
      #~(list (string-append "BIN=" #$output "/bin")
              (string-append "LIB=" #$output "/lib")
              (string-append "MAN=" #$output "/share/man")
              (string-append "TEXINPUTS=" #$output
                             "/share/texmf/tex/latex"))
      #:modules
      '((guix build gnu-build-system)
        (guix build utils)
        (srfi srfi-26))
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'enter-source-directory
            (lambda _
              (chdir "src")))
          (add-after 'enter-source-directory 'bind-early
            (lambda _
              (substitute* (list "lib/nwmtime"
                                 "shell/htmltoc")
                (("exec perl ")
                 (string-append "exec " (which "perl") " ")))
              (substitute* "shell/noweb"
                ((" cpif ")
                 (string-append " " #$output "/bin/cpif ")))))
          (delete 'configure)           ; no configure script
          (add-before 'install 'create-latex-directory
            (lambda _
              (mkdir-p (string-append #$output "/share/texmf/tex/latex"))))
          (add-after 'install 'refer-to-inputs
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion #$output
                (for-each (lambda (program)
                            (substitute* program
                              (("nawk")
                               (search-input-file inputs "bin/awk"))))
                          (append (map (cut string-append "bin/" <>)
                                       '("noweb" "nountangle"
                                         "noroots" "noroff"
                                         "noindex"))
                                  (map (cut string-append "lib/" <>)
                                       '("btdefn" "emptydefn" "noidx"
                                         "pipedocs" "toascii" "tohtml"
                                         "toroff" "totex" "unmarkup"))))
                (substitute* "bin/cpif"
                  (("^PATH=.*$")
                   (string-append "PATH="
                                  (dirname (search-input-file
                                            inputs"bin/basename")) ":"
                                  (dirname (search-input-file
                                            inputs "bin/cmp"))
                                  "\n")))))))
      #:tests? #f))                              ; no tests
    (inputs
     (list perl))
    (home-page "https://www.cs.tufts.edu/~nr/noweb/")
    (synopsis "Literate programming tool")
    (description
     "Noweb is designed to meet the needs of literate programmers while
remaining as simple as possible.  Its primary advantages are simplicity,
extensibility, and language-independence—especially noticeable when compared
with other literate-programming tools.  noweb uses 5 control sequences to
WEB's 27.  The noweb manual is only 4 pages; an additional page explains how
to customize its LaTeX output.  noweb works “out of the box” with any
programming language, and supports TeX, LaTeX, HTML, and troff back ends.")
    (license
     (list bsd-2                        ; dual-licenced under this and…
           (fsf-free "https://www.cs.tufts.edu/~nr/noweb/#copyright")))))
00'>2020-08-18gnu: Add glibmm-2.64....*gnu/packages/glib.scm (glibmm-2.64): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-08-18gnu: Add libsigc++-2....* gnu/packages/glib.scm (libsigc++-2): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-06-25gnu: glib: Hide 'zip' binding from SRFI-1....* gnu/packages/glib.scm: Hide 'zip' from (srfi srfi-1). Ludovic Courtès 2020-06-22gnu: template-glib: Update to 3.34.0....* gnu/packages/glib.scm (template-glib): Update to 3.34.0. Signed-off-by: Marius Bakke <marius@gnu.org> Giacomo Leidi 2020-06-02gnu: dbus: Fix CVE-2020-12049....* gnu/packages/patches/dbus-CVE-2020-12049.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (dbus/fixed): New variable. (dbus)[replacement]: New field. Marius Bakke 2020-05-14gnu: Add dbus-test-runner....* gnu/packages/glib.scm (dbus-test-runner): New variable. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz> Nicolò Balzarotti 2020-05-13gnu: appstream-glib: Remove unused input....* gnu/packages/glib.scm (appstream-glib)[inputs]: Remove LIBYAML. Marius Bakke 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-26gnu: perl-glib: Update to 1.3292....* gnu/packages/glib.scm (perl-glib): Update to 1.3292. Efraim Flashner 2020-04-18gnu: telepathy-glib: Disable failing tests....* gnu/packages/glib.scm (telepathy-glib)[arguments]: Add phase to disable failing tests. (cherry picked from commit 9049e4d808f241dd88ddcb6a0f74b0766624fb08) Kei Kebreau 2020-04-18gnu: dbus-glib: Update to 0.110....* gnu/packages/glib.scm (dbus-glib): Update to 0.110. (cherry picked from commit cff7f2f521a662d0dc01a07b5d7c2c61a7b47072) Kei Kebreau 2020-03-26gnu: libsigc++: Update to 2.10.3....* gnu/packages/glib.scm (libsigc++): Update to 2.10.3. Marius Bakke 2020-03-26gnu: GLib: Update to 2.62.6....* gnu/packages/glib.scm (glib): Update to 2.62.6. Marius Bakke 2020-03-05gnu: glib: Update to 2.62.5....* gnu/packages/glib.scm (glib): Update to 2.62.5. Marius Bakke 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-03-04gnu: appstream-glib: Update to 0.7.17....* gnu/packages/patches/appstream-glib-2020.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (appstream-glib): Update to 0.7.17. [source](patches): Remove. Marius Bakke 2020-03-04gnu: Update pypi.python.org home pages & use HTTPS....* gnu/packages/check.scm (python-unittest2, python-pytest-localserver) (python-discover)[home-page]: Follow (HTTPS) redirections. * gnu/packages/fontutils.scm (python2-defcon)[home-page]: Likewise. * gnu/packages/glib.scm (python2-pygobject-2)[home-page]: Likewise. * gnu/packages/graph.scm (python-igraph)[home-page]: Likewise. * gnu/packages/graphviz.scm (xdot)[home-page]: Likewise. * gnu/packages/pdf.scm (python-poppler-qt5)[home-page]: Likewise. * gnu/packages/python-web.scm (python-zope-event, python-zope-testing) (python-zope-testrunner, python-zope-i18nmessageid, python-zope-schema) (python-zope-configuration, python-zope-proxy, python-zope-location) (python-zope-security))[home-page]: Likewise. * gnu/packages/python-xyz.scm (python-setuptools,python-six) (python2-dogtail, python2-enum, python-enum34, python-unidecode) (python-numpydoc, python-decorator, python-drmaa, python-pathlib2) (python-ly, python-msgpack, python-termcolor, python-colorama) (python-pluggy, python2-pathlib2, python-rfc3987)[home-page]: Likewise. Tobias Geerinckx-Rice