aboutsummaryrefslogtreecommitdiff
;;; Copyright © 2021 Blake Shaw <blake@nonconstructivism.com>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages notcurses)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix build utils)
  #:use-module (guix download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages check)
  #:use-module (gnu packages haskell-xyz)
  #:use-module (gnu packages video)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages libunistring))

(define-public notcurses
  (package
    (name "notcurses")
    (version "3.0.9")
    (source
     (origin
       (method url-fetch)
       ;; Note: the upstream git repository contains non-free media (see the
       ;; documentation for DFSG_BUILD; but the project provides a sanitized
       ;; tarball for distributions.  If switching to a git source, we need
       ;; to find a way to elide the non-free demos with a source 'snippet'.
       (uri (string-append "https://github.com/dankamongmen/notcurses/releases"
                           "/download/v" version "/notcurses_" version
                           "+dfsg.1.orig.tar.xz"))
       (file-name (string-append name "-" version ".tar.xz"))
       (sha256
        (base32 "1sj2m7sil2i3yw73z15947kypsp0rnapwpwanwzam15lbicc8c3y"))))
    (build-system cmake-build-system)
    (arguments
     `(#:make-flags
       (list (string-append "CC=" ,(cc-for-target)))
       ;; These flags are documented in 'INSTALL.md' in the source distribution.
       #:configure-flags
       '( ;; Do not build "coverage"
         "-DUSE_COVERAGE=off"
         ;; Do not build HTML documentation
         "-DUSE_DOXYGEN=off"
         ;; Unfortunately this disables the manpages.
         ,@(if (supported-package? pandoc)
             '()
             '("-DUSE_PANDOC=off"))
         ;; Don't include mouse support
         "-DUSE_GPM=off"
         ;; Use FFmpeg for multimedia support
         "-DUSE_MULTIMEDIA=ffmpeg"
         ;; Follow the Debian Free Software Guidelines, omitting nonfree content.
         "-DDFSG_BUILD=ON")))
    (native-inputs
     (append
       (list pkg-config)
       (if (supported-package? pandoc)
         (list pandoc)
         '())
       (list doctest)))
    (inputs
     (list ffmpeg
           libdeflate
           libunistring
           ncurses
           zlib))
    (synopsis "Textual user interfaces")
    (description "Notcurses is a library for building complex textual user
interfaces on modern terminals.")
    (home-page "https://notcurses.com")
    (license license:asl2.0)))
ages/texlive.scm (%texlive-date): Update to 20230313. (%texlive-version): Rename to... (%texlive-year): ...this. (texlive-extra-src, texlive-texmf-src, texlivebin): Update source hashes. (texlivebin, texlivetexmf, texlive): Use %texlive-date for version. (texlivebin)[arguments]: Remove 'skip-mendex-tests phase, which does not apply any more. Remove 'patch-dvisvgm-build-files, which apparently is not needed any more. Remove a configure flag which is not recognized by the configure script any more. Andreas Enge 2023-08-17gnu: biber: Update to 2.17....* gnu/packages/texlive.scm (biber): Update to 2.17. Andreas Enge 2023-08-17gnu: texlive: Update to 2022....* gnu/packages/texlive.scm (%texlive-date): Update to 20220321. (texlive-extra-src, texlive-texmf-src, texlivebin): Update source hashes. Andreas Enge 2023-08-17gnu: texlive: Simplify the monolithic build....This removes phases added for the needs of the modular build system. It reverts commit dfdc002c9bf86270941823a96abded0aa5d44088 and subsequent ones, which download scripts from subversion instead of using those from the distribution. It also reverts the changes started in commit 04a0b1e09abce99857e7930336421ca6d15ae630 and removes the GUIX_TEXMF environment variable. * gnu/packages/texlive.scm (%texlive-tag, %texlive-revision): Remove variables. (texlivebin)[inputs]: Remove texlive-scripts. [phases]: Remove 'unpack-texlive-scripts, 'patch-scripts and 'customize-texmf.cnf and the script handling in 'post-install. [native-search-paths]: Remove them. Andreas Enge 2023-08-17gnu: texlive: Reinstate the monolithic texlive package....This goes back essentially to commit ad457d01147b8d6fcb4ee64b2dc2d699caa1d1ee and defines the monolithic texlive packages independently of the modular ones. It also downgrades their version to 2021. Not using dashes in the names of texlivebin and texlivetexmf prevents the profile hook for font mapping from being run during the command "guix shell -D texlive". * gnu/packages/tex.scm (texlive-bin-full): Remove variable. (biber): Remove variable deprecation. (texlive-texm, texlive): Move variables from here... * gnu/packages/texlive.scm (texlivetexm, texlive): ...to this new file. (%texlive-date, %texlive-version, %texlive-tag, %texlive-revision, texlive-extra-src, texlive-texmf-src, texlivebin): New variables. (biber): Add variable again. * gnu/packages/patches/biber-adapt-perl-5.36.patch: Add file again. * gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Register files. Andreas Enge