aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ninja)
  #:use-module ((guix licenses) #:select (asl2.0))
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages python))

(define-public ninja
  (package
    (name "ninja")
    (version "1.11.1")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/ninja-build/ninja")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "14kshkxdn833nkz2qkzb3w531dcqj6haad90gxj70ic05lb7zx9f"))))
    (build-system gnu-build-system)
    (inputs (list python-wrapper))
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda _
             (substitute* "src/subprocess-posix.cc"
               (("/bin/sh") (which "sh")))
             (substitute* "src/subprocess_test.cc"
               (("/bin/echo") (which "echo")))))
         (replace 'build
           (lambda _
             (invoke "./configure.py" "--bootstrap")))
         (replace 'check
           (lambda _
             (invoke "./configure.py")
             (invoke "./ninja" "ninja_test")
             (invoke "./ninja_test")))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin"))
                    (doc (string-append out "/share/doc/ninja")))
               (install-file "ninja" bin)
               (install-file "doc/manual.asciidoc" doc)))))))
    (home-page "https://ninja-build.org/")
    (synopsis "Small build system")
    (description
     "Ninja is a small build system with a focus on speed.  It differs from
other build systems in two major respects: it is designed to have its input
files generated by a higher-level build system, and it is designed to run
builds as fast as possible.")
    (license asl2.0)))
se latest upstream commit. Use git-version. Correct base version number to 0.7. [source]: Use git-file-name. [arguments]: Use gexps and remove trailing #t in phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andrew Whatson 2023-07-20gnu: tcsh: Skip substitution tests on the Hurd....* gnu/packages/shells.scm (tcsh)[arguments]: When building natively on the Hurd, add phase 'skip-tests'. Janneke Nieuwenhuizen 2023-07-18gnu: zsh: Update to 5.9....* gnu/packages/shells.scm (zsh): Update to 5.9. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Greg Hogan 2023-06-14gnu: linenoise: Update to 1.0-2.93b2db9....* gnu/packages/shells.scm (linenoise): Update to 1.0-2.93b2db9. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> 宋文武 2023-06-01gnu: fish: Update to 3.6.1....* gnu/packages/shells.scm (fish): Update to 3.6.1. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Greg Hogan 2023-05-24gnu: xonsh: Update to 0.14.0....* gnu/packages/shells.scm (xonsh): Update to 0.14.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Edison Ibáñez 2023-05-22gnu: oil: Update to 0.15.0....* gnu/packages/shells.scm (oil): Update to 0.15.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Felix Gruber 2023-04-26gnu: xonsh: Add missing input....Xonsh vim emulation mode/environment variable does not work without this. * gnu/packages/shell.scm (xonsh)[inputs]: Add PYTHON-PROMPT-TOOLKIT. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> jgart 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-06gnu: tcsh: Fix riscv64 cross-compilation....* gnu/packages/shells.scm (tcsh): fix riscv64 cross-build. [arguments]<#:phase>: Add 'update-config-scripts' phase for riscv64. [native-inputs]: Add CONFIG for riscv64. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Z572 2023-03-31gnu: zsh: Patch failing test that uses egrep....* gnu/packages/patches/zsh-egrep-failing-test.patch: New file. * gnu/packages/shells.scm (zsh): Patch it. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-27gnu: oil: Update to 0.14.2....* gnu/packages/shells.scm (oil): Update to 0.14.2. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Gruber 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-26gnu: fish: Update to 3.6.0....* gnu/packages/shells.scm (fish): Update to 3.6.0. [source]: Remove snippet, as the bundled PCRE2 sources have been removed (see CHANGELOG.rst). Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Winter 2023-02-16gnu: scsh: Use a search path....* gnu/packages/shells.scm (scsh)[source]: Add patch. [native-search-paths]: New field. * gnu/packages/patches/scsh-nonstring-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-12-11gnu: oil: Update to 0.12.9....* gnu/packages/shells.scm (oil): Update to 0.12.9. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Capitalise description sentences....* gnu/packages/shells.scm (dash)[description]: Capitalise ‘dash’. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Update to 0.5.12....* gnu/packages/shells.scm (dash): Update to 0.5.12. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2022-12-09gnu: xonsh: Update to 0.13.4....* gnu/packages/shells.scm (xonsh): Update to 0.13.4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Edison Ibáñez 2022-10-26gnu: oil: Update to 0.12.7....* gnu/packages/shells.scm (oil): Update to 0.12.7. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Felix Gruber 2022-09-27Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm Maxim Cournoyer 2022-09-22gnu: xonsh: Update to 0.13.3....* gnu/packages/shells.scm (xonsh): Update to 0.13.3. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> arkhan 2022-08-27Merge branch 'staging' into core-updatesMarius Bakke 2022-08-27gnu: oil: Update to 0.12.4....* gnu/packages/shells.scm (oil): Update to 0.12.4. Signed-off-by: Marius Bakke <marius@gnu.org> Felix Gruber 2022-08-27gnu: xonsh: Update to 0.13.1...* gnu/packages/shells.scm (xonsh): Update to 0.13.0. Signed-off-by: Marius Bakke <marius@gnu.org> arkhan 2022-08-17gnu: fish: Update to 3.5.1....* gnu/packages/shells.scm (fish): Update to 3.5.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Mike Jones 2022-08-11Merge branch 'staging' into core-updatesMarius Bakke 2022-07-27Merge branch 'staging' into core-updatesMarius Bakke 2022-07-24gnu: oil: Update to 0.12.0....* gnu/packages/shells.scm (oil): Update to 0.12.0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Felix Gruber 2022-07-24gnu: es: Use URL-FETCH/TARBOMB....* gnu/packages/shells.scm (es)[source]: Use URL-FETCH/TARBOMB to let us… [arguments]: …delete the ad-hoc 're-enter-rootdir phase. Tobias Geerinckx-Rice 2022-07-24gnu: es: Update to 0.9.2....* gnu/packages/shells.scm (es): Update to 0.9.2. Tobias Geerinckx-Rice 2022-07-22Merge branch 'staging' into core-updatesMarius Bakke 2022-07-12gnu: xonsh: Update to 0.13.0...* gnu/packages/shells.scm (xonsh): Update to 0.13.0. [source]: Rewrite snippet as a gexp. [native-inputs]: Add python-setuptools, python-wheel [inputs]: Add python-distro, python-pygments, python-pyperclip, python-setproctitle Signed-off-by: Ludovic Courtès <ludo@gnu.org> arkhan 2022-06-30gnu: tcsh: Use G-expression....* gnu/packages/shells.scm (tcsh)[arguments]: Rewrite as gexp. Marius Bakke 2022-06-30gnu: tcsh: Update to 6.24.01....* gnu/packages/shells.scm (tcsh): Update to 6.24.01. [source](uri): Switch to new download location. Marius Bakke 2022-06-08Merge branch 'master' into core-updatesLudovic Courtès 2022-05-13gnu: xonsh: Update to 0.12.4....* gnu/packages/shells.scm (xonsh): Update to 0.12.4. [source](snippet): Substitute "xonsh/parsers/completion_context.py". [arguments]: Rewrite #:phases as a gexp. Signed-off-by: Ludovic Courtès <ludo@gnu.org> arkhan