aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2022 Fatima Toothpaste <fatimatoothpaste@disroot.org>
;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages nicotine)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix build-system python)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages mp3)
  #:use-module (gnu packages xorg))

(define-public nicotine+
  (package
    (name "nicotine+")
    (version "3.3.6")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/Nicotine-Plus/nicotine-plus")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1sblhfsyf34lsarjv8b83k20jqfpgcxa1iqbvab05xy52v5y3vcd"))
       (modules '((guix build utils)))
       ;; Remove test that relies on network access.
       (snippet '(delete-file-recursively
                  "pynicotine/tests/unit/test_version.py"))))
    (build-system python-build-system)
    (arguments
     (list
      #:imported-modules `((guix build glib-or-gtk-build-system)
                           ,@%python-build-system-modules)
      #:modules `((guix build utils)
                  (guix build python-build-system)
                  ((guix build glib-or-gtk-build-system)
                   #:prefix glib-or-gtk:))
      #:phases #~(modify-phases %standard-phases
                   (add-after 'install 'wrap-program
                     (lambda _
                       (wrap-program (string-append #$output "/bin/nicotine")
                         `("GI_TYPELIB_PATH" ":" prefix
                           (,(getenv "GI_TYPELIB_PATH"))))))
                   (add-after 'wrap-program 'glib-or-gtk-wrap
                     (assoc-ref glib-or-gtk:%standard-phases
                                'glib-or-gtk-wrap))
                   (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
                     (assoc-ref glib-or-gtk:%standard-phases
                                'glib-or-gtk-compile-schemas))
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (when tests?
                         (invoke "xvfb-run" "python" "-m" "unittest")))))))
    (inputs (list bash-minimal
                  gspell
                  gtk
                  python-pygobject
                  libappindicator
                  python-pytaglib))
    (native-inputs (list gettext-minimal xvfb-run))
    (home-page "https://nicotine-plus.org/")
    (synopsis "Graphical client for Soulseek")
    (description
     "Nicotine+ is a graphical client for the Soulseek peer-to-peer
file sharing network.  It is an attempt to keep Nicotine working with
the latest libraries, kill bugs, keep current with the Soulseek protocol,
and add some new features that users want and/or need.")
    (license license:gpl3+)))
/td> 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-04gnu: CMake: Update to 3.14.3....* gnu/packages/cmake.scm (cmake-minimal): Update to 3.14.3. Marius Bakke 2019-03-20cmake: Generate documentation....To prevent complicating the dependencies of a core tool, a new variant, CMAKE-MINIMAL is introduced and the CMake build system is configured to use it by default. The regular CMAKE package gains a manpage, info manual as well as HTML documentation. Fixes issue #33497 (https://bugs.gnu.org/33497). * gnu/packages/cmake.scm (gnu): Use modules (gnu packages python-xyz), (gnu packages texinfo) and (srfi srfi-1). (cmake-minimal): Rename the original cmake variable to this. [phases]{configure}: Extract the configure script arguments to... [configure-flags]: here. [properties]: Set the HIDDEN? property to #t. (cmake): New variable, which inherits from CMAKE-MINIMAL. [phases]{move-html-doc}: Add phase. [native-inputs]: Add PYTHON-SPHINX and TEXINFO. [outputs]: Add the "doc" output. [properties]: Clear the inherited HIDDEN? property. * guix/build-system/cmake.scm (default-cmake): Use CMAKE-MINIMAL instead of CMAKE. Maxim Cournoyer 2019-03-17gnu: cmake: Update to 3.14.0....* gnu/packages/cmake.scm (cmake): Update to 3.14.0. Marius Bakke 2019-02-09gnu: cmake: Try CPATH and C_INCLUDE_PATH when finding system libraries....* gnu/packages/cmake.scm (cmake)[arguments]: Try both CPATH and C_INCLUDE_PATH instead of just the latter. Marius Bakke 2018-12-12gnu: CMake: Update to 3.13.1....* gnu/packages/cmake.scm (cmake): Update to 3.13.1. Marius Bakke 2018-09-09gnu: cmake: Update to 3.12.2....* gnu/packages/cmake.scm (cmake): Update to 3.12.2. Marius Bakke 2018-08-21gnu: cmake: Update to 3.12.1....* gnu/packages/cmake.scm (cmake): Update to 3.12.1. Marius Bakke 2018-07-21gnu: cmake: Update to 3.12.0....* gnu/packages/cmake.scm (cmake): Update to 3.12.0. Marius Bakke 2018-07-08gnu: cmake: Update to 3.11.4....* gnu/packages/cmake.scm (cmake): Update to 3.11.4. Tobias Geerinckx-Rice 2018-06-12gnu: cmake: Update to 3.11.3....* gnu/packages/cmake.scm (cmake): Update to 3.11.3. Tobias Geerinckx-Rice 2018-06-06Merge branch 'origin/core-updates-next' into core-updatesRicardo Wurmus 2018-05-25gnu: cmake: Delete Emacs library....* gnu/packages/cmake.scm (cmake)[arguments]: Delete Emacs library. Oleg Pykhalov 2018-05-24Merge branch 'master' into core-updatesMark H Weaver 2018-05-22Revert "gnu: cmake: Delete Emacs library."...This reverts commit f037673c3133ae7453794f1f62eecebf9d06b092. Mark H Weaver 2018-05-22gnu: cmake.scm: Add missing module....* gnu/packages/cmake.scm: Import emacs-build-system. Oleg Pykhalov 2018-05-22gnu: Add emacs-cmake-mode....* gnu/packages/cmake.scm (emacs-cmake-mode): New public variable. Oleg Pykhalov 2018-05-22gnu: cmake: Delete Emacs library....* gnu/packages/finance.scm (cmake)[arguments]: Delete Emacs library. Oleg Pykhalov 2018-04-30gnu: cmake: Update to 3.11.1....* gnu/packages/cmake.scm (cmake): Update to 3.11.1. Marius Bakke 2018-03-29gnu: cmake: Update to 3.11.0....* gnu/packages/cmake.scm (cmake): Update to 3.11.0. [arguments]: Enable fixed test. Adjust file substitutions. Run tests and "./configure" in parallel. (cmake-3.11): Remove variable. * gnu/packages/storage.scm (ceph)[arguments]: Remove #:cmake. Marius Bakke 2018-03-23gnu: cmake: Re-indent....* gnu/packages/cmake.scm (cmake): Re-indent. Arun Isaac 2018-03-23gnu: cmake: Update to 3.10.2....* gnu/packages/cmake.scm (cmake): Update to 3.10.2. [source]: Remove cmake-fix-tests patch. Do not remove bundled cmlibuv. [arguments]: Replace system* with invoke. [inputs]: Add rhash. Sort. [home-page]: Update URL. * gnu/packages/patches/cmake-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. Arun Isaac 2018-03-04gnu: Add cmake@3.11....* gnu/packages/cmake.scm (cmake-3.11): New public variable. Marius Bakke