aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Eric Bavier <bavier@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages nickle)
  #:use-module (gnu packages)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public nickle
  (package
    (name "nickle")
    (version "2.97")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://nickle.org/release/nickle-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "0gqashcs3r0d1yp6rq6q2ayjdwsjxnd8z0ij55ayrbhn296l7mp2"))
              (patches (search-patches "nickle-man-release-date.patch"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-build-date
           (lambda _
             ;; Our patch touches Makefile.am, but rather than rebootstrap,
             ;; make the substitution directly in Makefile.in.
             (substitute* "Makefile.in"
               (("BUILD_DATE") "RELEASE_DATE")))))))
    (synopsis "Numeric oriented programming language")
    (description
     "Nickle is a programming language based prototyping environment with
powerful programming and scripting capabilities.  Nickle supports a variety of
datatypes, especially arbitrary precision numbers.  The programming language
vaguely resembles C.  Some things in C which do not translate easily are
different, some design choices have been made differently, and a very few
features are simply missing.  Nickle provides the functionality of Unix bc, dc
and expr in a different form.  It is also an ideal environment for prototyping
complex algorithms.  Nickle's scripting capabilities make it a replacement for
spreadsheets in some applications, and its numeric features complement the
limited numeric functionality of text-oriented languages such as AWK and Perl.")
    (home-page "https://nickle.org/")
    (license license:expat)))
d>Garek Dyszel 2022-09-22gnu: coq: Update to 8.16.0....* gnu/packages/coq.scm (coq-core): Update to 8.16.0. (coq-bignums): Update to 8.16.0. (coq-equations): Update to 1.3-8.16. (coq-gappa): Adjust for changes in coq-core. Julien Lepiller 2022-09-22gnu: coq-interval: Update to 4.5.2....* gnu/packages/coq.scm (coq-interval): Update to 4.5.2. Julien Lepiller 2022-09-22gnu: coq-mathcomp: Update to 1.15.0....* gnu/packages/coq.scm (coq-mathcomp): Update to 1.15.0. Julien Lepiller 2022-09-22gnu: coq-gappa: Update to 1.5.2....* gnu/packages/coq.scm (coq-gappa): Update to 1.5.2. Julien Lepiller 2022-09-22gnu: coq-flocq: Update to 4.1.0....* gnu/packages/coq.scm (coq-flocq): Update to 4.1.0. Julien Lepiller 2022-09-22gnu: lablgtk3: Update to 3.1.2....* gnu/packages/ocaml.scm (lablgtk3): Update to 3.1.2. [arguments]: Do not build extensions anymore (missing dependency) * gnu/packages/games.scm (laby)[inputs]: Use `ocaml-lablgtk3-sourceview3'. * gnu/packages/maths.scm (frama-c)[inputs]: Use `ocaml-lablgtk3-sourceview3'. * gnu/packages/coq.scm (coq-ide)[inputs]: Use `ocaml-lablgtk3-sourceview3'. Julien Lepiller 2022-08-13gnu: dune: Update to 4.4.1....* gnu/packages/ocaml.scm (dune): Update to 4.4.1. * gnu/packages/coq.scm (coq-stdlib): Fix for new dune. Julien Lepiller 2022-06-18gnu: coq: Update to 8.15.2....* gnu/packages/coq.scm (coq-core): Update to 8.15.2. Julien Lepiller 2022-05-01gnu: coq: Update to 8.15.1....* gnu/packages/coq.scm (coq): Update to 8.15.1. Julien Lepiller 2022-02-11gnu: coq-stdpp: Update to 1.7.0....* gnu/packages/coq.scm (coq-stdpp): Update to 1.7.0. Julien Lepiller 2022-02-11gnu: coq-mathcomp: Update to 1.14.0....* gnu/packages/coq.scm (coq-mathcomp): Update to 1.14.0. Julien Lepiller 2022-02-11gnu: coq: Update to 8.15.0....* gnu/packages/coq.scm (coq): Update to 8.15.0. (coq-equations): Update to 1.3-8.15. * gnu/packages/patches/coq-fix-envvars.patch: Adapt to new version. Julien Lepiller 2022-02-11gnu: coq-interval: Update to 4.4.0....* gnu/packages/coq.scm (coq-interval): Update to 4.4.0. Julien Lepiller 2022-02-11gnu: coq-bignums: Update to 8.15.0....* gnu/packages/coq.scm (coq-bignums): Update to 8.15.0. Julien Lepiller 2022-02-11gnu: coq-gappa: Update to 1.5.1....* gnu/packages/coq.scm (coq-gappa): Update to 1.5.1. Julien Lepiller 2022-02-11gnu: coq-flocq: Update to 4.0.0....* gnu/packages/coq.scm (coq-flocq): Update to 4.0.0. Julien Lepiller 2021-12-22gnu: coq: Update to 8.14.1....* gnu/packages/coq.scm (coq-core): Update to 8.14.1. Julien Lepiller 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-30gnu: coq: Update to 8.14.0....* gnu/packages/coq.scm (coq): Update to 8.14.0. (coq-bignums): Update to 8.14.0. (coq-equations): Update to 1.3. * gnu/packages/patches/coq-fix-envvars.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Julien Lepiller 2021-11-30gnu: proof-general: Update to latest commit....* gnu/packages/coq.scm (proof-general): Update to latest commit. [license]: Change to glp3+. Julien Lepiller 2021-11-30gnu: coq-semantics: Update to 8.14.0....* gnu/packages/coq.scm (coq-semantics): Update to 8.14.0. Julien Lepiller 2021-11-22gnu: proof-general: Adjust autoloads for Emacs....Fixes <https://bugs.gnu.org/46016>. * gnu/packages/coq.scm (proof-general)[native-inputs]: Remove 'which'. [inputs]: Remove 'coq' and 'emacs'. [arguments]<#:make-flags>: Adjust to find 'emacs'. Set 'ELISP' and 'DEST_LISP'. <#:modules, #:imported-modules>: Remove. <#:phases>: Remove call to 'which' in Makefile. Add copy file allowing Emacs autoloads. Clean unnecessary code. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> zimoun 2021-11-21gnu: coq-stdpp: Update to 1.6.0....* gnu/packages/coq.scm (coq-stdpp): Update to 1.6.0. Julien Lepiller 2021-11-21gnu: coq-interval: Update to 4.3.1....* gnu/packages/coq.scm (coq-interval): Update to 4.3.1. Julien Lepiller 2021-11-21gnu: coq-coquelicot: Update to 3.2.0....* gnu/packages/coq.scm (coq-coquelicot): Update to 3.2.0. Julien Lepiller 2021-11-21gnu: coq-mathcomp: Update to 1.13.0....* gnu/packages/coq.scm (coq-mathcomp): Update to 1.13.0. Julien Lepiller 2021-11-21gnu: coq-gappa: Update to 1.5.0....* gnu/packages/coq.scm (coq-gappa): Update to 1.5.0. Julien Lepiller 2021-11-21gnu: coq-flocq: Update to 3.4.2....* gnu/packages/coq.scm (coq-flocq): Update to 3.4.2. Julien Lepiller 2021-11-20gnu: coq-interval: Update home-page....* gnu/packages/coq.scm (coq-interval)[home-page]: Update. Julien Lepiller 2021-11-20gnu: coq-gappa: Update home-page....* gnu/packages/coq.scm (coq-gappa)[home-page]: Update. Julien Lepiller 2021-11-20gnu: coq-flocq: Update home-page....* gnu/packages/coq.scm (coq-flocq)[home-page]: Update. Julien Lepiller 2021-11-18gnu: coq-stdpp: Adjust '#:make-flags'....* gnu/packages/coq.scm (coq-stdpp)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2021-11-18gnu: coq-equations: Adjust '#:make-flags'....* gnu/packages/coq.scm (coq-equations)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2021-11-18gnu: coq-autosubst: Adjust '#:make-flags'....* gnu/packages/coq.scm (coq-autosubst)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2021-11-18gnu: coq-mathcomp: Adjust '#:make-flags'....* gnu/packages/coq.scm (coq-mathcomp)[arguments]<#:make-flags>: Set install destination. <#:phases>: Remove replace 'install. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2021-11-18gnu: Add coq-semantics....* gnu/packages/coq.scm (coq-semantics): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2021-10-08gnu: coq: Add upstream-name....This prevents an error on inherited packages when running the updater. * gnu/packages/coq.scm (coq)[properties]: Add upstream-name. Julien Lepiller