aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages nettle)
  #:use-module (guix utils)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages m4))

(define-public nettle-2
  (package
    (name "nettle")
    (version "2.7.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/nettle/nettle-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "0h2vap31yvi1a438d36lg1r1nllfx3y19r4rfxv7slrm6kafnwdw"))))
    (build-system gnu-build-system)
    (arguments
     ;; 'sexp-conv' and other programs need to have their RUNPATH point to
     ;; $libdir, which is not the case by default.  Work around it.
     `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
                                              (assoc-ref %outputs "out")
                                              "/lib"))
       #:phases (modify-phases %standard-phases
                  (add-after 'install 'move-static-libraries
                    (lambda* (#:key outputs #:allow-other-keys)
                      (let ((out (assoc-ref outputs "out"))
                            (slib (string-append (assoc-ref outputs "static")
                                                 "/lib")))
                        (mkdir-p slib)
                        (with-directory-excursion (string-append out "/lib")
                          (for-each (lambda (ar)
                                      (rename-file ar (string-append
                                                       slib "/"
                                                       (basename ar))))
                                    (find-files
                                     "."
                                     ,(if (target-mingw?)
                                          '(lambda (filename _)
                                             (and (string-suffix? ".a" filename)
                                                  (not (string-suffix? ".dll.a" filename))))
                                          "\\.a$"))))
                        #t))))))
    (outputs '("out" "debug" "static"))
    (native-inputs (list m4))
    (propagated-inputs (list gmp))
    (home-page "https://www.lysator.liu.se/~nisse/nettle/")
    (synopsis "C library for low-level cryptographic functionality")
    (description
     "GNU Nettle is a low-level cryptographic library.  It is designed to
fit in easily in almost any context.  It can be easily included in
cryptographic toolkits for object-oriented languages or in applications
themselves.")
    (license gpl2+)))

(define-public nettle
  ;; This version is not API-compatible with version 2.  In particular, lsh
  ;; cannot use it yet.  So keep it separate.
  (package (inherit nettle-2)
    (version "3.9.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/nettle/nettle-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1qvc1iamnvbiss0bx9c98djgn3y60zs59c5wdyyip9qc3fcgzznc"))))
    (arguments
     (substitute-keyword-arguments (package-arguments nettle-2)
       ((#:configure-flags flags)
        ;; Build "fat" binaries where the right implementation is chosen
        ;; at run time based on CPU features (starting from 3.1.)
        `(cons "--enable-fat" ,flags))))))
g-qq)[synopsis]: Likewise. * gnu/packages/machine-learning.scm (python-lap)[synopsis]: Likewise. (python-pyro-api)[synopsis]: Likewise. * gnu/packages/messaging.scm (python-librecaptcha)[synopsis]: Likewise. * gnu/packages/python-check.scm (python-pytest-cram)[synopsis]: Likewise. * gnu/packages/python-web.scm (python-jschema-to-python)[synopsis]: Likewise. (python-sarif-om)[synopsis]: Likewise. (python-socksio)[synopsis]: Likewise. (python-msrest)[synopsis]: Likewise. * gnu/packages/tor.scm (torsocks)[synopsis]: Likewise. * gnu/packages/cran.scm (r-rlist)[synopsis]: Remove leading article. * gnu/packages/crates-io.scm (rust-clippy-lints-0.0.153)[synopsis]: Likewise. (rust-simplelog-0.11)[synopsis]: Likewise. * gnu/packages/samba.scm (wsdd)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-spki-0.4)[synopsis]: Remove trailing whitespace. * gnu/packages/golang.scm (go-github-com-mattn-go-zglob)[description]: Remove leading whitespace. * gnu/packages/haskell-check.scm (ghc-crypto-cipher-tests)[description]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-ctype)[synopsis]: Remove trailing whitespace. * gnu/packages/mpi.scm (openmpi-thread-multiple)[description]: Remove leading whitespace. * gnu/packages/node-xyz.scm (node-string-decoder)[synopsis]: Remove trailing whitespace. Vagrant Cascadian 2022-08-03gnu: Add android-file-transfer....* gnu/packages/android.scm (android-file-transfer): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> kiasoc5 2022-05-12gnu: python-miio: Update to 0.5.11....* gnu/packages/android.scm (python-miio): Update to 0.5.11. [phases]{relax-requirements}: New phase. {adjust-for-click-8}: Likewise. {check}: Remove extraneous add-installed-pythonpath call, INPUTS and OUTPUTS arguments. Invoke pytest with -vv. Maxim Cournoyer