aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018–2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages musl)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash))

(define-public musl
  (package
    (name "musl")
    (version "1.2.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.musl-libc.org/releases/"
                                  "musl-" version ".tar.gz"))
              (sha256
               (base32
                "1r3mgky9d19b2285s274qxzlgs7sncx8plm01vd691sdx2xii8d9"))))
    (build-system gnu-build-system)
    (arguments
     (list #:tests? #f                      ; musl has no tests
           #:configure-flags
           #~(list "--enable-wrapper=all"
                   (string-append "--syslibdir=" #$output "/lib"))))
    (inputs (list bash-minimal))
    (synopsis "Small C standard library")
    (description "musl is a simple and lightweight C standard library.  It
strives to be correct in the sense of standards-conformance and safety.")
    (home-page "https://musl.libc.org")
    ;; Musl as a whole is released under the Expat license.  Parts of it are
    ;; derived from various third-party projects that are released under
    ;; non-copyleft licenses.  See the COPYRIGHT file for details.
    (license license:expat)))
an>gnu: vim: Remove unneeded make-flag....Upstream reports this fixed with 8.2.3406. * gnu/packages/vim.scm (vim)[arguments]: Remove make-flags. (vim-full)[arguments]: Adjust accordingly. Efraim Flashner 2022-01-09gnu: vim: Update to 8.2.3995....* gnu/packages/vim.scm (vim): Update to 8.2.3995. [arguments]: Remove trailing #t from phases. (vim-full): Remove comment about package reliably building. Efraim Flashner 2021-12-21gnu: Add vim-gnupg....* gnu/packages/vim.scm (vim-gnupg): New variable. Efraim Flashner 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-12-01gnu: Add vim-nerdtree....* gnu/packages/vim.scm (vim-nerdtree): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Foo Chuan Wei 2021-11-26gnu: vim-fugitive: Update to 3.6....* gnu/packages/vim.scm (vim-fugitive): Update to 3.6. Efraim Flashner 2021-11-08Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-11-04gnu: Add vim-nerdcommenter....* gnu/packages/vim.scm (vim-nerdcommenter): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-11-03Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-11-01gnu: vim-scheme: Update to 0.0.0-3.e22fc8e....* gnu/packages/vim.scm (vim-scheme): Update to 0.0.0-3.e22fc8e. [source]: Use https. [license]: Update to new upstream license. Foo Chuan Wei 2021-10-31gnu: vim-tagbar: Add ctags fallback location....* gnu/packages/vim.scm (vim-tagbar)[arguments]: Add fill path to ctags as fallback location. [inputs]: Add universal-ctags. Efraim Flashner 2021-10-31gnu: Add vim-tagbar....* gnu/packages/vim.scm (vim-tagbar): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-31gnu: Add vim-characterize....* gnu/packages/vim.scm (vim-characterize): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-25gnu: Add vim-gitgutter....* gnu/packages/vim.scm (vim-gitgutter): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-25gnu: Add vim-mucomplete....* gnu/packages/vim.scm (vim-mucomplete): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-18gnu: Add vim-ctrlp....* gnu/packages/vim.scm (vim-ctrlp): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-18gnu: Add vim-surround....* gnu/packages/vim.scm (vim-surround): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-18gnu: vim-scheme: Update to 0.0.0-2.99af6be....* gnu/packages/vim.scm (vim-scheme): Update to 0.0.0-2.99af6be. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-13gnu: Add vim-paredit....* gnu/packages/vim.scm (vim-paredit): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Foo Chuan Wei 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-10gnu: vim-fugitive: Update to 3.4....* gnu/packages/vim.scm (vim-fugitive): Update to 3.4. [arguments]: Install missing directory. Efraim Flashner 2021-10-10gnu: vim: Update to 8.2.3487....* gnu/packages/vim.scm (vim): Update to 8.2.3487. [arguments]: Adjust custom 'patch-absolute-paths phase to add new substitution. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Steve George 2021-09-29gnu: vifm: Update to 0.12....* gnu/packages/vim.scm (vifm): Update to 0.12. Efraim Flashner 2021-09-17Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm Marius Bakke