aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018–2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages musl)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash))

(define-public musl
  (package
    (name "musl")
    (version "1.2.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.musl-libc.org/releases/"
                                  "musl-" version ".tar.gz"))
              (sha256
               (base32
                "1r3mgky9d19b2285s274qxzlgs7sncx8plm01vd691sdx2xii8d9"))))
    (build-system gnu-build-system)
    (arguments
     (list #:tests? #f                      ; musl has no tests
           #:configure-flags
           #~(list "--enable-wrapper=all"
                   (string-append "--syslibdir=" #$output "/lib"))))
    (inputs (list bash-minimal))
    (synopsis "Small C standard library")
    (description "musl is a simple and lightweight C standard library.  It
strives to be correct in the sense of standards-conformance and safety.")
    (home-page "https://musl.libc.org")
    ;; Musl as a whole is released under the Expat license.  Parts of it are
    ;; derived from various third-party projects that are released under
    ;; non-copyleft licenses.  See the COPYRIGHT file for details.
    (license license:expat)))
d>Ricardo Wurmus 2016-10-13gnu: Add gx-switchless-wah-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-slow-gear-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-vintage-fuzz-master-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-super-fuzz-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-voodoo-fuzz-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-hyperion-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-saturator-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-suppa-tone-bender-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-push-pull-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-tone-mender-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-overdriver-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-vbass-preamp-lv2....Ricardo Wurmus 2016-10-13gnu: Add gx-guvnor-lv2....Ricardo Wurmus 2016-10-10gnu: Add gxtuner....Ricardo Wurmus 2016-10-08gnu: yoshimi: Update to 1.4.1....Ricardo Wurmus 2016-10-08gnu: drumstick: Update to 1.1.0....Ricardo Wurmus 2016-09-26gnu: qtractor: Update to 0.7.9....Ricardo Wurmus 2016-09-21gnu: extempore: Only build on x86_64....Ricardo Wurmus 2016-09-16gnu: Add Extempore....Ricardo Wurmus 2016-09-16gnu: Add portmidi-for-extempore....Ricardo Wurmus 2016-09-13gnu: Add schismtracker....Kei Kebreau 2016-08-22gnu: synthv1: Build with gnu++11....David Craven 2016-08-04gnu: tuxguitar: Update to 1.3.2....Ricardo Wurmus 2016-07-31Merge branch 'master' into core-updatesMark H Weaver 2016-07-29gnu: beets: Update to 1.3.19....Alex Griffin 2016-07-25gnu: Use 'ghostscript-gs' in packages that need the 'gs' command....Ludovic Courtès 2016-07-21gnu: Update URLs for sourceforge.net....Leo Famulari 2016-07-03gnu: Add Amsynth....Ricardo Wurmus 2016-07-02gnu: Add midicsv....John J. Foerch 2016-06-22gnu: beets: Move propagated-inputs to inputs....Leo Famulari 2016-06-22gnu: beets: Update to 1.3.18....Leo Famulari 2016-06-18gnu: synthv1: Update to 0.7.5....Ricardo Wurmus 2016-06-16gnu: drumstick: Build with modular qt....Efraim Flashner 2016-06-16gnu: vmpk: Build with modular qt....Efraim Flashner 2016-06-16gnu: synthv1: Build with modular qt....Efraim Flashner 2016-06-16gnu: powertabeditor: Build with qtbase....Efraim Flashner 2016-06-05gnu: Use full SHA1 commit ids....Hartmut Goebel 2016-05-26gnu: Rename texlive module to tex....Roel Janssen