aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018–2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages musl)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash))

(define-public musl
  (package
    (name "musl")
    (version "1.2.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.musl-libc.org/releases/"
                                  "musl-" version ".tar.gz"))
              (sha256
               (base32
                "1r3mgky9d19b2285s274qxzlgs7sncx8plm01vd691sdx2xii8d9"))))
    (build-system gnu-build-system)
    (arguments
     (list #:tests? #f                      ; musl has no tests
           #:configure-flags
           #~(list "--enable-wrapper=all"
                   (string-append "--syslibdir=" #$output "/lib"))))
    (inputs (list bash-minimal))
    (synopsis "Small C standard library")
    (description "musl is a simple and lightweight C standard library.  It
strives to be correct in the sense of standards-conformance and safety.")
    (home-page "https://musl.libc.org")
    ;; Musl as a whole is released under the Expat license.  Parts of it are
    ;; derived from various third-party projects that are released under
    ;; non-copyleft licenses.  See the COPYRIGHT file for details.
    (license license:expat)))
d>2018-12-03Merge branch 'core-updates'Ludovic Courtès 2018-11-29gnu: schismtracker: Update to 20180810....Kei Kebreau 2018-11-26gnu: ams-lv2: Always return #t from phase remove-sse-flags....Björn Höfling 2018-11-26gnu: ams-lv2: Fix error in configure phase....Björn Höfling 2018-11-14Merge branch 'master' into core-updatesMarius Bakke 2018-11-11gnu: schismtracker: Remove custom bootstrap phase....Ricardo Wurmus 2018-11-11gnu: lilypond: Use INVOKE....Ricardo Wurmus 2018-11-11gnu: schismtracker: Fetch sources from git....Ricardo Wurmus 2018-11-11gnu: clyrics: Fetch sources from git....Ricardo Wurmus 2018-11-11gnu: lmms: Fetch sources from git....Ricardo Wurmus 2018-11-11gnu: milkytracker: Fetch sources from git....Ricardo Wurmus 2018-11-11gnu: pianobar: Fetch sources from git....Ricardo Wurmus 2018-11-10gnu: gxtuner: Fetch sources from git....Ricardo Wurmus 2018-11-10gnu: ams-lv2: Fetch sources from git....Ricardo Wurmus 2018-11-10gnu: portmidi-for-extempore: Fetch sources from git....Ricardo Wurmus 2018-11-10gnu: jalv-select: Fetch sources from git....Ricardo Wurmus 2018-11-09Merge branch 'master' into core-updatesMarius Bakke 2018-11-09gnu: powertabeditor: Fetch sources from git....Ricardo Wurmus 2018-11-09gnu: powertabeditor: Use INVOKE....Ricardo Wurmus 2018-11-08gnu: libmusicbrainz: Use INVOKE....Ricardo Wurmus 2018-11-08gnu: pd: Remove custom autoconf phase....Ricardo Wurmus 2018-11-08gnu: cmus: Fetch sources from git....Ricardo Wurmus 2018-11-08gnu: cmus: Use INVOKE....Ricardo Wurmus 2018-11-07Merge branch 'master' into core-updatesMarius Bakke 2018-11-07gnu: clementine: Build with sqlite-with-column-metadata....Pierre Langlois 2018-10-21Merge branch 'master' into core-updatesMarius Bakke 2018-10-21gnu: klick: Use scons-python2 for building....Marius Bakke 2018-10-21gnu: fluidsynth: Update to 2.0.1....Marius Bakke 2018-10-12gnu: Add libpd....宋文武 2018-10-08gnu: Add picard....Christopher Baines 2018-10-07gnu: pd: Update to 0.49-0....宋文武 2018-09-27gnu: yoshimi: Update to 1.5.9....Ricardo Wurmus 2018-09-10gnu: qtractor: Update to 0.9.2....Tobias Geerinckx-Rice 2018-09-06gnu: libgme: Update to 0.6.2....Kei Kebreau 2018-09-02gnu: rosegarden: Update to 18.06....宋文武 2018-08-27Update email for Pierre Neidhardt....Pierre Neidhardt 2018-08-24gnu: tuxguitar: Update to 1.5.2....Tobias Geerinckx-Rice 2018-08-24gnu: libgig: Update to 4.1.0....Tobias Geerinckx-Rice 2018-08-24gnu: denemo: Use INVOKE....Tobias Geerinckx-Rice 2018-08-23gnu: drumkv1: Update to 0.9.2....Tobias Geerinckx-Rice 2018-08-23gnu: synthv1: Update to 0.9.2....Tobias Geerinckx-Rice 2018-08-23gnu: samplv1: Update to 0.9.2....Tobias Geerinckx-Rice