aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018–2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages musl)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash))

(define-public musl
  (package
    (name "musl")
    (version "1.2.5")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.musl-libc.org/releases/"
                                  "musl-" version ".tar.gz"))
              (sha256
               (base32
                "1r3mgky9d19b2285s274qxzlgs7sncx8plm01vd691sdx2xii8d9"))))
    (build-system gnu-build-system)
    (arguments
     (list #:tests? #f                      ; musl has no tests
           #:configure-flags
           #~(list "--enable-wrapper=all"
                   (string-append "--syslibdir=" #$output "/lib"))))
    (inputs (list bash-minimal))
    (synopsis "Small C standard library")
    (description "musl is a simple and lightweight C standard library.  It
strives to be correct in the sense of standards-conformance and safety.")
    (home-page "https://musl.libc.org")
    ;; Musl as a whole is released under the Expat license.  Parts of it are
    ;; derived from various third-party projects that are released under
    ;; non-copyleft licenses.  See the COPYRIGHT file for details.
    (license license:expat)))
lass='nohover-highlight'> * gnu/packages/mate.scm (mate-settings-daemon): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add libmatekbd.ng0 * gnu/packages/mate.scm (libmatekbd): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add libmatemixer.ng0 * gnu/packages/mate.scm (libmatemixer): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add mate-panel.ng0 * gnu/packages/mate.scm (mate-panel): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add mate-session-manager.ng0 * gnu/packages/mate.scm (mate-session-manager): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add marco.ng0 * gnu/packages/mate.scm (marco): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add mate-terminal.ng0 * gnu/packages/mate.scm (mate-terminal): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-12gnu: Add caja.ng0 * gnu/packages/mate.scm (caja): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-03gnu: libmateweather: Update inputs.Efraim Flashner * gnu/packages/mate.scm (libmateweather)[inputs]: Remove gdk-pixpuf. Move dconf ... [native-inputs]: ... to here. 2017-09-03gnu: mate-desktop: Add 'gtk-doc' back to native-inputs.ng0 * gnu/packages/mate.scm (mate-desktop)[native-inputs]: Uncomment 'gtk-doc' as input. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-03gnu: mate-themes: Update to 3.22.13.ng0 * gnu/packages/mate.scm (mate-themes): Update to 3.22.13. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-03gnu: mate-themes: Update inputs.ng0 * gnu/packages/mate.scm (mate-themes)[inputs]: Remove gtk+, gtk-engines, murrine. Move gdk-pixbuf ... [native-inputs]: ... to here. Add gtk+@2. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-03gnu: mate-icon-theme: Remove 'gtk+' from native-inputs.ng0 * gnu/packages/mate.scm (mate-icon-theme)[native-inputs]: Remove 'gtk+'. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-09-03gnu: mate: Use https.ng0 * gnu/packages/mate.scm (mate-icon-theme)[source, home-page]: Use https. (mate-themes)[source, home-page]: Likewise. (mate-desktop)[source, home-page]: Likewise. (libmateweather)[source, home-page]: Likewise. (mate-menus)[source, home-page]: Likewise. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> 2017-06-11gnu: mate-menus: Update to 1.18.0.Kei Kebreau * gnu/packages/mate.scm (mate-menus): Update to 1.18.0. 2017-06-11gnu: libmateweather: Update to 1.18.1.Kei Kebreau * gnu/packages/mate.scm (libmateweather): Update to 1.18.1. [arguments]: Remove obsolete "--with-gtk" flag. 2017-06-11gnu: mate-desktop: Update to 1.18.0.Kei Kebreau * gnu/packages/mate.scm (mate-desktop): Update to 1.18.0. [arguments]: Remove obsolete configure flags. [inputs]: Remove python-2. 2017-06-11gnu: mate-icon-theme: Update to 1.18.2.Kei Kebreau * gnu/packages/mate.scm (mate-icon-theme): Update to 1.18.2. 2017-05-24gnu: mate-themes: Update to 3.22.11.Marius Bakke * gnu/packages/mate.scm (mate-themes): Update to 3.22.11. 2017-04-17gnu: mate-themes: Update to 3.22.10.Kei Kebreau * gnu/packages/mate.scm (mate-themes): Update to 3.22.10. 2017-01-14gnu: mate-themes: Update source hash.Mark H Weaver This is a followup to commit 44350d23da826731adc187b478e00b2601ab78dc. * gnu/packages/mate.scm (mate-themes)[source]: Update hash. * gnu/packages/gtk.scm (gtk+): Add reminder comment. 2016-11-08gnu: mate-themes: Update to 3.20.9.Efraim Flashner * gnu/packages/mate.scm (mate-themes): Update to 3.20.9. [source]: Update package location. [inputs]: Remove gtk+-2, add gtk+-3. [description]: Add note about dual gtk+-2/gtk+-3 support. 2016-11-08gnu: mate-menus: Update to 1.16.0.Efraim Flashner * gnu/packages/mate.scm (mate-menus): Update to 1.16.0. [propagated-inputs]: Move glib ... [inputs]: ... to here. 2016-11-08gnu: mate-desktop: Update to 1.16.1.Efraim Flashner * gnu/packages/mate.scm (mate-desktop): Update to 1.16.1. [arguments]: Build with gtk+-3, enable mpaste. [propagated-inputs]: Remove gtk+-2, move libxrandr, startup-notification ... [inputs]: ... to here. Add gtk+-3, python-2. 2016-11-08gnu: mate-icon-theme: Update to 1.16.0.Efraim Flashner * gnu/packages/mate.scm (mate-icon-theme): Update to 1.16.0. 2016-11-08gnu: libmateweather: Update to 1.16.1.Efraim Flashner * gnu/packages/mate.scm (libmateweather): Update to 1.16.1. [arguments]: Build with gtk+-3. [propagated-inputs]: Remove gtk+-2, move gdk-pixbuf ... [inputs]: ... to here. Add gtk+-3.