aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "066ncw51da1h6w80p6cl6flw8sznk933sf545xa0xzhfpnb8l00b"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
fcb'>gnu: xen: Build in parallel....I was unable to trigger any additional irreproducibility. If you can, please disable PARRALLEL-BUILD? instead. * gnu/packages/virtualization.scm (xen)[arguments]: Remove hard-coded ‘-j 1’ from the #:make-flags. Honour PARALLEL-BUILD? in the 'build phase. Tobias Geerinckx-Rice 2023-09-24gnu: xen: Update package style....* gnu/packages/virtualization.scm (xen) [arguments]: Rewrite as G-expressions. Use SEARCH-INPUT-FILE whenever possible. Put SUBSTITUTE* features to use. [native-inputs, inputs]: Remove input labels. Tobias Geerinckx-Rice 2023-09-24gnu: xen: Update to 4.14.6....* gnu/packages/virtualization.scm (xen): Update to 4.14.6. [arguments]: Remove obsolete quoting work-around for old bug. Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2023-09-24gnu: xen: Version the mini-os checkout....* gnu/packages/virtualization.scm (xen)[native-inputs]: Add the Xen name and version to the ‘…-mini-os-git-checkout’ store file name. Tobias Geerinckx-Rice 2023-09-24gnu: qemu: Update to 8.1.1....* gnu/packages/virtualization.scm (qemu): Update to 8.1.1. Tobias Geerinckx-Rice 2023-09-12gnu: qemu: Reinstate the iothreads-commit-active test....* gnu/packages/virtualization.scm (qemu) [arguments]: Add set-SOCK_DIR phase. (qemu-minimal) [arguments]: Delete the disable-extra-tests phase. Maxim Cournoyer 2023-09-08gnu: ganeti: Fix build....* gnu/packages/patches/ganeti-lens-compat.patch, gnu/packages/patches/ganeti-procps-compat.patch, gnu/packages/patches/ganeti-relax-dependencies.patch, gnu/packages/patches/ganeti-reorder-arbitrary-definitions.patch, gnu/packages/patches/ganeti-template-haskell-2.17.patch, gnu/packages/patches/ganeti-template-haskell-2.18.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/virtualization.scm (ganeti)[source](patches): Add them. Marius Bakke 2023-09-05gnu: qemu: Update to 8.1.0....* gnu/packages/virtualization.scm (qemu): Update to 8.1.0. [source] <patches>: Replace qemu-disable-aarch64-migration-test.patch with qemu-disable-some-qtests-tests.patch. <snippet>: Adjust for dtc relocation and meson and sgabios removal. [arguments] <configure-flags>: Remove --meson flag. Remove sgabios from the --firmwarepath value. <phases>: Adjust replace-firmwares and delete-firmwares phases for sgabios removal. [inputs]: Remove sgabios. (qemu-minimal): Use package/inherit, which is more appropriate for a package variant. [arguments]: New disable-extra-tests phase. * gnu/packages/patches/qemu-disable-aarch64-migration-test.patch: Delete file. * gnu/packages/patches/qemu-disable-some-qtests-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Reviewed-by: Kaelyn <kaelyn.alexi@protonmail.com> Maxim Cournoyer 2023-08-29gnu: runc: Update to 1.1.9....* gnu/packages/virtualization.scm (runc): Update to 1.1.9. Hilton Chain 2023-08-29gnu: looking-glass-client: Update package style....* gnu/packages/virtualization.scm (looking-glass-client): Restyle format. [arguments]: Use G-expressions. Drop trailing #t from phases. Signed-off-by: Christopher Baines <mail@cbaines.net> Ahmad Draidi 2023-08-29gnu: looking-glass-client: Update to B6....* gnu/packages/virtualization.scm (looking-glass-client): Update to B6. [source]: Use upstream tarball and switch to url-fetch. [inputs]: Add font-dejavu, libsamplerate, pipewire, pulseaudio. Remove openssl, sdl2, sdl2-ttf. [native-inputs]: Remove libconfig. [arguments]: Add "-DOPTIMIZE_FOR_NATIVE=OFF" to #:configure-flags for reproducibility and CPU compatibility. [use-modules]: Add (gnu packages fonts). Signed-off-by: Christopher Baines <mail@cbaines.net> Ahmad Draidi 2023-07-23gnu: lxcfs: Update to 5.0.4....* gnu/packages/virtualization.scm (lxcfs): Update to 5.0.4. [build-system]: Switch to Meson. [arguments]: Remove old value. Install System V init scripts. [native-inputs]: Remove autoconf, automake, and libtool. Add help2man, python, and python-jinja2. [inputs]: Upgrade fuse-2 to fuse (3). Tobias Geerinckx-Rice 2023-07-23gnu: lxcfs: Use G-expressions....* gnu/packages/virtualization.scm (lxcfs)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-23gnu: lxcfs: Fix build....* gnu/packages/virtualization.scm (lxcfs)[arguments]: Replace the default 'bootstrap phase. Tobias Geerinckx-Rice 2023-07-23gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users. Tobias Geerinckx-Rice 2023-07-26gnu: Add rvvm....* gnu/packages/virtualization.scm (rvvm): New variable. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Juliana Sims 2023-07-23gnu: qemu: Update to 7.2.4....* gnu/packages/virtualization.scm (qemu): Update to 7.2.4. Tobias Geerinckx-Rice 2023-07-16gnu: osinfo-db: Use G-expressions....* gnu/packages/virtualization.scm (osinfo-db)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-16gnu: osinfo-db: Update to 20230719....* gnu/packages/virtualization.scm (osinfo-db): Update to 20230719. Tobias Geerinckx-Rice