aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.44")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "1f6x3srkssjcnrmd9hkladc8nzkwq9rqkiy15r5ksg2k4bq4vp1p"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
iou 2023-10-24gnu: crawl: Update to 0.30.1....* gnu/packages/games.scm (crawl): Update to 0.30.1. Change-Id: Ibf2f041eb94354fd4006f6787a0da028af24f861 Nicolas Goaziou 2023-10-23gnu: colobot: Improve package style....* gnu/packages/games.scm (colobot)[arguments]: Use G-expressions. <#:phases>: Remove trailing #T. [native-inputs, inputs]: Remove labels. Nicolas Goaziou 2023-10-23gnu: colobot: Update to 0.2.1-alpha....* gnu/packages/games.scm (colobot): Update to 0.2.1-alpha. Nicolas Goaziou 2023-10-04gnu: ultrastar-deluxe: Update to 2023.9.0....* gnu/packages/games.scm (ultrastar-deluxe): Update to 2023.9.0. [source]: Use tagged version again. Tested-by: Jonathan Brielmaier <jonathan.brielmaier@web.de> Jonathan Brielmaier 2023-10-03gnu: steam-devices-udev-rules: Update to 1.0.0.61-1.1344348....* gnu/packages/games.scm (steam-devices-udev-rules): Update to 1.0.0.61-1.1344348. John Kehayias 2023-09-24gnu: 7kaa: Update to 2.15.6....* gnu/packages/games.scm (7kaa): Update to 2.15.6. Tobias Geerinckx-Rice 2023-09-27gnu: vcmi: Update to 1.3.2....* gnu/packages/games.scm (vcmi): Update to 1.3.2. Signed-off-by: Christopher Baines <mail@cbaines.net> Zhu Zihao 2023-09-24gnu: alex4: Remove non-free package....Its readme.txt goes out of its way to licence only ‘source code’ under the GPL2+, a reading supposedly confirmed by the author: https://libregamewiki.org/Talk:Alex_the_Allegator_4 However, we don't need to rely on the authenticity of that claim: the game data is clearly not licenced, and is required to run the binary. Without it, the game segfaults. * gnu/packages/games.scm (alex4): Remove variable. Fixes <https://issues.guix.gnu.org/65881>. Tobias Geerinckx-Rice 2023-09-26gnu: gtypist: Install the gtypist-mode Emacs major mode....* gnu/packages/games.scm (gtypist) [source]: Delete trailing #t in snippet. [native-inputs]: Add emacs-minimal. Maxim Cournoyer 2023-09-10gnu: angband: Update to 4.2.5....* gnu/packages/games.scm (angband): Update to 4.2.5. Tobias Geerinckx-Rice 2023-09-17gnu: cockatrice: add wayland dependency...* gnu/packages/games.scm (cockatrice): add wayland dependency Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sergio Pastor Pérez 2023-09-14gnu: armagetronad: Update to 0.2.9.1.1....* gnu/packages/games.scm (armagetronad): Update to 0.2.9.1.1. [inputs]: Add sdl-mixer to fix game audio. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hendursaga 2023-09-13gnu: tennix: Update to 1.3.4....* gnu/packages/games.scm (tennix): Update to 1.3.4. [arguments]<#:phases>: Update style and remove fix-include phase. [inputs]: Remove labels, update to SDL2, add SDL2_gfx dependency. [license]: Remove LGPL license, as SDL_rotozoom is no longer included. Signed-off-by: Christopher Baines <mail@cbaines.net> Hendursaga 2023-09-09gnu: vcmi: Update to 1.3.1....* gnu/packages/games.scm (vcmi): Update to 1.3.1. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Yovan Naumovski 2023-09-02gnu: Add openquest....* gnu/packages/games.scm (openquest): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> AwesomeAdam54321 2023-09-01gnu: utfcpp: Update to 3.2.4....* gnu/packages/textutils.scm (utfcpp): Update to 3.2.4. [snippet]: Unbundle ftest. [arguments]: Remove field. [native-inputs]: Add ftest. * gnu/packages/games.scm (warzone2100)[#:phases]: Adjust 'fix-utfcpp-include. * gnu/packages/video.scm (mkvtoolnix)[#:phases]: Add 'fix-utfcpp-include. Co-authored-by: Hilton Chain <hako@ultrarare.space> Signed-off-by: Hilton Chain <hako@ultrarare.space> Reza Housseini 2023-08-26gnu: freedroidrpg: Update to 1.0....* gnu/packages/games.scm (freedroidrpg): Update to 1.0. 宋文武 2023-08-26gnu: gnubg: Update to 1.07.001....* gnu/packages/games.scm (gnubg): Update to 1.07.001. 宋文武 2023-08-23gnu: knights: Fix build....* gnu/packages/games.scm (knights)[source]: Add snippet. 宋文武 2023-08-23gnu: prboom-plus: Fix build....* gnu/packages/games.scm (prboom-plus)[arguments]<#:configure-flags>: Add "CFLAGS=-fcommon". 宋文武 2023-08-23gnu: tetrinet: Fix build....* gnu/packages/games.scm (tetrinet)[arguments]: Add '-fcommon' to CFLAGS. 宋文武 2023-08-23gnu: alex4: Fix build....* gnu/packages/games.scm (alex4)[arguments]: Add '-fcommon' to CFLAGS. 宋文武 2023-08-23gnu: naev: Fix build....* gnu/packages/games.scm (naev)[inputs]: Don't use sdl-union. Remove sdl2-mixer. 宋文武 2023-08-21gnu: cdogs-sdl: Update to 1.5.0....* gnu/packages/games.scm (cdogs-sdl): Update to 1.5.0. Ricardo Wurmus 2023-08-21gnu: cdogs-sdl: Patch assets directory....* gnu/packages/games.scm (cdogs-sdl)[arguments]: Add phase 'patch-install-directory to ensure data files are installed there. Ricardo Wurmus 2023-08-21gnu: cdogs-sdl: Use G-expression....* gnu/packages/games.scm (cdogs-sdl)[arguments]: Use G-expression and refer to #$output. Ricardo Wurmus 2023-08-15gnu: colobot: Build with librsvg-for-system....* gnu/packages/games.scm (colobot)[native-inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: tuxpaint: Build with librsvg-for-system....* gnu/packages/games.scm (tuxpaint)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: pioneers: Build with librsvg-for-system....* gnu/packages/games.scm (pioneers)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: xboard: Build with librsvg-for-system....* gnu/packages/games.scm (xboard)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-13gnu: corsix-th: Use G-expressions....* gnu/packages/games.scm (corsix-th)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-08-13gnu: corsix-th: Update to 0.67....* gnu/packages/games.scm (corsix-th): Update to 0.67. Tobias Geerinckx-Rice 2023-07-30gnu: xonotic-data: Update to 0.8.6....* gnu/packages/games.scm (xonotic-data): Update to 0.8.6. Tobias Geerinckx-Rice 2023-07-30gnu: openttd-opensfx: Update to 1.0.3....* gnu/packages/games.scm (openttd-opensfx): Update to 1.0.3. Tobias Geerinckx-Rice 2023-07-30gnu: openttd-engine: Update to 13.4....* gnu/packages/games.scm (openttd-engine): Update to 13.4. Tobias Geerinckx-Rice 2023-07-28gnu: Add endgame-singularity....* gnu/packages/games.scm (endgame-singularity): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> TakeV