aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.44")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "1f6x3srkssjcnrmd9hkladc8nzkwq9rqkiy15r5ksg2k4bq4vp1p"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
lipse: Add store "data" package path as default....Adonay Felipe Nogueira 2017-10-09gnu: no-more-secrets: Update to 0.3.3....Tobias Geerinckx-Rice 2017-10-03gnu: mgba: Update to 0.6.1....Rutger Helling 2017-09-22gnu: openttd-opengfx: Disable parallel build....Arun Isaac 2017-09-22gnu: openttd: Include openttd-openmsx and openttd-opensfx....Arun Isaac 2017-09-22gnu: Add openttd-openmsx....Arun Isaac 2017-09-22gnu: Add openttd-opensfx....Arun Isaac 2017-08-31gnu: retux: Update to 1.3.5....Kei Kebreau 2017-08-30gnu: hyperrogue: Update to 10.0g....Kei Kebreau 2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau 2017-08-23gnu: higan: Update to 104....Rutger Helling 2017-08-23gnu: retroarch: Update to 1.6.7....Rutger Helling 2017-08-17gnu: Add mgba....Nicolas Goaziou 2017-08-16gnu: Add ltris....Kei Kebreau 2017-08-13gnu: Update open-adventure to d43854f0f6bb8e9eea7fbce80348150e7e7fc34d....ng0 2017-08-08gnu: 0ad: Update to 0.0.22-alpha....Christopher Baines 2017-08-06gnu: freedoom: Update to 0.11.3....Kei Kebreau 2017-08-01gnu: hyperrogue: Update to 10.0e....Kei Kebreau