aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "066ncw51da1h6w80p6cl6flw8sznk933sf545xa0xzhfpnb8l00b"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
io Flores Guerrero 2020-04-12gnu: openttd: Update to 1.10.0....The os/dos subdirectory has been removed by upstream commit: fdb804d86bcab8d0529bdf6ca925bed04ad2f047 * gnu/packages/games.scm (openttd)[version]: Update to 1.10.0. [source]: Change uri to cdn.openttd.org, remove snippet & modules. Vincent Legoll 2020-04-12gnu: openttd-opengfx: Update to 0.6.0....* gnu/packages/games.scm (openttd-opengfx)[version]: Update to 0.6.0. [source]: Change uri to cdn.openttd.org. [native-inputs]: Add which. Vincent Legoll 2020-04-11gnu: Add tennix....* gnu/packages/games.scm (tennix): New variable. Nicolas Goaziou 2020-04-11gnu: supertux: Update to 0.6.1.1....* gnu/packages/games.scm (supertux): Update to 0.6.1.1. Tobias Geerinckx-Rice 2020-04-10gnu: crispy-doom: Update to 5.7.2....* gnu/packages/games.scm (crispy-doom): Update to 5.7.2. Tobias Geerinckx-Rice 2020-04-09gnu: cataclysm-dda: Update to 0.E....* gnu/packages/games.scm (cataclysm-dda): Update to 0.E. Nicolas Goaziou 2020-04-04gnu: Replace uses of 'gettext' with 'gettext-minimal'....* gnu/packages/cdrom.scm (dvdstyler)[native-inputs]: Change from GNU-GETTEXT to GETTEXT-MINIMAL. * gnu/packages/emulators.scm (dolphin-emu)[native-inputs]: Likewise. * gnu/packages/engineering.scm (lepton-eda, kicad, kicad-i18l)[native-inputs]: Likewise. * gnu/packages/games.scm (quadrapassel, edgar)[native-inputs]: Likewise. * gnu/packages/gnome.scm (eog-plugins, workrave, geary)[native-inputs]: Likewise. * gnu/packages/guile-xyz.scm (guile-gi, emacsy)[native-inputs]: Likewise. * gnu/packages/image.scm (gpick)[native-inputs]: Likewise. * gnu/packages/messaging.scm (telegram-purple)[native-inputs]: Likewise. * gnu/packages/music.scm (fmit)[native-inputs]: Likewise. * gnu/packages/package-management.scm (flatpak)[native-inputs]: Likewise. * gnu/packages/patchutils.scm (quilt)[native-inputs]: Likewise. * gnu/packages/photo.scm (hugin)[native-inputs]: Likewise. * gnu/packages/security-token.scm (eid-mw)[native-inputs]: Likewise. * gnu/packages/telephony.scm (jami)[native-inputs]: Likewise. * gnu/packages/texinfo.scm (pinfo)[native-inputs]: Likewise. * gnu/packages/vulkan.scm (vkd3d)[native-inputs]: Likewise. * gnu/packages/web.scm (cadaver)[native-inputs]: Likewise. Marius Bakke 2020-04-02gnu: nethack: Make some inputs native....* gnu/packages/games.scm (nethack)[inputs]: Move flex & bison from here... [native-inputs]: ...to this new field. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Vincent Legoll 2020-04-01gnu: Add gnome-chess...* gnu/packages/games.scm (gnome-chess): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Jack Hill 2020-03-31gnu: Add neverball...* gnu/packages/games.scm (neverball): New variable. Vitaliy Shatrov 2020-03-29gnu: Remove more packages deprecated for over almost a year....* gnu/packages/games.scm (armagetron-advanced) (cataclysm-dark-days-ahead, gnubackgammon, l-abbaye-des-morts) (the-battle-for-wesnoth, the-battle-for-wesnoth-server) (project-starfighter, kiki-the-nano-bot, fish-fillets-ng) (dungeon-crawl-stone-soup): Let's forget this ever happened. * gnu/packages/emacs-xyz.scm (geiser, paredit, git-modes/old-name) (magit, magit-svn, haskell-mode, emacs-emms-player-mpv, bbdb) (ert-runner, groovy-emacs-modes): Remove variable. * gnu/packages/engineering.scm (emacs-emms-player-simple-mpv) (emacs-evil-ediff, emacs-evil-mu4e, emacs-wgrep-helm, ao): Likewise. * gnu/packages/finance.scm (monero-core): Likewise. * gnu/packages/gnome.scm (dungeon-crawl-stone-soup-tiles) (tales-of-maj-eyal, battle-tanks, the-legend-of-edgar) (gnome-tweak-tool): Likewise. * gnu/packages/gnuzilla.scm (conkeror): Likewise. * gnu/packages/guile-xyz.scm (mcron2): Likewise. * gnu/packages/image.scm (pngcrunch): Likewise. * gnu/packages/linux.scm (eudev-with-hwdb): Likewise. * gnu/packages/maths.scm (qtoctave): Likewise. * gnu/packages/package-management.scm (guile2.0-guix): Likewise. * gnu/packages/php.scm (php-with-bcmath): Likewise. * gnu/packages/python-xyz.scm (python-kivy-next, python2-kivy-next): Likewise. * gnu/packages/video.scm (livestreamer): Likewise. * gnu/packages/virtualization.scm (lookingglass): Likewise. * gnu/packages/vulkan.scm (vulkan-icd-loader): Likewise. * gnu/packages/syndication.scm (newsbeuter): Likewise. (newsboat)[description]: Remove historical footnote. Tobias Geerinckx-Rice 2020-03-26gnu: Add 7kaa....* gnu/packages/games.scm (7kaa): New variable. Naga Malleswari 2020-03-23gnu: extremetuxracer: Update to 0.8.0....* gnu/packages/games.scm (extremetuxracer): Update to 0.8.0. Tobias Geerinckx-Rice 2020-03-19gnu: Add foobillard++....* gnu/packages/games.scm (foobillard++): New variable. * gnu/packages/patches/foobillard++-pkg-config.patch: New file. * gnu/local.mk: Reference new file. Nicolas Goaziou 2020-03-18gnu: pioneer: Use HTTPS home page....* gnu/packages/games.scm (pioneer)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-18gnu: tintin++: Update to 2.02.02....* gnu/packages/games.scm (tintin++): Update to 2.02.02. Tobias Geerinckx-Rice 2020-03-14gnu: talkfilters: Don't use NAME in source URI....* gnu/packages/games.scm (talkfilters)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-03-14gnu: hyperrogue: Update to 11.3a....* gnu/packages/games.scm (hyperrogue): Update to 11.3a. Tobias Geerinckx-Rice 2020-03-13gnu: Add barrage....* gnu/packages/games.scm (barrage): New variable. Alberto Eleuterio Flores Guerrero 2020-03-13gnu: bastet: Use HTTPS home page....* gnu/packages/games.scm (bastet)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-11gnu: fortune-mod: Use HTTPS home page....* gnu/packages/games.scm (fortune-mod)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-11gnu: grue-hunter: Use HTTPS home page....* gnu/packages/games.scm (grue-hunter)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-11gnu: armagetronad: Update to 0.2.8.3.5....* gnu/packages/games.scm (armagetronad): Update to 0.2.8.3.5. Tobias Geerinckx-Rice 2020-03-11gnu: nethack: Update to 3.6.6....* gnu/packages/games.scm (nethack): Update to 3.6.6. Tobias Geerinckx-Rice 2020-03-10gnu: mars: Fix home page....* gnu/packages/games.scm (mars)[home-page]: Use working domain & HTTPS. Tobias Geerinckx-Rice