aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "066ncw51da1h6w80p6cl6flw8sznk933sf545xa0xzhfpnb8l00b"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
6'>gnu: gnucash: Update to 5.0....* gnu/packages/gnucash.scm (gnucash): Update to 5.0. [arguments]<phase>: Patch out unsupported tests. Remove references in patching code to removed source files upstream. * gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0. Signed-off-by: Leo Famulari <leo@famulari.name> Andy Tai 2022-09-13gnu: gnucash: Update to 4.11 and use gexps....* gnu/packages/gnucash.scm: Sort imports. (gnucash): Update to 4.11. Re-order fields, moving inputs after arguments. [arguments]: Use gexps. [phases]: Delete trailing #t. {unpack-gmock}: Delete phase. {set-env-vars}: Use search-input-directory. {install-locales}: Use gexps. {split-python-bindings}: Likewise. {wrap-programs}: Likewise. Also use search-input-file. [native-inputs]: Delete labels. Remove googlemock source. Sort. [inputs]: Delete labels. Sort. (gnucash-docs): Adjust URI and update hash. [native-inputs]: Delete labels. Sort. Maxim Cournoyer 2022-06-05gnu: aqbanking: Do not embed build date....* gnu/packages/gnucash.scm (aqbanking)[arguments]: Add 'use-version-instead-of-date phase. Vagrant Cascadian 2022-04-17gnu: gnucash: Update to 4.10....Variables gnucash and gnucash-docs have to be updated together. * gnu/packages/gnucash.scm (gnucash)[version]: Update to 4.10. (gnucash-docs)[version]: Update to 4.10. [build-system]: Migrate from gnu to cmake. [arguments]: Disable tests. Raghav Gururajan 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-16gnu: gnucash: Use webkitgtk-with-libsoup2....* gnu/packages/gnucash.scm (gnucash)[inputs]: Replace webkitgtk by webkitgtk-with-libsoup2. Guillaume Le Vaillant 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke 2021-10-13gnu: aqbanking: Update to 6.3.2....* gnu/packages/gnucash.scm (aqbanking): Update to 6.3.2. Tobias Geerinckx-Rice 2021-09-12gnu: gnucash: Update to 4.6....* gnu/packages/gnucash.scm (gnucash): Update to 4.6. [native-inputs]: Add gmp. Guillaume Le Vaillant 2021-05-26gnu: aqbanking: Update to 6.3.0....* gnu/packages/gnucash.scm (aqbanking): Update to 6.3.0. Kei Kebreau 2021-05-26gnu: gwenhywfar: Update to 5.6.0....* gnu/packages/gnucash.scm (gwenhywfar): Update to 5.6.0. Kei Kebreau