aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "066ncw51da1h6w80p6cl6flw8sznk933sf545xa0xzhfpnb8l00b"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
21:00:05 +0200'>2023-04-09gnu: haproxy: Update to 2.7.6....* gnu/packages/high-availability.scm (haproxy): Update to 2.7.6. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Yovan Naumovski 2023-03-26gnu: haproxy: Move to (gnu packages high-availability)....Copyright records were synchronized based on commit history. * gnu/packages/networking.scm (haproxy): Move this variable from here... * gnu/packages/high-availability.scm (haproxy): ...to here. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add pacemaker....* gnu/pacemaker/high-availability.scm (pacemaker): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add corosync....* gnu/packages/high-availability.scm (corosync): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add kronosnet....* gnu/packages/high-availability.scm (kronosnet): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: libqb: Update to 2.0.6....* gnu/packages/high-availability.scm (libqb): Update to 2.0.6. Run `guix style' over the package. [native-inputs]: Add autoconf, automake, libtools to fix configure and build phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Move libqb to high-availability....* gnu/packages/hardware.scm (libqb): Move to high-availability.scm. * gnu/packages/high-availability.scm: New file. * gnu/local.mk: Add high-availability.scm to GNU_SYSTEM_MODULES list. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher