aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mtools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages))

(define-public mtools
  (package
    (name "mtools")
    (version "4.0.44")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mtools/mtools-"
                                  version ".tar.bz2"))
              (sha256
               (base32
                "1f6x3srkssjcnrmd9hkladc8nzkwq9rqkiy15r5ksg2k4bq4vp1p"))
              (patches
               (search-patches "mtools-mformat-uninitialized.patch"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/mtools/")
    (synopsis "Access MS-DOS disks without mounting")
    (description
     "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
or Unix system.  It supports long file names and multiple disk formats.  It
also supports some FAT-specific features such as volume labels and
FAT-specific file attributes.")
    (license gpl3+)))
d>gnu: ImageMagick: Build reproducibly....Marius Bakke 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-14Merge branch 'staging'Marius Bakke 2020-03-14gnu: GraphicsMagick: Update to 1.3.35....Marius Bakke 2020-02-24gnu: ImageMagick: Update to 6.9.10-95....Marius Bakke 2020-02-14gnu: ImageMagick: Update to 6.9.10-92....Marius Bakke 2020-02-03Merge branch 'staging' into core-updatesMarius Bakke 2020-02-03Merge branch 'master' into stagingMarius Bakke 2020-01-29gnu: GraphicsMagick: Update to 1.3.34....Leo Famulari 2020-01-22gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'....Marius Bakke 2020-01-19gnu: ImageMagick: Update to 6.9.10-87....Marius Bakke 2019-12-13Merge branch 'master' into stagingBrett Gilio 2019-12-12gnu: graphicsmagick: Update to 1.3.33....Tobias Geerinckx-Rice 2019-12-11gnu: imagemagick: Update to 6.9.10-78....Marius Bakke 2019-10-08gnu: imagemagick: Update to 6.9.10-68....Marius Bakke 2019-08-04gnu: ImageMagick: Update to 6.9.10-58....Marius Bakke 2019-07-04Merge branch 'master' into stagingMarius Bakke 2019-07-03gnu: GraphicsMagick: Update to 1.3.32....Leo Famulari 2019-07-02gnu: ImageMagick: Update to 6.9.10-51....Marius Bakke 2019-06-30gnu: ImageMagick: Update to 6.9.10-50....Marius Bakke 2019-06-14gnu: imagemagick: Update to 6.9.10-49....Marius Bakke 2019-05-24gnu: imagemagick: Update to 6.9.10-46....Marius Bakke 2019-05-13gnu: ImageMagick: Update to 6.9.10-45....Marius Bakke 2019-05-04gnu: imagemagick: Update to 6.9.10-42....Marius Bakke 2019-04-01gnu: ImageMagick: Update to 6.9.10-35....Marius Bakke 2019-03-23gnu: imagemagick: Update to 6.9.10-34....Marius Bakke 2019-03-23Merge branch 'master' into stagingMarius Bakke 2019-03-22gnu: graphicsmagick: Update to 1.3.31....Tobias Geerinckx-Rice 2019-03-22gnu: graphicsmagick: Don't use NAME in source URI....Tobias Geerinckx-Rice 2019-02-10gnu: ImageMagick: Update to 6.9.10-27....Marius Bakke 2018-12-12gnu: ImageMagick: Update to 6.9.9-16....Marius Bakke 2018-12-04gnu: imagemagick: Update to 6.9.10-15....Marius Bakke 2018-11-14gnu: ImageMagick: Update to 6.9.10-14....Alex Vong