aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages motti)
  #:use-module (gnu packages)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download))

(define-public motti
  (package
    (name "motti")
    (version "3.1.1")
    (source
      (origin
        (method url-fetch)
        (uri (string-append
               "mirror://gnu/motti/motti-" version ".tar.gz"))
        (sha256
         (base32
          "0ag4gpxy42l30660b4f2lrp52xi5sik9s6frr7jfxqxjsf29lbb3"))))
    (build-system gnu-build-system)
    (synopsis "Multiplayer strategy game")
    (description
     "GNU Motti is a simple multiplayer strategy game played in a terminal.
The objective of the game is to conquer enemy capitals by occupying and
encircling territory.")
    (home-page "https://www.gnu.org/software/motti")
    (license gpl3+)))
tr> 2020-01-03gnu: fasm: Expand acronym in description....Tobias Geerinckx-Rice 2020-01-03gnu: fasm: Update to 1.73.21....Tobias Geerinckx-Rice 2020-01-03gnu: Add rgbds....Jakub Kądziołka 2019-12-01gnu: nasm: Don't use NAME in source URI....Tobias Geerinckx-Rice 2019-10-21gnu: yasm: Disable parallel tests....Christopher Baines 2019-10-12gnu: lightning: Update to 2.1.3....Tobias Geerinckx-Rice 2019-05-25Merge branch 'staging' into core-updatesMarius Bakke 2019-05-24gnu: Add libjit....Andy Tai 2019-05-08gnu: fasm: Update to 1.73.11....Tobias Geerinckx-Rice 2019-05-01Merge branch 'master' into core-updatesMarius Bakke 2019-04-11gnu: fasm: Update to 1.73.10....Tobias Geerinckx-Rice 2019-03-10gnu: nasm: Update to 2.14.02....Marius Bakke 2019-02-21gnu: fasm: Update to 1.73.09....Tobias Geerinckx-Rice 2019-02-15gnu: fasm: Update to 1.73.08....Tobias Geerinckx-Rice 2019-01-13gnu: nasm: Update license....Marius Bakke 2019-01-13gnu: nasm: Update home page....Marius Bakke 2019-01-09gnu: fasm: Update comments....Danny Milosavljevic 2019-01-09gnu: fasm: Fix grammatical errors in description....Danny Milosavljevic 2019-01-09gnu: Add dev86....Danny Milosavljevic 2019-01-05gnu: Add fasm....guy fleury iteriteka