;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2019 L p R n d n ;;; Copyright © 2021 Guillaume Le Vaillant ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages arcan) #:use-module (guix build-system cmake) #:use-module (guix build-system gnu) #:use-module (guix git-down
aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2016, 2017, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016–2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moreutils)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages docbook)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages xml)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix utils))

(define-public moreutils
  (package
    (name "moreutils")
    (version "0.69")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
                    name "-" version ".tar.gz"))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "1l859qnzccslvxlh5ghn863bkq2vgmqgnik6jr21b9kc6ljmsy8g"))))
    (build-system gnu-build-system)
    (arguments
     (list #:phases
           #~(modify-phases %standard-phases
               (add-after 'install 'wrap-program
                 (lambda _
                   (for-each
                     (lambda (script)
                       (wrap-program script
                         `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
                     (find-files (string-append #$output "/bin")))))
               (delete 'configure))     ; no configure script
           #:make-flags
           #~(list (string-append "PREFIX=" #$output)
                   (string-append "DOCBOOKXSL="
                                  #$(this-package-native-input "docbook-xsl")
                                  "/xml/xsl/docbook-xsl-"
                                  #$(package-version (this-package-native-input
                                                      "docbook-xsl")))
                   (string-append "CC=" #$(cc-for-target)))))
    (inputs
     (list bash-minimal
           perl
           perl-ipc-run
           perl-timedate
           perl-time-duration))
    ;; For building the manual pages.
    (native-inputs
     (list docbook-xml-4.4
           docbook-xsl
           libxml2
           libxslt))
    (home-page "https://joeyh.name/code/moreutils/")
    (synopsis "Miscellaneous general-purpose command-line tools")
    (description
     "Moreutils is a collection of general-purpose command-line tools to
augment the traditional Unix toolbox.")
    (properties
     '((release-monitoring-url . "https://git.joeyh.name/index.cgi/moreutils.git/")))
    (license license:gpl2+)))
(uri (git-reference (url "https://github.com/letoram/openal") (commit "1c7302c580964fee9ee9e1d89ff56d24f934bdef"))) (sha256 (base32 "0dcxcnqjkyyqdr2yk84mprvkncy5g172kfs6vc4zrkklsbkr8yi2")))))) (native-inputs (list pkg-config ruby)) ; For documentation and testing (home-page "https://arcan-fe.com") (synopsis "Display server, multimedia framework and game engine (egl-dri)") (description "Arcan is a development framework for creating virtually anything from user interfaces for specialized embedded applications all the way to full-blown desktop environments. At its heart lies a multimedia engine programmable using Lua.") ;; https://github.com/letoram/arcan/blob/master/COPYING (license (list license:gpl2+ license:lgpl2.0 license:lgpl2.0+ license:public-domain license:bsd-3))))) (define-public arcan-sdl (package (inherit arcan) (name "arcan-sdl") (inputs (modify-inputs (package-inputs arcan) (delete "libdrm") (prepend sdl))) (arguments `(,@(ensure-keyword-arguments (package-arguments arcan) '(#:configure-flags '("-DCMAKE_C_FLAGS=-fcommon" "-DVIDEO_PLATFORM=sdl" "-DBUILTIN_LUA=off" "-DSTATIC_OPENAL=off" "-DDISABLE_JIT=off" "-DENABLE_LWA=on" "-DSTATIC_SQLITE3=off" "-DSTATIC_FREETYPE=off" "-DSHMIF_TUI_ACCEL=on"))))) (synopsis "Combined display server, multimedia framework and game engine (SDL)"))) (define-public xarcan (let ((commit "8e6ee029388326cfe5cddeffe482eb3702e9b7f3") (revision "1" )) (package (name "xarcan") (version (git-version "0.5.4" revision commit)) (source (origin (method git-fetch) (file-name (git-file-name name version)) (uri (git-reference (url "https://github.com/letoram/xarcan") (commit commit))) (sha256 (base32 "0zng7cs6733mnf0p6g5wv02981f2sf567n56csax6cmzb8fpamym")))) (build-system gnu-build-system) (arguments `(#:configure-flags `("--enable-kdrive" "--enable-xarcan" "--disable-xorg" "--disable-xwayland" "--disable-xnest" "--disable-xvfb" "--enable-glamor" "--enable-glx" "--disable-int10-module" "--enable-ipv6" "--enable-record" "--without-systemd-daemon" "--enable-xcsecurity" "--disable-static" ,(string-append "--with-xkb-path=" (assoc-ref %build-inputs "xkeyboard-config") "/share/X11/xkb") ,(string-append "--with-xkb-bin-directory=" (assoc-ref %build-inputs "xkbcomp") "/bin") ,(string-append "--with-xkb-output=" "/tmp")))) ; FIXME: Copied from xorg (native-inputs (list pkg-config autoconf automake libtool util-macros)) (inputs `(("arcan" ,arcan) ("font-util" ,font-util) ("libdrm" ,libdrm) ("libepoxy" ,libepoxy) ("libkbfile" ,libxkbfile) ("libressl" ,libressl) ("libx11" ,libx11) ("libxfont2" ,libxfont2) ("mesa" ,mesa) ("pixman" ,pixman) ("xkeyboard-config" ,xkeyboard-config) ("xkbcomp" ,xkbcomp) ("xorgproto" ,xorgproto) ("xtrans" ,xtrans))) (home-page "https://arcan-fe.com") (synopsis "Patched Xserver that bridges connections to Arcan") (description "Patched Xserver with a KDrive backend that uses the arcan-shmif to map Xlib/Xcb/X clients to a running arcan instance. It allows running an X session as a window under Arcan.") (license license:expat)))) (define-public arcan-wayland (package (inherit arcan) (name "arcan-wayland") (native-inputs (list pkg-config)) (inputs (list arcan libseccomp libxkbcommon mesa wayland wayland-protocols)) (arguments `(#:tests? #f #:phases (modify-phases %standard-phases (add-before 'configure 'chdir (lambda _ (chdir "src/tools/waybridge") #t)) (add-after 'unpack 'fix-cmake-find-shmif (lambda* (#:key inputs #:allow-other-keys) (substitute* "src/platform/cmake/modules/Findarcan_shmif.cmake" (("/usr/local") (assoc-ref inputs "arcan"))) #t))))) (synopsis "Wayland protocol service for Arcan") (description "Arcan-wayland (waybridge) bridges Wayland connections with an Arcan connection point. It allows Wayland compatible clients to connect and render using Arcan.") (license license:bsd-3)))