aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2016, 2017, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016–2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moreutils)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages docbook)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages xml)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix utils))

(define-public moreutils
  (package
    (name "moreutils")
    (version "0.69")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
                    name "-" version ".tar.gz"))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "1l859qnzccslvxlh5ghn863bkq2vgmqgnik6jr21b9kc6ljmsy8g"))))
    (build-system gnu-build-system)
    (arguments
     (list #:phases
           #~(modify-phases %standard-phases
               (add-after 'install 'wrap-program
                 (lambda _
                   (for-each
                     (lambda (script)
                       (wrap-program script
                         `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
                     (find-files (string-append #$output "/bin")))))
               (delete 'configure))     ; no configure script
           #:make-flags
           #~(list (string-append "PREFIX=" #$output)
                   (string-append "DOCBOOKXSL="
                                  #$(this-package-native-input "docbook-xsl")
                                  "/xml/xsl/docbook-xsl-"
                                  #$(package-version (this-package-native-input
                                                      "docbook-xsl")))
                   (string-append "CC=" #$(cc-for-target)))))
    (inputs
     (list bash-minimal
           perl
           perl-ipc-run
           perl-timedate
           perl-time-duration))
    ;; For building the manual pages.
    (native-inputs
     (list docbook-xml-4.4
           docbook-xsl
           libxml2
           libxslt))
    (home-page "https://joeyh.name/code/moreutils/")
    (synopsis "Miscellaneous general-purpose command-line tools")
    (description
     "Moreutils is a collection of general-purpose command-line tools to
augment the traditional Unix toolbox.")
    (properties
     '((release-monitoring-url . "https://git.joeyh.name/index.cgi/moreutils.git/")))
    (license license:gpl2+)))
8 +0100'>2018-11-05gnu: xapian: Update to 1.4.9....* gnu/packages/patches/xapian-revert-5489fb2f8.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/search.scm (xapian): Update to 1.4.9. [source](patches): Remove. (python-xapian-bindings): Update to 1.4.9. Marius Bakke 2018-08-01gnu: xapian: Update to 1.4.7....* gnu/packages/search.scm (xapian, python-xapian-bindings): Update to 1.4.7. Marius Bakke 2018-07-13gnu: xapian: Fix notmuch test failure....* gnu/packages/patches/xapian-revert-5489fb2f8.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/search.scm (xapian)[source](patches): Use it. Marius Bakke 2018-07-12gnu: xapian: Update to 1.4.6 [fixes CVE-2018-0499]....* gnu/packages/search.scm (xapian, python-xapian-bindings): Update to 1.4.6. Marius Bakke 2018-06-22gnu: libtocc: Return #t from all phases....* gnu/packages/search.scm (libtocc)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases. Re-indent. Tobias Geerinckx-Rice 2018-05-31gnu: xapian: Use INVOKE....* gnu/packages/search.scm (xapian)[arguments]: Substitute INVOKE for SYSTEM*. Tobias Geerinckx-Rice 2018-05-26gnu: xapers: Fix recommended packages...* gnu/packages/search.scm (xapers): [inputs]: remove python, poppler [propagated-inputs]: add poppler, xclip, xdg-utils. [arguments]: modify-phases to disable x-terminal options. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Adam Massmann 2018-04-04gnu: xapers: Fix man page and xapers-adder installation...* gnu/packages/search.scm (xapers)[arguments]: Adjust install-file destinations in install-doc phase. Signed-off-by: Eric Bavier <bavier@member.fsf.org> Adam Massmann 2018-04-04gnu: Add xapers...* gnu/packages/search.scm (xapers): New variable. Signed-off-by: Eric Bavier <bavier@member.fsf.org> Adam Massmann 2018-03-05gnu: tocc, libtocc: Use HTTPS home page....* gnu/packages/search.scm (libtocc, tocc)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2018-01-27gnu: python-xapian-bindings: Don't hard-code Python sitedir....* gnu/packages/search.scm (python-xapian-bindings)[arguments]: In #:make-flags, use VERSION-MAJOR+MINOR to set pkgpylibdir. Marius Bakke 2017-12-10gnu: xapian: Update to 1.4.5....* gnu/packages/search.scm (xapian, python-xapian-bindings): Update to 1.4.5. Marius Bakke