aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mold)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system trivial)
  #:use-module (gnu packages base)
  #:use-module (gnu packages c)
  #:use-module (gnu packages digest)
  #:use-module (gnu packages tbb)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages compression)
  #:use-module ((guix licenses) #:prefix license:))

(define-public mold
  (package
    (name "mold")
    (version "2.35.1")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/rui314/mold")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1zsnc2x7j0xrdmy49sbr3m131cwpxdhabh05cljkfh3ff0ypp4pb"))
       (modules '((guix build utils)))
       (snippet
        #~(begin
            (for-each
             (lambda (x)
               (delete-file-recursively (string-append "third-party/" x)))
             '("mimalloc" "tbb" "xxhash" "zlib" "zstd"))))))
    (build-system cmake-build-system)
    (arguments
     (list
      ;; Mold only uses mimalloc on 64-bit systems, even with the
      ;; configure flag set, saying it is unstable on 32-bit systems.
      #:configure-flags #~(list #$@(if (target-64bit?)
                                       '("-DMOLD_USE_SYSTEM_MIMALLOC=ON")
                                       '("-DMOLD_USE_MIMALLOC=OFF"))
                                "-DMOLD_USE_SYSTEM_TBB=ON"
                                "-DBUILD_TESTING=ON")
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'configure 'force-system-xxhash
            (lambda _
              (substitute* "lib/common.h"
                (("#include \"../third-party/xxhash/xxhash.h\"")
                 "#include <xxhash.h>"))))
          (add-before 'configure 'fix-compiler-name-in-test
            (lambda _
              (substitute* "test/common.inc"
                (("CC=\"\\$\\{TEST_CC:-cc\\}\"") "CC=gcc")
                (("CXX=\"\\$\\{TEST_CXX:-c\\+\\+\\}\"")
                 "CXX=g++"))))
          (add-before 'configure 'skip-tbb-lto-test
            (lambda _
              ;; This test needs tbb 2021.9.0 or newer
              (delete-file "test/lto-version-script.sh")))
          (add-before 'configure 'disable-rpath-test
            (lambda _
              ;; This test fails because mold expect the RUNPATH as-is,
              ;; but compiler in Guix will insert the path of gcc-lib and
              ;; glibc into the output binary.
              (delete-file "test/rpath.sh"))))))
    (inputs
     (append
       (if (target-64bit?)
           (list mimalloc)
           '())
       (list tbb xxhash zlib `(,zstd "lib"))))
    (home-page "https://github.com/rui314/mold")
    (synopsis "Fast linker")
    (description
     "Mold is a faster drop-in replacement for existing linkers.
It is designed to increase developer productivity by reducing build time,
especially in rapid debug-edit-rebuild cycles.")
    (license license:agpl3)))

(define* (make-mold-wrapper mold #:key mold-as-ld?)
  "Return a MOLD wrapper.  When MOLD-AS-LD? is true, create a 'ld' symlink that
points to 'mold'."
  (package
    (inherit mold)
    (name (if mold-as-ld? "mold-as-ld-wrapper" "mold-wrapper"))
    (source #f)
    (native-inputs '())
    (inputs (list (make-ld-wrapper "ld.mold-wrapper" #:binutils mold
                                   #:linker "ld.mold")
                  (make-ld-wrapper "mold-wrapper" #:binutils mold #:linker
                                   "mold")))
    (propagated-inputs '())
    (build-system trivial-build-system)
    (arguments
     (list #:builder
           #~(let ((ld.mold (string-append #$(this-package-input
                                              "ld.mold-wrapper")
                                           "/bin/ld.mold"))
                   (mold (string-append #$(this-package-input "mold-wrapper")
                                        "/bin/mold")))
               (mkdir #$output)
               (mkdir (string-append #$output "/bin"))
               (symlink ld.mold (string-append #$output "/bin/ld.mold"))
               (symlink mold (string-append #$output "/bin/mold"))
               (when #$mold-as-ld?
                 (symlink ld.mold (string-append #$output "/bin/ld"))))))
    (synopsis "Mold linker wrapper")
    (description "This is a linker wrapper for Mold; like @code{ld-wrapper}, it
wraps the linker to add any missing @code{-rpath} flags, and to detect any
misuse of libraries outside of the store.")))

(define-public mold-wrapper
  (make-mold-wrapper mold))

(define-public mold-as-ld-wrapper
  (make-mold-wrapper mold #:mold-as-ld? #t))
/a>...Xonsh vim emulation mode/environment variable does not work without this. * gnu/packages/shell.scm (xonsh)[inputs]: Add PYTHON-PROMPT-TOOLKIT. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> jgart 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-06gnu: tcsh: Fix riscv64 cross-compilation....* gnu/packages/shells.scm (tcsh): fix riscv64 cross-build. [arguments]<#:phase>: Add 'update-config-scripts' phase for riscv64. [native-inputs]: Add CONFIG for riscv64. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Z572 2023-03-31gnu: zsh: Patch failing test that uses egrep....* gnu/packages/patches/zsh-egrep-failing-test.patch: New file. * gnu/packages/shells.scm (zsh): Patch it. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-27gnu: oil: Update to 0.14.2....* gnu/packages/shells.scm (oil): Update to 0.14.2. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Gruber 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-26gnu: fish: Update to 3.6.0....* gnu/packages/shells.scm (fish): Update to 3.6.0. [source]: Remove snippet, as the bundled PCRE2 sources have been removed (see CHANGELOG.rst). Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Winter 2023-02-16gnu: scsh: Use a search path....* gnu/packages/shells.scm (scsh)[source]: Add patch. [native-search-paths]: New field. * gnu/packages/patches/scsh-nonstring-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-12-11gnu: oil: Update to 0.12.9....* gnu/packages/shells.scm (oil): Update to 0.12.9. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Capitalise description sentences....* gnu/packages/shells.scm (dash)[description]: Capitalise ‘dash’. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Update to 0.5.12....* gnu/packages/shells.scm (dash): Update to 0.5.12. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2022-12-09gnu: xonsh: Update to 0.13.4....* gnu/packages/shells.scm (xonsh): Update to 0.13.4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Edison Ibáñez 2022-10-26gnu: oil: Update to 0.12.7....* gnu/packages/shells.scm (oil): Update to 0.12.7. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Felix Gruber 2022-09-27Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm Maxim Cournoyer 2022-09-22gnu: xonsh: Update to 0.13.3....* gnu/packages/shells.scm (xonsh): Update to 0.13.3. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> arkhan 2022-08-27Merge branch 'staging' into core-updatesMarius Bakke 2022-08-27gnu: oil: Update to 0.12.4....* gnu/packages/shells.scm (oil): Update to 0.12.4. Signed-off-by: Marius Bakke <marius@gnu.org> Felix Gruber 2022-08-27gnu: xonsh: Update to 0.13.1...* gnu/packages/shells.scm (xonsh): Update to 0.13.0. Signed-off-by: Marius Bakke <marius@gnu.org> arkhan 2022-08-17gnu: fish: Update to 3.5.1....* gnu/packages/shells.scm (fish): Update to 3.5.1. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Mike Jones 2022-08-11Merge branch 'staging' into core-updatesMarius Bakke 2022-07-27Merge branch 'staging' into core-updatesMarius Bakke 2022-07-24gnu: oil: Update to 0.12.0....* gnu/packages/shells.scm (oil): Update to 0.12.0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Felix Gruber 2022-07-24gnu: es: Use URL-FETCH/TARBOMB....* gnu/packages/shells.scm (es)[source]: Use URL-FETCH/TARBOMB to let us… [arguments]: …delete the ad-hoc 're-enter-rootdir phase. Tobias Geerinckx-Rice 2022-07-24gnu: es: Update to 0.9.2....* gnu/packages/shells.scm (es): Update to 0.9.2. Tobias Geerinckx-Rice 2022-07-22Merge branch 'staging' into core-updatesMarius Bakke 2022-07-12gnu: xonsh: Update to 0.13.0...* gnu/packages/shells.scm (xonsh): Update to 0.13.0. [source]: Rewrite snippet as a gexp. [native-inputs]: Add python-setuptools, python-wheel [inputs]: Add python-distro, python-pygments, python-pyperclip, python-setproctitle Signed-off-by: Ludovic Courtès <ludo@gnu.org> arkhan