aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moe)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages compression)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public moe
  (package
    (name "moe")
    (version "1.14")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/moe/moe-"
                          version ".tar.lz"))
      (sha256
       (base32 "17cw43zsahisz5msqdv366np3zrdschgnm1lk1pm26dfw1nbvfpl"))))
    (build-system gnu-build-system)
    (native-inputs (list lzip))
    (inputs (list ncurses))
    (home-page "https://www.gnu.org/software/moe/moe.html")
    (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
    (description
     "GNU Moe is a powerful-but-simple-to-use text editor.  It works in a
modeless manner, and features an intuitive set of key-bindings that
assign a degree of severity to each key; for example, key
combinations with the Alt key are for harmless commands like cursor
movements while combinations with the Control key are for commands
that will modify the text.  Moe features multiple windows, unlimited
undo/redo, unlimited line length, global search and replace, and
more.")
    (license gpl2+)))
-minimal)[arguments]: Rewrite the unused 'apply-guix-specific-patches' phase so that it applies the following two patches. [native-search-paths]: New field. * gnu/packages/patches/icecat-compare-paths.patch: New patch that compares add-on paths (which are package store paths) to detect package changes. * gnu/packages/patches/icecat-use-system-wide-dir.patch: New patch that replaces "/usr/lib/mozilla" (the system-wide directory for extensions and native manifests) with "$ICECAT_SYSTEM_DIR". Clément Lassieur 2023-10-09gnu: icu4c-73-promise: Fix broken test....* gnu/local.mk (dist_patch_DATA): Add patch. * gnu/packages/gnuzilla.scm (icu4c-73-promise)[source]: Add patch. * gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch: New file. Clément Lassieur 2023-10-03gnu: icecat: Update to 115.3.1-guix0-preview1 [fixes CVE-2023-5217]....* gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Mark H Weaver 2023-09-28gnu: icecat: Update to 115.3.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2023-5168, CVE-2023-5169, CVE-2023-5171, CVE-2023-5174, and CVE-2023-5176. * gnu/packages/gnuzilla.scm (icu4c-73-promise): New variable. (all-mozilla-locales, %icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. (icecat-minimal)[inputs]: Use icu4c-73-promise. Remove nss. [native-inputs]: Use rust-cbindgen-0.24, llvm-15, clang-15, and node-lts. [arguments]<configure-flags>: Comment out "--with-system-nss". [description]: "IceCat 102" --> "IceCat 115". (%icecat-locales): Update. (all-mozilla-102-locales, %icecat-102-base-version) (%icecat-102-version, icecat-102-source): New variables bound to the old values, for use by icedove. (icedove-source): Ues 'icecat-102-source'. (make-l10n-package)[arguments]<phases>: Simplify reference to '#$locales, and thereby eliminate the unnecessary dependence on %icedove-locales by icecat-l10n, and similarly on %icecat-locales by icedove-l10n. [native-inputs]: Use node-lts. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new upstream. * gnu/packages/patches/icecat-102-makeicecat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Mark H Weaver 2023-09-17gnu: icecat: Update to 102.15.1 [security fixes]....This fixes fix mfsa2023-40, a critical webp vulnerability. See https://www.mozilla.org/en-US/security/advisories/mfsa2023-40/ * gnu/packages/gnuzilla.scm (%icecat-base-version, icecat-source): Update to 102.15.1. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Dr. Arne Babenhauserheide 2023-09-01gnu: icedove: Update to 102.15.0....* gnu/packages/gnuzilla.scm (icedove): Update to 102.15.0. Jonathan Brielmaier 2023-08-30gnu: icecat: Update to 102.15.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2023-4573, CVE-2023-4574, CVE-2023-4575, CVE-2023-4576, CVE-2023-4581, and CVE-2023-4584. * gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Mark H Weaver 2023-08-01gnu: icecat: Update to 102.14.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2023-4045, CVE-2023-4046, CVE-2023-4047, CVE-2023-4048, CVE-2023-4049, CVE-2023-4050, CVE-2023-4054, CVE-2023-4055, and CVE-2023-4056. * gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, upstream base version, and hashes. Mark H Weaver 2023-07-10gnu: icedove: Update to 102.13.0....* gnu/packages/gnuzilla.scm (icedove): Update to 102.13.0. Jonathan Brielmaier 2023-07-04gnu: icecat: Update to 102.13.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2023-37201, CVE-2023-37202, CVE-2023-37207, CVE-2023-37208, and CVE-2023-37211. * gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Mark H Weaver 2023-06-11gnu: icedove: Update to 102.12.0....* gnu/packages/gnuzilla.scm (%icedove-version, thunderbird-comm-source): Update to 102.12.0. Jonathan Brielmaier 2023-06-06gnu: icecat: Update to 102.12.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2023-34414 and CVE-2023-34416. * gnu/packages/gnuzilla.scm (%icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Mark H Weaver 2023-05-29gnu: icedove: Update to 102.11.2....* gnu/packages/gnuzilla.scm (%icedove-version): Update to 102.11.2. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de> Jonathan Brielmaier