aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moe)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages compression)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public moe
  (package
    (name "moe")
    (version "1.14")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/moe/moe-"
                          version ".tar.lz"))
      (sha256
       (base32 "17cw43zsahisz5msqdv366np3zrdschgnm1lk1pm26dfw1nbvfpl"))))
    (build-system gnu-build-system)
    (native-inputs (list lzip))
    (inputs (list ncurses))
    (home-page "https://www.gnu.org/software/moe/moe.html")
    (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
    (description
     "GNU Moe is a powerful-but-simple-to-use text editor.  It works in a
modeless manner, and features an intuitive set of key-bindings that
assign a degree of severity to each key; for example, key
combinations with the Alt key are for harmless commands like cursor
movements while combinations with the Control key are for commands
that will modify the text.  Moe features multiple windows, unlimited
undo/redo, unlimited line length, global search and replace, and
more.")
    (license gpl2+)))
hon… [inputs]: …to their proper home and remove libaio. Tobias Geerinckx-Rice 2020-05-13gnu: samba: Remove obsolete iniparser input....* gnu/packages/samba.scm (samba)[inputs]: Remove iniparser. Tobias Geerinckx-Rice 2020-05-11gnu: samba: Update to 4.11.9....* gnu/packages/samba.scm (samba): Update to 4.11.9. Tobias Geerinckx-Rice 2020-05-10gnu: samba: Update to 4.11.8 [fixes CVE-2020-10700, CVE-2020-10704]....* gnu/packages/samba.scm (samba): Update to 4.11.8. Tobias Geerinckx-Rice 2020-03-07gnu: ppp: Update to 2.4.8-1.8d45443 [fixes CVE-2020-8597]....* gnu/packages/samba.scm (ppp): Update to 2.4.8-1.8d45443. Use GIT-FETCH and GIT-FILE-NAME. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Vincent Legoll 2020-02-05gnu: ppp: Update to 2.4.8....* gnu/packages/samba.scm (ppp): Update to 2.4.8. [source]: Change to GIT-FETCH. Marius Bakke 2020-01-30gnu: samba: Update to 4.11.6....* gnu/packages/samba.scm (samba): Update to 4.11.6. Marius Bakke 2020-01-16gnu: ldb: Downgrade to 1.5.6....1.5.6 is actually newer and fixes problems with Python 3.8. * gnu/packages/samba.scm (ldb): Downgrade to 1.5.6. Marius Bakke 2019-12-24gnu: samba: Update to 4.11.4....* gnu/packages/samba.scm (samba): Update to 4.11.4. Tobias Geerinckx-Rice 2019-12-24gnu: tevent: Update to 0.10.2....* gnu/packages/samba.scm (tevent): Update to 0.10.2. Tobias Geerinckx-Rice 2019-12-24gnu: talloc: Update to 2.3.1....* gnu/packages/samba.scm (talloc): Update to 2.3.1. Tobias Geerinckx-Rice 2019-12-24gnu: cifs-utils: Update phase style....* gnu/packages/samba.scm (cifs-utils)[arguments]: Use keyword arguments in phases. Tobias Geerinckx-Rice 2019-12-24gnu: cifs-utils: Update to 6.10....* gnu/packages/samba.scm (cifs-utils): Update to 6.10. [arguments]: Force a ‘bootstrap’. Add a ‘create-man8dir’ phase. Tobias Geerinckx-Rice 2019-11-13gnu: iniparser: Don't use unstable tarball....* gnu/packages/samba.scm (iniparser)[source]: Download using git-fetch. Efraim Flashner 2019-11-01gnu: samba: Update to 4.11.2....* gnu/packages/samba.scm (samba): Update to 4.11.2. Tobias Geerinckx-Rice 2019-09-24Merge branch 'master' into core-updatesLudovic Courtès