aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moe)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages compression)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public moe
  (package
    (name "moe")
    (version "1.14")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/moe/moe-"
                          version ".tar.lz"))
      (sha256
       (base32 "17cw43zsahisz5msqdv366np3zrdschgnm1lk1pm26dfw1nbvfpl"))))
    (build-system gnu-build-system)
    (native-inputs (list lzip))
    (inputs (list ncurses))
    (home-page "https://www.gnu.org/software/moe/moe.html")
    (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
    (description
     "GNU Moe is a powerful-but-simple-to-use text editor.  It works in a
modeless manner, and features an intuitive set of key-bindings that
assign a degree of severity to each key; for example, key
combinations with the Alt key are for harmless commands like cursor
movements while combinations with the Control key are for commands
that will modify the text.  Moe features multiple windows, unlimited
undo/redo, unlimited line length, global search and replace, and
more.")
    (license gpl2+)))
ulari <leo@famulari.name> Z572 2021-10-06gnu: quazip: Update to 1.1....* gnu/packages/compression.scm (quazip): Redefine as an heir to the… (quazip-0): …new name of the previous package definition. Adjust all packages with quazip as input to use quazip-0. Tobias Geerinckx-Rice 2021-09-20gnu: kdenlive: Use qt-build-system....* gnu/packages/kde.scm (kdenlive)[build-system]: Use qt-build-system. [arguments]<#:phases>: Do not wrap variables that are wrapped by qt-build-system in 'wrap-executable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Vinicius Monego 2021-09-20gnu: kdenlive: Update to 21.08.1....* gnu/packages/kde.scm (kdenlive): Update to 21.08.1. [inputs]: Order alphabetically. Use MLT 7. Add qtnetworkauth. Remove rttr. [arguments]<#:phases>: Don't return #t. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Vinicius Monego 2021-07-14Revert "gnu: kdeconnect: Fix wayland compatibility."...This is unneeded after 30759c4aadf279e470e8d7f94de332a31c1b9f42. This reverts commit f60ef2f7a46a00da40dc19af9d409781aa700a37. Efraim Flashner 2021-07-06gnu: mlt: Rename to mlt-6....* gnu/packages/video.scm (mlt): Rename to mlt-6. [build-system]: Use cmake-build-system. [arguments]: Remove #:make-flags. Adjust 'override-LDFLAGS phase. {#:configure-flags}: Remove --enable-gpl3 and --enable-gpl. Set "GTK2_GDKCONFIG_INCLUDE_DIR" and "GTK2_GLIBCONFIG_INCLUDE_DIR". (shotcut): Use mlt-6. * gnu/packages/animation.scm (synfig): Use mlt-6. * gnu/packages/kde.scm (kdenlive): Use mlt-6. This change is to add MLT 7 which will be done in the next commit. Signed-off-by: Leo Famulari <leo@famulari.name> Vinicius Monego 2021-06-25gnu: krita: Update to 4.4.5....* gnu/packages/kde.scm (krita): Update to 4.4.5. Tobias Geerinckx-Rice 2021-06-14gnu: Rename qtbase to qtbase-5....This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit. Maxim Cournoyer 2021-06-05gnu: qca: Update to 2.3.3....* gnu/packages/kde.scm (qca): Update to 2.3.3. Tobias Geerinckx-Rice 2021-05-05gnu: Add labplot....* gnu/packages/kde.scm (labplot): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vinicius Monego 2021-03-29gnu: krita: Update to 4.4.3....* gnu/packages/kde.scm (krita): Update to 4.4.3. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> la snesne 2021-03-11gnu: qca: Update to 2.3.2....* gnu/packages/kde.scm (qca): Update to 2.3.2. Tobias Geerinckx-Rice 2021-02-27gnu: Add massif-visualizer....* gnu/packages/kde.scm (massif-visualizer): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Alexandros Theodotou