aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages moe)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages compression)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public moe
  (package
    (name "moe")
    (version "1.14")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/moe/moe-"
                          version ".tar.lz"))
      (sha256
       (base32 "17cw43zsahisz5msqdv366np3zrdschgnm1lk1pm26dfw1nbvfpl"))))
    (build-system gnu-build-system)
    (native-inputs (list lzip))
    (inputs (list ncurses))
    (home-page "https://www.gnu.org/software/moe/moe.html")
    (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
    (description
     "GNU Moe is a powerful-but-simple-to-use text editor.  It works in a
modeless manner, and features an intuitive set of key-bindings that
assign a degree of severity to each key; for example, key
combinations with the Alt key are for harmless commands like cursor
movements while combinations with the Control key are for commands
that will modify the text.  Moe features multiple windows, unlimited
undo/redo, unlimited line length, global search and replace, and
more.")
    (license gpl2+)))
Bakke 2019-09-24gnu: Add mojoshader-with-viewport-flip....* gnu/packages/gl.scm (mojoshader-with-viewport-flip): New variable. Pierre Neidhardt 2019-09-24gnu: mojoshader: Broaden feature support (viewport flipping and depth clipping)....* gnu/packages/gl.scm (mojoshader)[arguments]: Build with FLIP_VIEWPORT and DEPTH_CLIPPING. Pierre Neidhardt 2019-09-24gnu: Add mojoshader....* gnu/packages/gl.scm (mojoshader): New variable. Pierre Neidhardt 2019-08-29gnu: mesa: Update to 19.1.5....* gnu/packages/gl.scm (mesa): Update to 19.1.5. Rutger Helling 2019-08-15gnu: mesa: Remove unnecessary inputs....* gnu/packages/gl.scm (mesa)[native-inputs]: Remove unnecessary inputs. Rutger Helling 2019-08-13Merge branch 'master' into core-updatesMarius Bakke 2019-08-07gnu: mesa: Update to 19.1.4....* gnu/packages/gl.scm (mesa): Update to 19.1.4. Marius Bakke 2019-08-05gnu: mesa: Enable Intel 32-bit Vulkan drivers....* gnu/packages/gl.scm (mesa)[arguments]: Also build Vulkan drivers for Intel on i686-linux. Rutger Helling 2019-07-31gnu: ftgl: Update to 2.4.0....* gnu/packages/gl.scm (ftgl): Update to 2.4.0. [home-page]: Change to maintained fork at <https://github.com/frankheckenbach/ftgl>. [source]: Change to GIT-FETCH. [native-inputs]: Add AUTOCONF, AUTOMAKE and LIBTOOL. Marius Bakke 2019-07-30gnu: glu: Update to 9.0.1....* gnu/packages/gl.scm (glu): Update to 9.0.1. Rutger Helling 2019-07-25gnu: mesa: Correct configure flag....* gnu/packages/gl.scm (mesa): Build the iris driver for the correct systems. Rutger Helling 2019-07-25gnu: mesa: Update to 19.1.3....* gnu/packages/gl.scm (mesa): Update to 19.1.3. [configure-flags]: Add iris to gallium-drivers. Rutger Helling 2019-07-07gnu: mesa: Use the "release" Meson build type....* gnu/packages/gl.scm (mesa)[arguments]: Add <#:build-type>. Marius Bakke 2019-06-29gnu: mesa: Do not pass an empty string argument to the build system....This is a follow-up to commit 301b2e74f986385664153e6e770e238b351f5cf0. * gnu/packages/gl.scm (mesa)[arguments]: Return the empty list instead of an empty string for the non-matching case. Marius Bakke 2019-06-29Merge branch 'master' into stagingMarius Bakke 2019-06-26gnu: Add mesa-opencl-icd....* gnu/packages/gl.scm (mesa-opencl-icd): New variable. Ricardo Wurmus 2019-06-26gnu: Add mesa-opencl....* gnu/packages/gl.scm (mesa-opencl): New variable. Ricardo Wurmus 2019-06-26gnu: mesa: Update to 19.1.1....* gnu/packages/gl.scm (mesa): Update to 19.1.1. [native-inputs]: Add glslang, vulkan-headers, vulkan-loader for i686-linux and x86_64-linux. [arguments]: Enable "-Dvulkan-overlay-layer" configuration flag for i686-linux and x86_64-linux. Rutger Helling 2019-06-11Merge branch 'master' into stagingMarius Bakke 2019-06-09gnu: virtualgl: Update to 2.6.2....* gnu/packages/gl.scm (virtualgl): Update to 2.6.2. Tobias Geerinckx-Rice 2019-06-05gnu: mesa: Disable failing test on i686....* gnu/packages/gl.scm (mesa)[arguments]: Add phase when building for i686. Marius Bakke 2019-06-05Merge branch 'master' into stagingMarius Bakke 2019-06-05gnu: soil: Update home page....* gnu/packages/gl.scm (soil)[home-page]: Use HTTPS. Marius Bakke 2019-06-05gnu: mesa-utils: Update home page....* gnu/packages/gl.scm (mesa-utils)[home-page]: Use HTTPS. Marius Bakke 2019-05-13gnu: mesa: Update to 19.0.4....* gnu/packages/gl.scm (mesa): Update to 19.0.4. Rutger Helling 2019-05-05gnu: mesa: Update gallium drivers....* gnu/packages/gl.scm (mesa)[arguments]: Update configure-flags for aarch64 and armhf for gallium drivers. Efraim Flashner 2019-05-04gnu: mesa: Update to 19.0.3....* gnu/packages/gl.scm (mesa): Update to 19.0.3. Marius Bakke 2019-04-29gnu: ftgl: Don't build libftgl.a....* gnu/packages/gl.scm (ftgl)[arguments]: Add "--disable-static" to #:configure-flags. Marius Bakke 2019-04-01Merge branch 'master' into stagingMarius Bakke 2019-03-31gnu: Fix descriptions to not use quotes....* gnu/packages/admin.scm (wpa-supplicant-minimal, mingetty, di), * gnu/packages/audio.scm (fil-plugins), * gnu/packages/base.scm (make-ld-wrapper, make-glibc-locales), * gnu/packages/bioinformatics.scm (r-samtools), * gnu/packages/chez.scm (chez-mit), * gnu/packages/commencement.scm (make-gcc-toolchain), * gnu/packages/compression.scm (fastjar), * gnu/packages/cran.scm (r-maps, r-rcpp), * gnu/packages/databases.scm (sparql-query), * gnu/packages/dunst.scm (dunst), * gnu/packages/ftp.scm (ncftp), * gnu/packages/gl.scm (freeglut), * gnu/packages/haskell-check.scm (ghc-tasty-golden), * gnu/packages/haskell.scm (ghc-case-insensitive, ghc-text, ghc-haskell-src, ghc-syb, ghc-deepseq-generics, ghc-network-uri, ghc-rerebase, ghc-zlib), * gnu/packages/image.scm (jbig2dec), * gnu/packages/kde-frameworks.scm (kinit, karchive), * gnu/packages/linux.scm (wireless-tools, perf, module-init-tools, kbd), * gnu/packages/lirc.scm (lirc), * gnu/packages/lisp.scm (uglify-js), * gnu/packages/mate.scm (mate-netbook), * gnu/packages/microcom.scm (microcom), * gnu/packages/music.scm (bristol), * gnu/packages/networking.scm (perl-geo-ip), * gnu/packages/patchutils.scm (patches), * gnu/packages/perl-check.scm (perl-test-more-utf8), * gnu/packages/perl.scm (perl-log-report-optional, perl-file-which, perl-io-tty, perl-log-any, perl-digest-sha1, perl-class-load, perl-regexp-common, perl-module-pluggable, perl-class-modifier), * gnu/packages/python-xyz.scm (python-backports-abc, python-natsort), * gnu/packages/samba.scm (iniparser), * gnu/packages/search.scm (mlocate), * gnu/packages/spice.scm (spice), * gnu/packages/statistics.scm (r-dt, r-lubridate, r-estimability, r-commonmark, r-digest, r-viridislite, r-stringr), * gnu/packages/tex.scm (texlive-latex-changebar), * gnu/packages/version-control.scm (subversion), * gnu/packages/w3m.scm (w3m), * gnu/packages/web.scm (perl-http-parser, perl-plack-middleware-reverseproxy), * gnu/packages/xorg.scm (xkeyboard-config, mkfontdir, xcursor-theme, mkfontscale, xinit, font-alias)[description]: Use @code instead of quotes. Efraim Flashner