aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
3-04-19gnu: Add python-hatch-vcs....* gnu/packages/python-build.scm (python-hatch-vcs): New variable. Maxim Cournoyer 2023-04-19gnu: python-hatchling: Update to 1.14.0....* gnu/packages/python-build.scm (python-hatchling): Update to 1.14.0. [arguments]: Replace do-not-depend-on-hatchling phase with add-src-to-path. [description]: Expound. Maxim Cournoyer 2023-04-19gnu: python-hatchling: Move to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-hatchling): Move to... * gnu/packages/python-build.scm (python-hatchling): ... here. Maxim Cournoyer 2023-04-19gnu: python-flit-scm: Update to 1.7.0....* gnu/packages/python-build.scm (python-flit-scm): Update to 1.7.0. [build-system]: Use pyproject-build-system. [arguments]: Remove #:phases. Add #:build-backend. [native-inputs]: Delete field. Maxim Cournoyer 2023-04-19gnu: python-setuptools-scm: Update to 7.1.0....* gnu/packages/python-build.scm (python-setuptools-scm): Update to 7.1.0. [arguments]: Disable tests. [propagated-inputs]: Add python-typing-extensions. Remove input labels. Maxim Cournoyer 2023-04-19gnu: python-typing-extensions: Move to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-typing-extensions): Move to... * gnu/packages/python-build.scm (python-typing-extensions): ... here. Maxim Cournoyer 2023-04-19gnu: python-flit-core-bootstrap: Update to 3.8.0....* gnu/packages/python-build.scm (python-flit-core-bootstrap): Update to 3.8.0. [home-page]: Update URL. Maxim Cournoyer 2023-04-19gnu: python-poetry-core: Update to 1.5.2....* gnu/packages/python-build.scm (python-poetry-core): Update to 1.5.2. [source]: Adjust URL. [build-system]: Use pyproject-build-system. [arguments]: New field. Maxim Cournoyer 2023-04-19gnu: python-pep517-bootstrap: Add TODO comment....* gnu/packages/python-build.scm (python-pep517-bootstrap): Add TODO comment. Maxim Cournoyer 2023-04-19gnu: python-wheel: Update to 0.40.0....* gnu/packages/python-build.scm (python-wheel): Update to 0.40.0. [home-page]: Update URL. Maxim Cournoyer 2023-04-19gnu: python-setuptools: Update to 67.6.1....* gnu/packages/python-build.scm (python-setuptools): Update to 67.6.1. Maxim Cournoyer 2023-04-19gnu: python-pip: Update to 23.1....* gnu/packages/python-build.scm (python-pip): Update to 23.1. Maxim Cournoyer 2023-04-19gnu: python-tomli-w: Use pyproject-build-system....* gnu/packages/python-build.scm (python-tomli-w) [build-system]: Use pyproject-build-system. [arguments]: Remove #:phases arguments. Maxim Cournoyer 2023-04-19gnu: python-tomli: Update to 2.0.1....* gnu/packages/python-build.scm (python-tomli): Update to 2.0.1. [build-system]: Use pyproject-build-system. [arguments]: Remove build and install phase overrides. Add add-self-to-path. [native-inputs]: Remove python-pypa-build and input labels. Maxim Cournoyer 2023-04-19gnu: python-pathspec: Update to 0.11.1....* gnu/packages/python-build.scm (python-pathspec): Update to 0.11.1. [home-page]: Update URL. Maxim Cournoyer 2023-04-19gnu: Add python-trove-classifiers....* gnu/packages/python-build.scm (python-trove-classifiers): New variable. Maxim Cournoyer 2023-04-19gnu: python-xyz: Move some packages to (gnu packages python-build)....This is to prepare for the new 'python-hatchling' build package, which has these dependencies. * gnu/packages/python-xyz.scm (python-pathspec, python-pluggy): Move to... * gnu/packages/python-build.scm: ... here. Re-organize definitions a bit, with comments. Maxim Cournoyer